Some snap apps do not open

Hi there!

I installed Manjaro Gnome on my laptop as default OS. I have two M2 SSDs and replace the original with Windows for a new one with Manjaro, and use the Windows SSD with a SSD to USB adapter. I’m not sure if my installation/setup was perfect because I cannot change the os to the another one easily.

In another hand, I worked with my company PC in Manjaro for a couples years and had no problem with snap/flatpak apps. Today I cannot open some snap apps and I really think I did not do anything weird to install them. The behavior of each of these apps is the following:

  • I click on the app or open through the terminal with snap run [app] or directly with the name of the app [app]
  • The app seems is loading but after some seconds (like 20-30) nothing happens, the loader at the left-upper corner disappear and the terminal did not show anything, no message error or log to guess the problem.

I read another topics like this but I followed step by step that I can see and my problems persist, everything seems good for my site but certain apps does not work. The list of the apps is bellow:

  • slack 4.34.120
  • opera 103.0.4928.26

I used using both apps in my company pc with no problems, so I think the issue could be on my OS version/Kernel version/ snap setup. Thus I let you some info about my system and hope this could be useful for you can help me:


AMD Ryzen 7 3700U with Radeon Vega Mobile Gfx
x86_64 arch


Kernel: 6.5.5-1-MANJARO (linux65)

When I ran sudo systemctl status snapd I had the following results:

I hope you can help me!

What is the output when you run the app through terminal?

The snapd status output seems to be normal. I have something like that too and snaps are working.

1 Like

Hi @michaldybczak, thansk for the fast answer, sorry for my late, I was very busy this week!

When I run the app through the terminal I se literally nothing, the termial does not show any message or log, I let you an example of both cases (Slack and Opera):

As you can see, slack close directly with no message and Opera keeps running with no response. When I clicked over these I can see a loader for a second but nothing happens after that.


If you need another info please let me know. Thank you!

This doesn’t look right.

I checked my apps and I get often output like this:

snap run clickup
Gtk-Message: 22:07:42.674: Failed to load module "xapp-gtk3-module"
Gtk-Message: 22:07:42.680: Failed to load module "appmenu-gtk-module"
Gtk-Message: 22:07:42.751: Failed to load module "colorreload-gtk-module"
Gtk-Message: 22:07:42.751: Failed to load module "window-decorations-gtk-module"
Gtk-Message: 22:07:42.751: Failed to load module "appmenu-gtk-module"

I found one app, that behaved like yours, so I decided to reinstall it. I removed it and it turned out that it changed channel and after installing it anew, it started behaving like the others one. See my terminal output:

 michaldybczak  alienware-PC  ~  snap run fluent-reader

 michaldybczak  alienware-PC  ~  snap remove fluent-reader
fluent-reader removed

 michaldybczak  alienware-PC  ~  snap install fluent-reader
error: snap "fluent-reader" is not available on stable but is available to install on the following

       candidate  snap install --candidate fluent-reader
       beta       snap install --beta fluent-reader
       edge       snap install --edge fluent-reader

       Please be mindful pre-release channels may include features not completely tested or
       implemented. Get more information with 'snap info fluent-reader'.

 michaldybczak  alienware-PC  ~  snap install --beta fluent-reader
fluent-reader (beta) 0.7.4 from No Name Pro (nonamepro0) installed

 michaldybczak  alienware-PC  ~  snap run fluent-reader
Gtk-Message: 22:12:53.656: Failed to load module "xapp-gtk3-module"
Gtk-Message: 22:12:53.700: Failed to load module "appmenu-gtk-module"
Gtk-Message: 22:12:53.900: Failed to load module "colorreload-gtk-module"
Gtk-Message: 22:12:53.900: Failed to load module "window-decorations-gtk-module"
Gtk-Message: 22:12:53.901: Failed to load module "appmenu-gtk-module"
(electron) Security Warning: A WebContents was just created with both webviewTag and contextIsolation enabled.  This combination is fundamentally less secure and effectively bypasses the protections of contextIsolation.  We strongly recommend you move away from webviews to OOPIF or BrowserView in order for your app to be more secure

I believe something similar maid have happened to you, so you need to reinstall the apps that misbehave. I noticed that snap apps sometimes break and need reinstallation.

Hi again @michaldybczak, I tried to do that you suggested me but It did not work for me, I ran the both apps before uninstall them, then I uninstalled and reinstalled both apps and I ran them again but everything looks like before. I attach photos so you can see the processes:


I was able to see that snap has a some flags to debugging the run process, so I use snap run --debug-log opera command then I searched the word ‘error’ in all logs and find only one line that have a message error, this said that logger.go:92: DEBUG: mount name:"/run/user/1000/doc/by-app/snap.opera" dir:"/run/user/1000/doc" type:"none" opts:MS_BIND unparsed:"" (error: <nil>). After that I went to the file and found that the /doc/ folder is not a casual folder and It was empty, so idk if the error was here effectively.

Please copy and paste terminal output using preformatted text instead of uploading screenshots of text.

Each image uploaded to the server makes forum database backups larger. Search engines cannot read screenshots and one cannot copy and paste from them without an OCR program.

Please edit your post accordingly.

1 Like

Something unusual is happening on your computer. Log in to a test vanilla user (if not present, create one) and install those snap apps there, and see if the issue is happening. If not, some user config is at fault and you need to track it down and delete it. If the issue is happening, beats me :frowning: It can be anything, from config on root, AUR package messing with snaps, conflicting or incorrect root configs, including mounting, some file corruptions, disc issues…

Since you are on Manjaro, I would suggest to use Slack or Opera from AUR, although it still doesn’t resolve snap issues.

Opera is in the repo.