Some keys on my keyboard type multiple characters

For example when i type:
1 → '1
2 → 2 + F1
4 → 54
5 → 54
6 → 67
7 → 67
8 → =8
0 → -0
= → =8
LCtrl → LCtrl + F5

i dont know if this is a problem with my keyboard, the drivers, or manjaro
i already tried restarting, unplugging then plugging my keyboard but it didnt seem to help

That could be a keyboard issue, but maybe a misconfiguration? What is your current configuration for your keyboard?

Probably output of localectl status should be sufficient.

//EDIT: also, testing the keyboard from a live environment on USB could help diagnose if the issue is reproducible on various other systems (try other OS if possible, but simply a Manjaro ISO could also do the trick for testing).

Either you have a (weird) keybinding, or a faulty keyboard.

Check that documentation to help you diagnose:

it didnt happen on windows 10 but when i got back in manjaro it started happening some times instead of all the time like before, i have no idea of whats going on

also, here is the output of localectl status:

   System Locale: LANG=en_US.UTF-8
       VC Keymap: br-abnt2
      X11 Layout: br

Is that all the output? Mine has more (System Locale / VC Keymap / X11 Layout / X11 Model / X11 Variant). Also while you’re at it, give output of inxi -Fazy

ok so i restarted my computer more
and now it stopped so i guess that solved the problem (???)
anyways sorry for wasting your time

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.