Some keyboard keys don't work after updating

After an update some keys doesn’t work such as shift, t and y, num lock, backspace, tab, some function keys…

  Kernel: 5.10.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64
  root=UUID=8b41ce60-189a-4d34-8bcf-3d96cbdbe24a rw quiet apparmor=1
  security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.22.5 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
  Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: LENOVO product: 81FB v: Lenovo ideapad 330S-15ARR
  serial: <filter> Chassis: type: 10 v: Lenovo ideapad 330S-15ARR
  serial: <filter>
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40709WIN serial: <filter>
  UEFI: LENOVO v: 7WCN37WW date: 05/22/2019
  ID-1: BAT1 charge: 4.2 Wh (18.5%) condition: 22.7/30.0 Wh (75.5%) volts: 6.9
  min: 7.4 model: LENOVO BASE-BAT type: Li-poly serial: <filter>
  status: Discharging cycles: 1843
  RAM: total: 6.74 GiB used: 3.31 GiB (49.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges required.
  Info: Quad Core model: AMD Ryzen 5 2500U with Radeon Vega Mobile Gfx
  bits: 64 type: MT MCP arch: Zen family: 17 (23) model-id: 11 (17)
  stepping: 0 microcode: 810100B cache: L2: 2 MiB bogomips: 31949
  Speed: 1593 MHz min/max: 1600/2000 MHz boost: enabled Core speeds (MHz):
  1: 1593 2: 1541 3: 1367 4: 1366 5: 1471 6: 1595 7: 1434 8: 1366
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
  bmi2 bpext clflush clflushopt clzero cmov cmp_legacy constant_tsc cpb cpuid
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb irperf lahf_lm lbrv lm mca
  mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx nonstop_tsc nopl
  npt nrip_save nx osvw overflow_recov pae pat pausefilter pclmulqdq pdpe1gb
  perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni popcnt pse pse36
  rdrand rdseed rdtscp rep_good sep sev sev_es sha_ni skinit smap smca sme
  smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 succor svm svm_lock syscall tce
  topoext tsc tsc_scale v_vmsave_vmload vgif vmcb_clean vme vmmcall wdt
  xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities: Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
  disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Raven Ridge [Radeon Vega Series / Radeon Vega Mobile Series]
  vendor: Lenovo driver: amdgpu v: kernel bus-ID: 03:00.0 chip-ID: 1002:15dd
  class-ID: 0300
  Device-2: Acer Integrated Camera type: USB driver: uvcvideo bus-ID: 3-1:2
  chip-ID: 5986:2115 class-ID: 0e02
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver:
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa
  display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2")
  s-diag: 582mm (22.9")
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 142 size: 344x193mm (13.5x7.6")
  diag: 394mm (15.5")
  OpenGL: renderer: AMD Radeon Vega 8 Graphics (RAVEN DRM 3.40.0
  5.10.70-1-MANJARO LLVM 12.0.1)
  v: 4.6 Mesa 21.2.3 direct render: Yes
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio vendor: Lenovo
  driver: snd_hda_intel v: kernel bus-ID: 03:00.1 chip-ID: 1002:15de
  class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor driver: N/A
  alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 03:00.5
  chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel
  v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.70-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.38 running: no
  Device-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
  vendor: Lenovo driver: ath10k_pci v: kernel bus-ID: 01:00.0
  chip-ID: 168c:0042 class-ID: 0280
  IF: wlp1s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
  broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 3-2:3
  chip-ID: 0cf3:e500 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
  rfk-block: hardware: no software: yes address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 119.24 GiB used: 89.83 GiB (75.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Samsung model: MZ7LN128HAHQ-000L2
  size: 119.24 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: SSD serial: <filter> rev: 4L0Q scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 118.95 GiB size: 116.52 GiB (97.96%)
  used: 89.83 GiB (77.1%) fs: ext4 dev: /dev/sda2 maj-min: 8:2 label: N/A
  uuid: 8b41ce60-189a-4d34-8bcf-3d96cbdbe24a
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 296 KiB (0.1%) fs: vfat dev: /dev/sda1 maj-min: 8:1 label: NO_LABEL
  uuid: 9288-FBC5
  Alert: No swap data was found.
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-3:11 info: Microsoft USB Keyboard type: Keyboard
  driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
  power: 70mA chip-ID: 045e:078c class-ID: 0301
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 4 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 2 rev: 2.0
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:2 info: Acer Integrated Camera type: Video driver: uvcvideo
  interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:2115
  class-ID: 0e02
  Device-2: 3-2:3 info: Qualcomm Atheros type: Bluetooth driver: btusb
  interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e500
  class-ID: e001
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 1 rev: 3.1 speed: 10 Gb/s
  chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 54.6 C mobo: N/A gpu: amdgpu temp: 54.0 C
  Fan Speeds (RPM): N/A
  Processes: 248 Uptime: 1h 43m wakeups: 20 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1438 lib: 393
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: konsole inxi: 3.3.07

What should I do?

Microsoft USB Keyboard

Oh, that’s why! But you installed GNU/Linux.
Just kidding.

Check keyboard type settings:
Meta / Super → System settings → (Hardware) Input devices → Keyboard → Try to switch different keyboard models from the list.

If not:

I see you are using kernel of the 5.10-family. Consider to try other kernel:
5.13 (soon (in a few weeks) will be dropped by Manjaro as it is end-of-new-patches (EoL) already),
5.15 (it is currently in beta version (public testing stage)).

May be other people have better ideas to suggest.

1 Like


That’s an old keyboard that I plug to use my laptop. The external keyboard work just fine but the laptop keyboard is the one with the problem .

I tried installing 5.4, 5.13 and 5.14 kernel, none of the three solved the problem. Something I notice is that with the kernel 5.10 the keyboard and the mouse(I also plug a mouse, but don’t worry this isn’t from microsoft :joy:) stop working after a while like they weren’t connected, but with 5.13 it works perfectly.

I also try changing the keyboard model, didn’t work either. I don’t know if I try enough models but with the ones I tried didn’t work.

Thanks for answering me😁.

OK, but be careful: I heard a cases when if keyboard and mouse are from MS, then sometimes Win11 updates can reach your machine and to turn into a new Winduser :slight_smile:

Hm, even other keyboard also not as good as supposed to be?

Forgot to try keyboard settings mode/model? They are also available here:
Start btn-> Manjaro Settings ManagerKeyboard settings

Also try to review
Start btn-> Manjaro Settings ManagerHardware configuration: show all devices, auto-install open-source driver, etc.

Ran out of ideas.

Suggest to search in Internet search engines:
arch linux usb microsoft keyboard some keys does not work after update,
your variations.

Wait, wait, wait. I am half-sleeping now.
Kernel of 5.13 version solves the problem fully - all keyboard keys works, but 5.4, 5.10 and a bit newer 5.14 has the issue described in initial post?
To run a just installed kernel PC should be rebooted and a kernel version should be chosen at boot time.
Are you sure that after every kernel version installation you did a reboot and chose another kernel version?

Please try 5.15 generation, but before to do it wait a bit (probably a couple of days): Manjaro - Branch Compare
Make the linux515 query there.
See different branches there?

The rc3 in in your stable updates branch now. Try to wait it at least until the rc5 reaches the stable. I expect it to be in stable version on about Tuesday. The greater the number the more stable/fixed kernel is, rc5+ probably will be in a couple of days in stable, do not try rc3 just in case.

Although this is stating the obvious, hardware does fail, keyboards included.
I have had this happen more than once.

To rule that out and to check whether the failing keyboard keys just coincided with the update you connect it to
you could boot your installation medium - or any other live linux installer
and check whether the keyboard works there.

… maybe it is actually broken …
but even a laptop keyboard can be swapped fairly easily should this be the case

1 Like