Some issues I've been having and looking for some help

I just installed Manjaro, again… I was distro hopping okay. And now that I installed it again I find that some hotkeys I set just flat out aren’t working. For example I set meta+alt+s to open pamac and it worked before but not this time. Another weird thing is I could’ve sworn there was an option to switch user at the lock screen but that’s no longer there. Everything else seems find and I’m really just curious if anyone else is running into these problems and if there’s anything I could do to fix some of this. Thanks in advance

Are you on kde, xfce, or another distro?

1 Like

I’m on KDE, I tagged the thread plasma to see if other KDE users were experiencing this

I just saw the tag. I had the same problem with the user login screen on KDE. It was a fresh install for me, so a reinstall took care of it. I hope you find a solution

1 Like

I’d like to avoid just reinstalling the whole system so I’m gonna keep looking for a solution. Thank you

Does this mean you were preserving /home across these installs or similar?
Or just that hotkeys dont work the same way on this fresh install ?

Hot keys aren’t working the same on this fresh install

How did you create them exactly?
What command/execution/path are you setting?
(ex pamac GUI is pamac-manager)

before I set them through KDE’s system settings -> shortcuts -> global shortcuts -> and bobs your uncle. but on this fresh install I do the same thing with the same keys and it just doesn’t work. Do you know if there’s a log I can look at somewhere to see if there’s an error?

Command Log: journalctl -S today (plasma is super verbose)
GUI Log: Menu -> System -> ksystemlog
Core dump: coredumpctl - look for kglobalaccel5
Config file: ~/.config/kglobalshortcutsrc - grep -ib1 _launch | less

I tried this and the global shortcut didn’t work either. There are current hits for global access keys at bugs.kde.org (product=frameworks-kglobalaccel or Product: systemsettings
Component: kcm_keys). I haven’t narrowed it down.

Update:
This might be the one:421329 – New Global Shortcuts KCM: shortcuts to launch 3rd-party apps don't work

Which is discussed here, according to comment #21.

First I updated manjaro, pacman -Syu.
I looked at kinfocenter to get the versions of plasma, framework and Qt, before and after.
I also looked at the file /etc/lsb-release, before and after.
Although plasma framework was updated, I did it more as a matter of standard procedure.

To make a long story short, until plasma fix is in the update, a work around is:

  1. Go to Global Shortcuts
  2. Remove your current shortcut by clicking the “x” next to the Application name.
  3. Close Global Shortcuts
  4. mkdir --parents ~/.local/share/kglobalaccel
  5. Go to Global Shortcuts and add your Application and shortcut key and Apply.

If you look in ~/.local/share/kglobalaccel there should now be a file
org.manjaro.pamac.manager.desktop. This is for Add/Remove Software.

The above procedure could be done in multiple ways, but I know the above works. Any new shortcuts should be okay now, because the directory exists, and you know where to look :wink:
It seems they are still working on what direction to go.

Doing a locate on that file name, it is located /usr/share/applications/. locate is part of the mlocate package and is updated via the command updatedb. The update should be automatic, but it can be run at anytime with sudo.

find is another useful command. I have an alias f1 in my .bashrc file that is
alias f1='find -newermt "1 minute ago"'. If I make a configuration change I’ll run that command to see what config files were modified.

2 Likes

Lock screen or Login screen…

If login screen:
At the bottom of the login window there are 4 buttons, the last being “Different User”. Click it.
This screen is going to be different based on Display Manager - Login Screen (SDDM), which is in Startup and Shutdown module. The one I described is Breath (0.2.0). Otherwise just type the user_id and password. It’s an option to have users displayed on the greeting screen. Check out /etc/sddm.conf and/or /etc/sddm.conf.d/kde_settings.conf.

There’s an option in the menu under Power/Session to switch user.

If lock screen:
Someone just asked this question on the kde forum. They have a nice image showing how it use to look. Unfortunately no answer yet. I can’t test this.

1 Like

Thanks so much for the detailed reply. I will go through the steps you’ve given to try to fix my shortcuts, looks like I’ll have to wait for the lock screen to get fixed though

Try to change your keyboard layout to something else. I use a lat-dead-tilde, and the tide was not working. So, I change to another Spanish layout, I tested and the key works, then I return to the correct layout and the problem was gone.

Regards.

Discussion and comments at
-bugs.archlinux.org/task/67623#comment191966- seem to indicate that there is a bug in systemd.

I also have this problem- No “switch user” in Power/Session menu and no button in lock screen to “switch user” as mentioned at -
-forum.kde.org/viewtopic.php?f=289&t=167448&p=436179&hilit=switch+user+lock#p436179

It seems we will have to wait until it is fixed or downgrade as mentioned in the first link above.
:slightly_frowning_face:

1 Like

Hi everyone!!
I’m new to Linux and really like manjaro. Everything is working great.
The only problem I’m having is with jDownloader. I can access my network folders using files viewer, I can also access them through the web browser using smb. For some reason, jDownloader can’t see my Synology network folders. I’ve been trying to solve this issue for almost two weeks.

Thanks

The Lock Screen widget can be configured to have Switch User functionality. Unfortunately, you end up with two additional icons: lock screen and switch user. I had to add the widget for now as I found no other way to switch users.