Some Flatpak applications not launching

Edit (a few days later): I just updated OSU! (the only available update) and that updated a bunch of Nvidia stuff, and it did take a while. However, after the Nvidia stuff was upgraded, it updated OSU! and now all Flatpaks work again?? It’s just like the last time this happened. Why do Flatpaks break after some updates??

So I just updated my system, which I do update frequently, but now some Flatpak applications don’t launch, such as Blender, Kdenlive and OSU!. Neiter does OBS, but it gives this error message and nothing more:

My system is up to date, and I’ve not messed with Nvidia drivers. This has happened earlier one time, but then I think a update for the Nvidia drivers or something came and everything just worked again, so it was only for a very short time like this. Non-Flatpaks run fine, such as Blender from Manjaro repos. I also tested Terraria on Steam and it worked just fine too. However, some Flatpaks run fine too, like Audacity. But I guess it’s because it doesn’t require something that makes the other applications break.

This is what the applications say when trying to launch them:

Also included that last thing there because why not.

I saw someone ask to run this command in some random thread I saw so I’m putting it here:

inxi -Gx                                                                                                                                     ✔ 
  Device-1: NVIDIA TU104 [GeForce RTX 2060] vendor: ASUSTeK driver: nvidia
    v: 510.73.05 arch: Turing bus-ID: 26:00.0
  Display: x11 server: X.Org v: 21.1.3 driver: X: loaded: nvidia
    gpu: nvidia resolution: 1: 2560x1440 2: N/A
  OpenGL: renderer: NVIDIA GeForce RTX 2060/PCIe/SSE2
    v: 4.6.0 NVIDIA 510.73.05 direct render: Yes

So, is there any fix for this? And why is this a thing? Thanks.