Some apps fall to coredump, guess because of gpu != nvidia

When pasting terminal output, add three backticks ` OR 3 tilde ~ above and below the text:

text

I did it this time for you. Please do it like this in the future.

Thank you :bowing_man:

1 Like

you dont even have nvidia hardware … you can try install the modesetting driver and see:
sudo mhwd -i pci video-modesetting
reboot

did it, the same

Well the system runs at 800Mhz all the the time due powersave governor. Set it on conservative for example:

sudo cpupower frequency-set -g conservative 

That will choose the lowest frequency as possible to save energy but clock up if needed.

$ sudo cpupower frequency-set -g conservative 
Setting cpu: 0
Error setting new values. Common errors:
- Do you have proper administration rights? (super-user?)
- Is the governor you requested available and modprobed?
- Trying to set an invalid policy?
- Trying to set a specific frequency, but userspace governor is not available,
   for example because of hardware which cannot be set to a specific frequency
   or because the userspace governor isn't loaded?
sudo cpupower frequency-info

:question:

$ sudo cpupower frequency-info
analyzing CPU 0:
  driver: intel_pstate
  CPUs which run at the same hardware frequency: 0
  CPUs which need to have their frequency coordinated by software: 0
  maximum transition latency:  Cannot determine or is not supported.
  hardware limits: 800 MHz - 3.50 GHz
  available cpufreq governors: performance powersave
  current policy: frequency should be within 800 MHz and 3.50 GHz.
                  The governor "powersave" may decide which speed to use
                  within this range.
  current CPU frequency: Unable to call hardware
  current CPU frequency: 1.43 GHz (asserted by call to kernel)
  boost state support:
    Supported: yes
    Active: yes

only powersave and performence available? :rofl:

That might because of this new driver:

Let me check, what can be done.

How is it correlated to

FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn't usable.

or edrawmind failing to start web-browser

Core was generated by `/opt/EdrawMind-9/libexec/QtWebEngineProcess --type=renderer --disable-a'.

The iGPU scales like the CPU governor says.But you can disable that, if you want. So both CPU and GPU run at powersave mode.

Sorry I am stupid and dont understand here if “I want” :slight_smile:

how to disable it for check?

Ok, you need create this file as root with an editor of your chose and add the options. Then reboot.

file: /etc/modprobe.d/20-intel.conf

options i915 enable_psr=0
options i915 enable_dc=0
options i915 enable_fbc=0
options i915 verbose_state_checks=Y
options i915 mitigations=off

More information:

modinfo i915

didn’t help (

first navigate to /etc/modprobe.d and check if the file with the options is there, if yes run this:
sudo mkinitcpio -P
then reboot

Ok I tried that app pomotroid, and it crash on NVIDIA as well. So must be some sort of bug.

but he doesnt have nvidia … maybe its just a pomotroid bug?

Yeah that is what I am saying. Maybe a newer/older library which is incompatible.

i try also running pomotroid, it crashes…

ah…
and can you try edrawmind-bin then too?

because two of them forced me to think it is something system dependand
just install and click sign in