Some app is preventing me to change the display resolution on a VMWare guest

Hello community!

I just installed a new version of Manjaro KDE 21.0.7 on a VMware Fusion version 12.1.2. The installation came very well and I also installed all the updates.
After that I ran Pamac app and searched for “vmware”. It showed "xf86-video-vmware 13.3.0-2. I downloaded, installed and rebooted the virtual machine.

When I go to the Display Configuration, it shows as a display Virtual1 at 800x600. I click to select another resolution it changes it but drops it almost instantly and gives this message.

KWin Windows Manger
Desktop effects have been suspended by another application.
You can resume using the ‘Alt+Shift+F12’ shortcut.

I also noticed 3 notifications:
Compositing has been suspended - Another application has requested to suspend compositing.
Graphics Reset - A graphics reset event occurred.
Xwayland Crash - Xwayland has crashed.

I know there is a VMware Tool option to install right from the VMware Fusion, but it doesn’t install.

I used the method above before in other Manjaro versions and it worked.

Please, if somebody can help me I thank in advance.

From what I could find here in the Forum, there are some issues with KDE Plasma, PaMac and wayland.

Read this: Pamac 10.1.3-3 rendering issue (gtk3-nocsd related? Confirmed on KDE and Xfce, Nvidia and Intel GPU)

I have not read all posts but it looks like some time will be required until fix.

  1. Wayland and KDE are not working together well yet.
  2. VMWare and hardware acceleration are not working together well yet.
  3. Arch (And thus Manjaro) is not officially supported by VMWare

So turn #1 and #2 off and you’ll have a happier environment, and keep to LTS kernels only!


Please, can you tell me how to turn off Wayland?
I have not found an online explanation on how to do that, even in this forum.
The only explanation I found is to edit gmd/gdm3 custon.conf file but there is no gdm or gdm3 directory in /etc.

That is a completely new question unrelated to your original one (to which I don’t know the answer except: reinstall from scratch) so search for “Replace Wayland with Xorg” and if you can’t find anything either, create a new topic.

Therefore, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

1 Like

By typing in Terminal:


it returned X11

I saw a video that Ubunto users logoff their account and on the login screen have a gear icon, there they can choose a Wayland or Xorg session.

Any new idea?

Where does this come from then???


This is from a notification I receive when I try to change screen resolution.

Sorry, but I don’t know anything about Wayland except it’s a Gnome experimental display server, so unfortunately, I can’t help you any further…


1 Like

I just watched a video that explain “How To Generate xorg.conf In elementaryOS Luna or Ubuntu” from youtube.
He is using a VirtualBox and Ubuntu. I’m using VMware and Manjaro KDE 21.0.7, but I think it is a good explanation and may apply to my problem.

6 months ago I bought a Raspberry Pi 4 with 8GB and testing many Linux Distros for it, I really liked Manjaro. So I installed it on VMware machine at the time. I think it was version 19.X.X. it worked flawlessly on both Raspberry Pi and the VMware machine.

I don’t recall if I tested version 20.X.X but this version 21.X.X had many changes and something is forcing the 800x600 resolution in the VMware. I also installed VirtualBox and it has the same 800x600 limitation.

My point it is not a problem with a VM software or another, I still think it is hooked to the changes on the 21.X.X of Manjaro.

I installed Manjaro KDE 21.0.7 on my PC with a Radeon RX570 8GB a it works beautifully. I don’t need Manjaro there, it is my Game PC and for that “debloated” Windows 10 is fine for that.

I want to have Manjaro on my VMware because it sits on my Macbook Pro, that is my work machine.

You helped a lot because it is chatting that we can reach solutions.

Just my two cents.

I installed the same Manjaro version (KDE 21.0.7). By default it is not going to use Wayland. I updated the system (so now it is 21.1) and after that installed open-vm-tools package and enable it with:

sudo systemctl enable --now vmtoolsd

And right away it detected VMWare’s windows resolution and changed to it.

PS: I also restarted the computer when necessary.

Ok. I spoke too fast. After restarting the virtual machine I wasn’t able to change the resolution anymore through KDE settings… BUT I found a command to change it: vmwgfxctrl (it is part of open-vm-tools)

To see current profile and possible resolution modes:

vmwgfxctrl --print-topology

To set the desired resolution (i.e. 1440x900):

sudo vmwgfxctrl --set-topology 1440x900+0+0

To get help:

vmwgfxctrl --help

I think it should be possible to make this automatic but I haven’t found yet how.

Edit: I have an older VM (20.2) that works correctly. If I update it, it stills detects window size and adapts to it. I haven’t been able still to found any difference with the newer vm. Same open-vm-tools package, same modules, same service (vmtoolsd).

Edit 2: After some debugging, I found out some interesting and little odd thing. I use VMWare Workstation Pro, and I have to disable “Stretch mode” in VM settings > Hardware > Display. Also I have to set at least 4 cores to autoresize to work correctly. Now everything works fine for me.

I made all the updates to the system. And Rebooted.

I typed in terminal:
sudo systemctl enable --now vmtoolsd

I got this answer:
Failed enable unit: Unit file vmtoolsd.service does not exist.

bash: vmwgfxctrl: command not found.

Have you installed open-vm-tools package? The service and the command are part of it. Also you have to have the system updated (them vmwgfx command is a new addition).

Anyway read the edits in my previous message, as I managed to make autoresize to work.

I got this:

Failed to enable unit: Unit file vmtoolsd.service does not exist.

As terminal I’m using Konsole in bash.

I already asked, but anyway… You have to install open-vm-tools package. That service and vmwgfxctrl are part of it.

Do you mean the one that comes in the VMware menu?

No. Inside the virtual machine:

pamac install open-vm-tools
1 Like