[SOLVED] Zsh prompt problem/error after update


I have the same problem (I updated my system via sudo pacman -Syu last night). Tried this solution, but after running sudo locale-gen nothing happens:

Generating locales...
Generation complete.

Then I checked on “Language & region” option in GNOME Shell configuration, and language list (with default set to Spanish before update) is now empty!

How can i recover my language list?

Welcome to the forum @daniloquispe :wave:

Consider subscribing to the Stable Updates Announcements RSS feed

Check out the guide below, you need to find the right locale for spanish in
/etc/locale.gen remove the # before the line that you need and then run sudo locale-gen There are more options them I em used to, you probably just need one line un-commented.

You tried which solution?
This one?

He (or you) should have taken more care and should have written this instead:
sudo echo en_US.UTF-8 UTF-8 >> /etc/locale.gen && sudo locale-gen

Then you’d still have your locale file.
Now you have one which only contains US english. :roll_eyes:

See if you still have it:
sudo nano /etc/locale.gen
uncomment the locale you want (remove the hash mark → #)
then run:
sudo locale-gen


The "uncomment line in /etc/locale.gen worked. Thanks @Hanzel and @Nachlese!

But this is still weird for me… I have a second PC with Manjaro (laptop), also with “Spanish (Peru)” language set. I didn’t update system yet, and I checked /etc/locale.gen file and all lines in file are commented. So, why is my Spanish language configuration working fine in my laptop (non-upgraded) but lost in my mail PC (just upgraded)?

Glad you are up and runing again :smiley:

I’m not able to explain that situation, but when you have the same issue, you know what to do to fix it.

Well, that’s right. At least I learned a new trick today, hehe :wink:

Thanks again!

1 Like

It probably has been replaced/overwritten - well, not probably, but rather: obviously
… which shouldn’t have happened.

As soon as the package “glibc” is updated, the command “locale-gen” is run.
If the file is pristine - like new, with everything commented - you’ll lose your locale setting in that moment.
… check that file in your other computer and uncomment what you need so the next update of glibc will not harm you
perhaps make a backup of that file
sudo cp /etc/locale.gen /etc/locale.gen.original

Why this happened? I don’t know.
But it hit many - the forum is full of it.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.