[Solved] Xfce : Small but annoying problem with 3 screens

This question has already been on forum.xfce.org (not answered), sorry for duplicating

Hi,

I'm running Manjaro 18.1.1 / Xfce 4.14, on a Thinkpad E580.

Everything's nice and sexy when the laptop is "alone". Love it ! :smiling_face_with_three_hearts:

Problem's comes when I plug the Lenovo docking station (USB-C) with two 27'' screens connected to it.

To get the desktop I want, (3 screens in a row), I need to

  • select "Extend to the right" in the xfce4-display-settings -m that (most of the time) automatically pops up when I plug the dock
  • go to "advanced", where only the two 27'' screens are visible
  • set / unset the "Mirror display" check box to get the 3 screens visible (I keep laptop screen as primary)
  • hit "Apply" and "Close"

It then works great.

But, I thought I could save this profile in the "advanced" tab, but

  • the profile name I try to save doesn't show in the list (but it does exist, as if I try to re-define a new profile with the same name, I tells me "A profile with the same name already exist").
  • of course, the profile should be "automatically enabled when display is connected", but doesn't.

Any suggestion is welcome !

Thanks

Diego

You could try using arandr to create a profile and save it - default is ~/.screenlayout/ call it anything e.g. triple-head.sh - it will be saved as a script.

Copy or move it to ~/.local/bin - then execute the script from a terminal.

triple-head.sh
1 Like

Why whould you have to copy them to ~/.local/bin and execute from terminal? I have such scripts saved on my desktop and they execute from there (without opening the terminal) just fine (I had to give them permission to run as a program).

This can be done ...

If a user do not use desktop icons - but window manager even Gnome don't have desktop icons - a script would have to be available in the path - and the default location for arandr saved scripts - is not in the path.

Another point - usually you need a .desktop file to launch a script - many systems associate ASCII files with text editors thus double clicking a script would just open the file in a text editor.

1 Like

Could you share a link to your xfce issue?


It seems current implementation of display profiles feature is not perfect yet.
So, maybe you should give some feedback to the devs at xfce bugs.

Btw. In my xfce install there is no ~/.local/bin There is only a share folder in the ~/.local folder

Yeah ok, but he clearly stated this is on xfce.

Grammar correction

Just for your information, not to sound as a wiseguy:
a user is he, so it is does instead of do. Gnome is it so it is doesn't instead of don't.
So it will read:

If a user does not use desktop icons - but window manager even Gnome doesn't have desktop icons

I see so many people make these kind of basic grammar mistakes, while for the rest write perfect English, that I had to correct you. Sorry if this bothers you.

1 Like

Yes, of course : https://forum.xfce.org/viewtopic.php?id=13466

Hi all,

Sorry for the delay, strangely, I don't receive notifications when an answer is posted ...

I didn't knew about arandr @linux-aarhus, thx, I'll try this.

Works perfectly, thanks.

xfce4-display-settings -m still pop's up when I plus the dock, any idea how to avoid this ?

It's not possible for now I guess

You posted at the forum. I meant bugs, but you can still check existing relevant bugs and add info, if needed.

Done https://bugzilla.xfce.org/show_bug.cgi?id=16094

Forum kindly sponsored by