[SOLVED] XFCE new installation - no sound

I have installed XFCE 20.2.1 on my Lenovo ThinkPad X13, and have no sound output. In PulseAudio Volume Control I see the following:

Playback tab:
System Sounds: 100%
Firefox: Audiostream: 100%

Output Devices tab:
Dummy Output: Approx. 80%

I have updated the kernel from 5.9.16-1, to 5.10.2-2, and restarted the laptop, this does not restore sound. I would be grateful of some help to restore sound, thank you.

Hello @PrettyPixel :wink:

Please check this first:

pulseaudio-ctl | grep "muted\|Volume"
speaker-test -t wave -c 8 #>(install `alsa-utils`)


inxi -Aazy

and post the output here. Thanks.

Thank you for the reply. Here is the output:

[wendy@ThinkPad-X13 ~]$ pulseaudio-ctl | grep “muted|Volume”
Volume level : 70 %
Is sink muted : no
Is source muted : no

[wendy@ThinkPad-X13 ~]$ speaker-test -t wave -c 8 #>(install alsa-utils)

speaker-test 1.2.4

Playback device is default
Stream parameters are 48000Hz, S16_LE, 8 channels
WAV file(s)
Rate set to 48000Hz (requested 48000Hz)
Buffer size range from 24 to 262144
Period size range from 8 to 87382
Using max buffer size 262144
Periods = 4
was set period_size = 65536
was set buffer_size = 262144
0 - Front Left
4 - Center
1 - Front Right
7 - Side Right
3 - Rear Right
2 - Rear Left
6 - Side Left
5 - LFE

Did you hear any sound? Alsa can produce sound and connect to your soundcard at least.

I guess you forgot this:

inxi -Aazy

Still no sound.

Output as requested:

[wendy@ThinkPad-X13 ~]$ inxi -Aazy
Device-1: Intel vendor: Lenovo driver: sof-audio-pci
alternate: snd_hda_intel,snd_soc_skl,snd_sof_pci bus ID: 00:1f.3
chip ID: 8086:02c8
Sound Server: ALSA v: k5.10.2-2-MANJARO

Here is a screenshot of Alsamixer. I clicked Fn + F6 to select sound card. There were two choices, Default and, enter device name. I selected Default. It’s not on mute, is it?


Did you install the sof-firmware?

pamac install sof-firmware

Just installed now, thank you. I now have sound. Will my system software been corrupted in anyway by not having this installed/having to troubleshoot etc? Many thanks.

“sof” just stand “Sound Open Firmware”, seems intel contributes to this firmware, but it is not installed by default because not many sound cards are supported there.

No it will will not be corrupted by not having this firmware. It will just not work.

Thank you :slight_smile:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.