[SOLVED] xfce compositor: Transparency graphic artifacts

Hey there,

I just installed manjaro 18.1.0rc8
and experienced some weird rendering with xfce.

As soon as I plug in an external display via HDMI (which may not be exclusive cause here though),
there are contrasty squares all over places which have recently be changed/painted (by the compositor, seemingly).
See the following photo:

I managed to resolve this issue by disabling XFCE's Window Composition in the Manjaro Settings.
It eversince does render window contents properly, yet without any window transparency.

Should I address this issue at XFCE forums, or is Manjaro the right place for this?
Does anyone have a hint to what might cause this issue?

It may be related to the new XFCE 4.14 release whose packages came along an initial package update.
I also just wanted to post this issue somewhere so people may google it :smiley:

My hardware:

System:
  Host: linuxacer Kernel: 5.3.0-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.14.1 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Acer product: Nitro AN515-43 v: V1.03 
  serial: <root required> 
  Mobo: PK model: Octavia_PKS v: V1.03 serial: <root required> UEFI: Insyde 
  v: 1.03 date: 06/12/2019 
Battery:
  ID-1: BAT1 charge: 58.2 Wh condition: 58.1/57.5 Wh (101%) 
CPU:
  Topology: Quad Core model: AMD Ryzen 5 3550H with Radeon Vega Mobile Gfx 
  bits: 64 type: MT MCP L2 cache: 2048 KiB 
  Speed: 1355 MHz min/max: 1400/2100 MHz Core speeds (MHz): 1: 1355 2: 1275 
  3: 1223 4: 1225 5: 1375 6: 1314 7: 1223 8: 1226 
Graphics:
  Device-1: AMD Baffin [Radeon RX 460/560D / Pro 
  450/455/460/555/555X/560/560X] 
  driver: amdgpu v: kernel 
  Device-2: AMD Picasso driver: amdgpu v: kernel 
  Display: x11 server: X.Org 1.20.5 driver: amdgpu,ati unloaded: modesetting 
  resolution: 2560x1440~60Hz, 1920x1080~60Hz 
  OpenGL: renderer: AMD RAVEN (DRM 3.33.0 5.3.0-1-MANJARO LLVM 8.0.1) 
  v: 4.5 Mesa 19.1.4 
Audio:
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel 
  Device-2: AMD Family 17h HD Audio driver: snd_hda_intel 
  Device-3: ASUSTek Xonar U3 sound card type: USB 
  driver: hid-generic,snd-usb-audio,usbhid 
  Sound Server: ALSA v: k5.3.0-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  driver: r8169 
  IF: enp3s0 state: down mac: 08:97:98:6c:5b:68 
  Device-2: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter 
  driver: ath10k_pci 
  IF: wlp4s0 state: up mac: e8:d0:fc:81:fc:a1 
Drives:
  Local Storage: total: 942.70 GiB used: 158.02 GiB (16.8%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN520 SDAPNUW-512G-1114 size: 476.94 GiB 
  ID-2: /dev/sda type: USB vendor: Crucial model: CT500MX500SSD1 
  size: 465.76 GiB 
Partition:
  ID-1: / size: 84.45 GiB used: 8.17 GiB (9.7%) fs: ext4 dev: /dev/nvme0n1p6 
Sensors:
  System Temperatures: cpu: 46.1 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 46 C device: amdgpu temp: 39 C 
Info:
  Processes: 244 Uptime: 24m Memory: 13.67 GiB used: 1.54 GiB (11.3%) 
  Shell: bash inxi: 3.0.35 
1 Like

A really weird issue

I can confirm this for the last few xfce RC's
I couldnt get a picture of it though - did not show in screenshots.
I can also confirm that it stopped after turning off XFWM's compositor.

Can confirm this issue here: Graphical glitches / artifacts after update to XFCE 4.14

Does anyone know if it has been reported to the XFCE devs already?

Also it seems so far everyone has had a ryzen/amdgpu ..

That's what I was wondering.
If not, I'm gonna open a ticket in the XFCE board.

Thanks for hinting the other issue :slight_smile:

Seems my issue has been adressed already:
https://bugzilla.redhat.com/show_bug.cgi?id=1739863

See also my ticket on xfce forums:
https://forum.xfce.org/viewtopic.php?pid=53797

According to one XFCE forum moderator,
this issue is caused by a buggy blanking mode called 'glx' which is used by default.

Setting it to 'xpresent' or 'off' causes the compositor to work properly again. This is magic.

Just set the vblank setting to xpresent via:

xfconf-query -c xfwm4 -p /general/vblank_mode -t string -s "xpresent" --create

And restart, also note that libxpresent must be installed!

2 Likes

Are there any disadvantages in terms of performance or other bugs when using off/xpresent mode vs. glx mode?

I am not sure of the ins and outs .. but this could be fixed in the ISOs immediately ..
xpresent seems to be the newer implementation and should work better for everyone it works for.
The issue is that it seems xpresent makes nvidia's unhappy. I dont know much more than that.

I'm gonna spin up an ISO to check ...

For intel gpu's xpresent seems to be better. On glx, windows are lagging behind the mouse cursor a lot when they are being moved. It's not really a big thing but ok...

Yup.
Setting

    <property name="vblank_mode" type="string" value="xpresent"/>

in

/live-overlay/etc/skel/.config/xfce4/xfconf/xfce-perchannel-xml/xfwm4.xml
(actually I copied the whole file from current iso and edited that one line that was originally set to "auto" - which defaults to glx as discussed above)

Made the initial desktop experience much nicer. All glitch gone.

I will edit this post with a link to a fixed and working extra-minimal-xfce-linux53-unstable iso when it is done uploading.

OK here ya go:

Let me know if it works for you too :slight_smile:

4 Likes

Same here with a Ryzen 5 2500U - applied the suggested xfwm configuration change, now everything is working fine even with the most recent 5.3 kernel.

This topic was automatically closed after 90 days. New replies are no longer allowed.

Forum kindly sponsored by