[Solved] Wireless Printer not connected

openrc

#1

Hello,
I am using the OpenRc XFCE edition of Manjaro.

I installed a new to me HP B210 wireless printer. It is installed and enabled, but when I try to print anything, the print queue says that it cannot connect. I am not sure what the problem is.

Here is some information that may help.

$ cups-config --version 2.2.3

$ lpinfo -v network beh network ipps network socket network lpd network http file cups-pdf:/ network ipp network https network smb direct hp direct hpfax network dnssd://Photosmart%20Plus%20B210%20series%20%5B2812F9%5D._pdl-datastream._tcp.local/ network socket://192.168.1.74:9100 network ipp://HP2812F9.local:631/ipp/printer

$ lpstat -t scheduler is running system default destination: HP_Photosmart_Plus_B210_series device for HP-Photosmart-C4100-series: hp:/usb/Photosmart_C4100_series?serial=MY63SB924004J7 device for HP_Photosmart_Plus_B210_series: dnssd://Photosmart%20Plus%20B210%20series%20%5B2812F9%5D._pdl-datastream._tcp.local/ HP-Photosmart-C4100-series accepting requests since Sat 03 Jun 2017 05:22:35 PM EDT HP_Photosmart_Plus_B210_series accepting requests since Sat 03 Jun 2017 06:06:40 PM EDT printer HP-Photosmart-C4100-series disabled since Sat 03 Jun 2017 05:22:35 PM EDT - Paused printer HP_Photosmart_Plus_B210_series now printing HP_Photosmart_Plus_B210_series-385. enabled since Sat 03 Jun 2017 06:06:40 PM EDT Unable to locate printer "HP2812F9.local". HP_Photosmart_Plus_B210_series-385 jrchristophel 99328 Sat 03 Jun 2017 06:06:40 PM EDT


#2

Maybe you could put in a hosts file entry to see if it’s just a problem finding that name.
I think I have seen this before, but I can’t remember what I did about it.


#3

Hey River,

I just went through this two days ago, and it was crazy hard, unlike with earlier editions where OpenRC/XFCE found the same printer almost automagically. I think the elogind thing changed a lot of things under the hood.

I tried many things, but here are a few late-stage items that seemed to be key to my eventual success.

Things to install:
The usual suspects like hplip and cups-openrc
sane-openrc
hpoj

Take down the firewall and run hp-setup as root, per https://wiki.archlinux.org/index.php/SANE_%28%E7%AE%80%E4%BD%93%E4%B8%AD%E6%96%87%29

Finally, use the option where you connect with USB first, and then let it jump to the wireless.

Hope it helps.


#4

Thanks jsamyth and kernelKurtz. I took both of your suggestions and now my printer is working!

I had to install sane-openrc and hpoj. I also had the wrong hostname.domain in my /etc/hosts file so I changed it to HP2812F9.local. After doing all that it started to work.

Thanks!


#5

Excellent news. Print in happiness!