SOLVED -- WiFi driver problem - TPLink AC600 RTL8821AU

Hi, just bought a new WiFi adaptor for PC to replace my cable interface. I checked before I bought and the adaptor I was after looked to be Linux compatible - hmmm… maybe.

However the device is as above TP-Link AC600 and I cannot get the thing to work. I have tried several suggestions both from this forum and others but either what I tried doesn’t work or the source has gone missing ! LSUSB provides the following (so it is seen)

Bus 001 Device 008: ID 2357:0120 TP-Link Archer T2U PLUS [RTL8821AU]

I am currently on kernel

Linux Home 5.10.7-3-MANJARO #1 SMP PREEMPT Fri Jan 15 21:11:34 UTC 2021 x86_64 GNU/Linux

Can anyone offer any suggestions on how I get this thing to work ? It wasn’t too dear so if it won’t it won’t but I would rather not throw it away :slight_smile:

Thanks for any help in advance.

First install dkms and linux-headers then restart.

Then from the AUR install rtl8821au-dkms-git


Do u have ‘linux-firmware’ installed?

1 Like

Thank you - I have been looking everywhere for that didn’t know it was in AUR :slight_smile: I have that installed and rebooted do I need to do anything else as it doesn’t seem to be loaded. At least the Wireless setup doesn’t see the card even though the system does.

Thanks for your help though- really appreciated.

Hi, yes I do have that installed, just didn’t know where the driver was. Got that installed now but must be missing something, possibly a modprobe ?

Done a bit more checking and got the following extra info if it helps

dkms status
8814au,, 5.10.7-3-MANJARO, x86_64: installed
8814au,, 5.4.89-1-MANJARO, x86_64: installed
rtl8812au, 5.3.4: added
rtl8821au, 5.1.5.r83.g3a44070, 5.4.89-1-MANJARO, x86_64: installed
[neil@Home ~]$ su
*Password: *
[Home neil]# modprobe rtl8821au
modprobe: FATAL: Module rtl8821au not found in directory /lib/modules/5.10.7-3-MANJARO

Well it looks like that driver is not working… uninstall rtl8821au-dkms-git

Then install rtl8821au422-dkms-git This driver includes drivers for rtl8821, rtl8812 & rtl8811. The driver was last updated in 2019, but people are reporting that it works.

You may have to try kernel 5.8 if 5.10 does not work.

Thanks for that - this worked perfectly.
Really appreciate the help

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.