[SOLVED] Why my manjaro freeze after i use for opening firefox, etc.

Hi @Nao,
just for my understanding, you created a new user and logged in with this new user after booting and have the same issues as before?

1 Like

If you were having issues with Windows 10, and then issues with DeepinOS, and now issues with Manjaro, then the only real common factor is the hardware.

It's possible that the CPU really is failing (or e.g. overheating), or you have some other hardware issue like a lack of power or bad connection.

The issues i got from deepin is different than the issues i got now.

And issues i got is different too for widows 10.

The reason why i must switch from deepin because i accidently broke the whole system (yeah i'm dumb because i just want to move it from /usr/lib and after got restart, deepin changed to initramfs)

Yes, i created new user as you instructed and still got the error.

That is not clear from your posts so far. For example, you said:

and then:

However - given the CPU error in the logs this still points to something outside of Manjaro's influence:

So - a hardware issue would very easily explain why your system freezes.


1 Like

Hmmm.. so this is problem because my hardware error?

Oh okay then, i just gotta go to repair my computer.

Btw thanks for your explanation @jonathon

Before starting disassembling your computer, please provide output of

$ cat /var/log/Xorg.0.log | grep -i i915

The issue could be linked to your combination of GPU and graphic driver.

Here is a very good link which could potentially provide a solution, look for the "freeze" part:

Here is the output

OK, now the more difficult part:

Please provide output of

$ ls /etc/modprobe.d

Didn't return anything.

OK, that's good, one issue less. Now I have to find out where to put a
GPU usage with NoAccel option
in your configuration, will take a while...

I've put NoAccel option on /etc/X11/xorg.conf.d/20-intel.conf (Just created new file)

Congrats, you have been faster than me. Will be interesting to see if this helps already.

Only want to mention I found another folder


where some configs are stored on my PC, one file is called


Yeah, i'll trying if this setup is working for me or not..
And if this last option is not work, then it must be a problem from my hadware.

could be, do a memtest, and check your hdd, also your processor is that great.

do a bit of reading here

Ok the problem is solved now after i trying to put NoAccel option, then edit grub CMDLINE_LINUX_DEFAULT, and switching from KDE to XFCE

Now my computer is smooth enough to browser freely with firefox, or do whatever i want without freezing stuff.

Thanks guys for helping me solving my issues :slight_smile:

1 Like

That's great! Please mark the thread as solved.

What did you edit ?

1 Like

If i'm not wrong, i added this:

And create a folder called /.drirc with:

<device screen="0" driver="dri2">
	<application name="Default">
		<option name="vblank_mode" value="0"/>

Also i delete my account and switch to XFCE,
now i'm not having any issues about freezing again.

Careful, that will have some impact on your battery life. It's impossible to know how much but you'll need to keep an eye on it.
I used that for several months to workaround the Bay Trail bug that I mentioned earlier in the thread.
THankfully I don't need it anymore with linux53 which has the "fix".

Glad it's not freezing up on you anymore! :wink:

Forum kindly sponsored by Bytemark