[solved] VMWare Will not start

kernel
vmware
#1

Just done a clean install of Manjaro on a Laptop and when i installed VMware the program dose not start.

I dont get any error message when i open it it just dose nothing.

Running the file in the terminal dose nothing

System

OS; Manjaro 17.0 Gellivara 64-bit
DE: XFCE
and im running the most up to date VMWare Player

many thanks

#2

Vmware AFAIK requires source code patching before use on kernel > 4948

That said - I cannot get it run under 4.4 or 4.8 or 4.9 - workstation pro 12.5.3

Edit
Installing the latest 12.5.4 made all the service start when doing /etc/init.d/vmware start -but the rest does not work on any kernel. Very annoying.

I also had a look at the patches that exist for vmmon and vmnet but these module are patched so I am in the dark myself.

I also had a look at the vmware installer log - which contains something like ‘this is a kvm enabled system and vmware cannot run’. I cannot find what that message is supposed to mean other than the obvious which I don’t have installed. Vmware and VirtualBox usually don’t have a problem on coexist.

https://wiki.archlinux.org/index.php/VMware

Also tried vmware-modconfig --console -install-all` no luck
Out of pure annoyance and irritation I have decided to reinstall my workstation so I will be back.

This has be tried when back
ln -s wssc-adminTool /usr/lib/vmware/bin/vmware-wssc-adminTool

Then on a fresh install it still doesn’t work but I found the answer.

@Infinatum @jsamyth
The answer is on Vmware communites forum

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4:$LD_LIBRARY_PATH

1 Like
Help me thi command run " vmware-modconfig --console --install-all" this show output
[wiki]Installing VMware
#3

Ah Ok

Im running Kernel 4.9.13-1

I had a manjaro system running at 4.4.45-1 abd it seems to work with that, would downgradeing to a older kernel fix the problem (with the Manjaro Settings Manager)?

Edit: Going back to an older version dose not fix the problem

#4

Did you install the opensource kernel modules supplied in the Manjaro.

#5

I installed the kernel Via the Manjaro Settings Manager, then booted into that kernel on startup.


#6

Yes, but that’s not what I asked.

There are Vmware tools modules available that are opensource (and available from Manjaro). These run in the virtual machine.

#7

Installed them but it still dose not work.

I have installed the folowing

linux-rt-lts-manjaro-open-vm-tools-modules 2:2013.09.16-19
open-vm-tools 6:10.1.0-2

EDIT: Running VirtualBox works in Linux Kernel 3.18.48 but when it runs for 2 min it crashes the OS

47.042947] shutting down cpus with MNI
47.044957] Kernel Offset: 0x0 from 0xfffff …
47.046024] drm_kms_helper: panic occurred, switching back to text console

#8

If I did understand your OP correct.

  • Do you have trouble starting Vmware on you host-machine?

or

  • Do have problem with a Vmware in a virtual machine?

If it is the first point you do not need openvm-tools.
Have you had a look at this post?

1 Like
#9

I cannot Start Vmware on my host machine, along with virtual box.

Unlike VMware, Vertual Box start but i cannot run the VM,

I have installed open-vm-tools 6:10.1.0-2 from the manjaro package manager.

starting Vmware i get the following message

useing a older kernle dose the same, however Vertual box works for 2 min untill the whole system crashes.

would useing an older version of manjaro fix this issue

#10

Run the most recent LTS 4.9 kernel

Your VirtualBox is giving a faulty message. Run

sudo vboxreload

Your Vmware is failing because it cannot find a shared library.
The solution for this issue is decribed in the Vmware tricks post mentioned above

#11

DId you install the VIX along with VMware? I usually download that as well.

#12

Running the command for VirtualBox gives the following error

Result

$ sudo vboxreload
Unloading modules:
Loading modules: modprobe: FATAL: Module vboxnetadp not found in directory /lib/modules/4.9.13-1-MANJARO
modprobe: FATAL: Module vboxnetflt not found in directory /lib/modules/4.9.13-1-MANJARO
modprobe: FATAL: Module vboxpci not found in directory /lib/modules/4.9.13-1-MANJARO
modprobe: FATAL: Module vboxdrv not found in directory /lib/modules/4.9.13-1-MANJARO

On your Vmware tricks post Virtual machine monitor and Virtual ethernet have not failed, where for me they fail.

Also “/usr/bin/vmware” dose not exsist, though “/usr/bin/vmplayer” dose, so im not sure how diffirent it would be.
if i cannot get this working soon ill just use an older version of manjaro.

thnaks for the help

#13

Your result of running vboxreload point to missing headers for your kernel

sudo pacman -S linux49-headers

Edit vmplayer wrapper and add the same export line

sudo nano /usr/bin/vmplayer
#14

https://wiki.archlinux.org/index.php/VMware

To make VMware use its own version of Curl as well, add:

export LD_LIBRARY_PATH=/usr/lib/vmware/lib/libcurl.so.4

before the following line from the end of the file:

exec “$libdir”/bin/“name of script” “$@”

in /usr/bin/vmware and/or /usr/bin/vmplayer.

#15

It seems to start now though i get this.

what is the path for the kernel headers?

#16

When you get this you don’t have headers and will have to install them

sudo pacman -S linux49-headers

and vmware will find them

#17

Found Why it did not work, it says

==> No kernel 4.9.16-1-MANJARO modules. You must install them to use DKMS!

Summary

warning: linux49-headers-4.9.16-1 is up to date – reinstalling
resolving dependencies…
looking for conflicting packages…

Packages (1) linux49-headers-4.9.16-1

Total Installed Size: 50.72 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [#####] 100%
(1/1) checking package integrity [#####] 100%
(1/1) loading package files [#####] 100%
(1/1) checking for file conflicts [#####] 100%
(1/1) checking available disk space [######] 100%
:: Running pre-transaction hooks…
(1/1) Remove DKMS modules
==> No kernel 4.9.16-1-MANJARO modules. You must install them to use DKMS!
:: Processing package changes…
(1/1) reinstalling linux49-headers [###########] 100%
:: Running post-transaction hooks…
(1/2) Install DKMS modules
==> No kernel 4.9.16-1-MANJARO modules. You must install them to use DKMS!
(2/2) Arming ConditionNeedsUpdate…

#18

Uninstall DKMS you do not need it with Manjaro.

#19

The linux46-headers have been installed but vmware still cannot find it

[details=Running VM player in the terminal]

Gtk-Message: Failed to load module “canberra-gtk-module”: libcanberra-gtk-module.so: cannot open shared object file: No such file or directory
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “murrine”,
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “murrine”,
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “murrine”,
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “murrine”,
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
(vmware-modconfig:2233): Gtk-WARNING **: Unable to locate theme engine in module_path: “adwaita”,
/usr/share/themes/Vertex-Maia/gtk-2.0/gtkrc:1163: error: unexpected identifier direction', expected character}’[/details]

would i have to manualy show VMware where the files are, or would a reinstall fix the issue?

#20

You can ignore those errors.

For the headers - they must match your kernel - and if you changed kernel you have to reboot on the selected kernel before it has effect.

for kernel 49 - linux49-headers
for kernel 44 - linux44-headers

###Structure
As understands your errors and your posts - you have had an unstructured approach to solve this issue.

Trial and Error is the way we all learn but this must be a structured trial and error - so it in the process is possible to clean up and not leave your system with all the solutions tried.

As you have seen installing DKMS introduced new issues by itself and it is hard to determine what actually is needed to help you.

It might be necessarry for you to backtrack your steps and reverse those steps that didn’t work. Cleanup your workplace - so to speak.