(Solved) Viewnior not working in testing manjaro32 17.1.1

Not sure where to post this for support for manjaro32. I installed the testing 17.1.1 RC and had no problems with the installer, but could not open viewnior to view image files.

Here’s my terminal output.

Blockquote

[meurglys@ma3a ~]$ viewnior
viewnior: error while loading shared libraries: libexiv2.so.14: cannot open shared object file: No such file or directory
[meurglys@ma3a ~]$

Blockquote

I appreciate the effort to bring back 32-bit support. Thanks, and keep up the good work.

This is provided by the package exiv2. The current version is 0.26-2. Viewnior current version on x86_54 is 1.6-3. What is it in manjaro32?

$ pacman -Ss exiv2
extra/exiv2 0.26-2 [installed]
    Exif, Iptc and XMP metadata manipulation library and tools

$ pacman -Ss viewnior
community/viewnior 1.6-3 [installed]
    A simple, fast and elegant image viewer program

Outdated mirror perhaps?


(moved from #general-discussion to #technical-issues-and-assistance:applications)

Hmmmm…other than viewnior not working, I’m happy to report that installing and running manjaro32 testing 17.1.1 rc1 working well.

Oh - if this is a fresh installation then run an update… :wink:

@jonathon Worked in Stable, before I set it to testing and ran the massive update. I then burned the 17.1.1 rc1 testing .iso and noticed it wouldn’t work booting into the live environment either. Ran the smaller update, and still no joy.

The 17.1.1-rc1 iso was built using an older set of packages; you’d need to check package versions in the live environment to check.

If you update the installed system now you should end up with the up-to-date packages (x32-stable, -testing, and -unstable are all at the same point).

@jonathon
I have installed viewnior on main pc (testing branch) and now updated and installed on Manjaro32 (I guess testing branch)

Versions of exiv2 and viewnior are the same on both computers, but on 32 don’t start

So I builded viewnior with yaourt -Sb and now start, it taked less disk space also

2 Likes

Both were the same as what I had installed.

1 Like

Thanks both - looks like it needs a rebuild.

Built, let me snap it down though the branches, there are very minor changes at the moment (like, two packages or something).

OK, it should be with you shortly. :slight_smile:

1 Like

Works now. Thanks Jonathon.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark