[SOLVED] Update fails partially (on phonon-qt4)

updating

#1

Hello all,

today is received an update and it ends with the lines below.
I tried a key refresh but that didn’t help.
Any ideas how to solve this?

Thanks,

Ray

remote: Compressing objects: 100% (10/10), done.
remote: Total 11 (delta 1), reused 11 (delta 1)
Unpacking objects: 100% (11/11), done.
==> Making package: phonon-qt4 4.10.1-2 (za 25 aug 2018 16:50:56 CEST)
==> Checking runtime dependencies…
==> Checking buildtime dependencies…
==> Retrieving sources…
-> Downloading phonon-4.10.1.tar.xz…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 356 100 356 0 0 4944 0 --:–:-- --:–:-- --:–:-- 4944
100 344 100 344 0 0 1476 0 --:–:-- --:–:-- --:–:-- 1476
100 314k 100 314k 0 0 155k 0 0:00:02 0:00:02 --:–:-- 178k
-> Downloading phonon-4.10.1.tar.xz.sig…
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 360 100 360 0 0 5070 0 --:–:-- --:–:-- --:–:-- 5142
100 819 100 819 0 0 3607 0 --:–:-- --:–:-- --:–:-- 30333
==> Validating source files with sha256sums…
phonon-4.10.1.tar.xz … Passed
phonon-4.10.1.tar.xz.sig … Skipped
==> Verifying source file signatures with gpg…
phonon-4.10.1.tar.xz … FAILED (unknown public key B92A5F04EC949121)
==> ERROR: One or more PGP signatures could not be verified!


Problem while updating from AUR
#2

Remove phonon-qt4. It’s been discontinued on Manjaro repos along many other qt4 packages and you probably don’t need it.

The error is because now it is in the AUR and you don’t have the PGP key of the packager. But as I said, most likely you don’t need it at all and better to remove it.


AUR update incomplete - PGP signature incorrect
#3

Thanks! Removed phonon4 + kdebase runtime and there are no updates anymore :slight_smile:
Ray


#4

When I attempt to remove phonon-qt4 I get the following error:

error: failed to prepare transaction (could not satisfy dependencies)
:: kdelibs: removing phonon-qt4 breaks dependency ‘phonon-qt4’


#5

Remove kdelibs aswell.


#6

kdelibs seems fairly important to the KDE desktop environment


#7

Yes. Back when it was KDE4. It’s not needed at all in KDE5.


#8

Thank you for such a quick reply


split this topic #9

4 posts were split to a new topic: Open Sankore needs phonon-qt4


#10

excellent worked me


#11

Unfortunately, I have recently been afflicted with the update notifier flagging the same two files (pyqt4-common and python-pyqt4) and then in the update section the process attempts to install phonon-4.10.1.tar.xz and phonone-4.10.1.tar.xz.sig . Upon updating the process fails as the OP has described. I have tried the solution given by Signalrunner however, those files are shown as NOT installed on my system and even if I try to install them (so as to then uninstall as per the suggestion) that install itself fails! So I am left with the update notifier continually being red upon boot and I have to quit the update notifier because as I have said, I can’t follow the solution here described. I am running 4.19.0-1-MANJARO #1 SMP PREEMPT Mon Oct 22 18:40:59 UTC 2018 x86_64 GNU/Linux and Testing Branch. Any ideas would be most appreciated.


#12

What a mess. In order for the “phonon-qt4” package to update, which seems a dependence of those pyqt packages, I believe you have to both import it’s PGP keys and make sure all their dependencies are met. Specially “phonon-qt4-backend” which could be a little bit tricky it seems. Take a look at it’s AUR page:

https://aur.archlinux.org/packages/phonon-qt4

And I don’t know, maybe take a look at those pyqt4 packages with pacman -Qi nameofpackage and see which other packages depends on them.

Anyway, maybe it would be a better idea to open a new thread to explain your problem, since time has passed and this is flagged as solved.


#13

@Signalrunner
I followed your suggestion(s) particularly pacman-Qi and after a little trial and error, I believe by removing (in Pacman) pyqt4-common the problem may be resolved. I will reboot and see if the apparent fix sticks. Thank you for your help.
Edit: after a reboot the issue is indeed resolved. Once again, thank you Signalrunner for putting me on the right track to fixing this. I don’t use KDE so am not sure how I ended up with some of those pyqt files but perhaps they are not necessarily exclusive to KDE. Whatever the case, all is resolved now.
Cheers.


#14

Thank you LinuxIsBest and SignalRunner, between the two of you I got this fixed on my system. Excellent.


closed #15

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.