[solved]Unable to mount root

I installed the latest Manjaro KDE on /dev/sda2. The swap file is /dev/sda1. My home folder is /dev/sda11.
After grub was updated, I had it written to the mbr. When I re-booted I booted into another linux distro that I use for my main work. I was just going to learn what I could about Manjaro. When I got into my main distro, I updated grub and saved the new grub to MBR. Then when I re-booted and tried to log into Manjaro I got "kernel panic-not syncing: VFS: unable to mount root fs on unknown block(0,0)"
I went back into my main distro and opened a console as root and typed blkid -c /dev/null and got the below:

/dev/sda1: UUID=“0f30d567-af7c-4aba-919e-e386886b1d90” TYPE=“swap” PARTUUID=“4773ed51-01”
/dev/sda2: UUID=“68790adf-3a6b-4b61-9f25-33a4182109cd” TYPE=“ext4” PARTUUID=“4773ed51-02”
/dev/sda11: LABEL=“Home64bit” UUID=“f0273316-2213-4753-93a4-602fdd9adf80” TYPE=“ext4” PARTUUID=“4773ed51-0b”

Then I looked at the grub entry for /dev/sda2 and got this: insmod part_msdos
insmod ext2
set root='hd0,msdos2’
if [ x$feature_platform_search_hint = xy ]; then
search --no-floppy --fs-uuid --set=root --hint-bios=hd0,msdos2 --hint-efi=hd0,msdos2 --hint-baremetal=ahci0,msdos2 68790adf-3a6b-4b61-9f25-33a4182109cd
else
search --no-floppy --fs-uuid --set=root 68790adf-3a6b-4b61-9f25-33a4182109cd
fi
linux /boot/vmlinuz-4.9-x86_64 root=UUID=68790adf-3a6b-4b61-9f25-33a4182109cd rw quiet resume=UUID=0f30d567-af7c-4aba-919e-e386886b1d90
initrd /boot/intel-ucode.img

Manjaro’s grub plays well with other distros … but updating grub from a different OS will F* up manjaro.

This is from another OS grub.
Try this to help you get back Manjaro grub as default.
Do not forget to ‘grub-install’ and ‘update-grub’ when you boot to Manjaro.

Thanks for the info. I will try this and post back the outcome.

My screen went dark while updating and I totally messed up the install because I didn’t know how to get back to the gui desktop. So I re-installed. Problem solved for now. I not only don’t understand a lot about grub2 and how to edit it but octopi is really confusing for me to use after using another updater for so long.
Thanks again. I have some reading to do.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark