[Solved] Thinkpad X250 - Sabrent USB audio input

audio

#1

Hi,

New to Manjaro/Arch and having an issue getting audio input via a Sabrent USB soundcard. There is some input (via a mic) however it is very low and grainy. Output however is working perfectly!

I have installed pulseaudio and confirmed the levels are correct via pavucontrol.

Some system details below.

System:    Host: hostname Kernel: 4.19.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: i3 4.16 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: LENOVO product: 2OCLS2BT00 v: ThinkPad X250 serial: <filter> 
           Mobo: LENOVO model: 2OCLS2BT00 v: 0B98417 WIN serial: <filter> UEFI [Legacy]: LENOVO v: N10ET33W (1.12 ) 
           date: 04/06/2015 
Battery:   ID-1: BAT1 charge: 0 Wh condition: N/A model: N/A status: Unknown 
CPU:       Topology: Dual Core model: Intel Core i5-5300U bits: 64 type: MT MCP arch: Broadwell rev: 4 L2 cache: 3072 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 18366 
           Speed: 798 MHz min/max: 500/2900 MHz Core speeds (MHz): 1: 798 2: 798 3: 799 4: 800 
^[[AGraphics:  Device-1: Intel HD Graphics 5500 vendor: Lenovo driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.3 driver: intel unloaded: modesetting tty: N/A 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.3.1 direct render: Yes 
Audio:     Device-1: Intel Broadwell-U Audio vendor: Lenovo driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel Wildcat Point-LP High Definition Audio vendor: Lenovo driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.13-1-MANJARO 
Network:   Device-1: Intel Ethernet I218-LM vendor: Lenovo driver: e1000e v: 3.2.6-k port: 3080 bus ID: 00:19.0 
           IF: enp0s25 state: down mac: <filter> 
           Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel port: efa0 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 119.24 GiB used: 15.53 GiB (13.0%) 
           ID-1: /dev/sda vendor: SanDisk model: SD7SB3Q128G1001 size: 119.24 GiB 
Partition: ID-1: / size: 108.21 GiB used: 15.53 GiB (14.4%) fs: ext4 dev: /dev/sda1 
           ID-2: swap-1 size: 8.80 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 50.5 C mobo: N/A 
           Fan Speeds (RPM): cpu: 3683 
Info:      Processes: 162 Uptime: 1m Memory: 7.50 GiB used: 335.3 MiB (4.4%) Init: systemd Compilers: gcc: 8.2.1 Shell: zsh 
           v: 5.6.2 inxi: 3.0.28 

The device is detected and can be seen under lsusb.

lsusb
Bus 001 Device 002: ID 8087:8001 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 005: ID 5986:0366 Acer, Inc 
Bus 002 Device 004: ID 8087:0a2a Intel Corp. 
Bus 002 Device 003: ID 138a:0017 Validity Sensors, Inc. VFS 5011 fingerprint sensor
Bus 002 Device 002: ID 0d8c:0014 C-Media Electronics, Inc. Audio Adapter (Unitek Y-247A)
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

I was previously using Ubuntu where the device was functioning perfectly on Kernal 4.18. Which showed the device as below.

lsusb
Bus 002 Device 002: ID 0d8c:0014 C-Media Electronics, Inc. 

If anyone could point me in the right direction it would be appreciated.
Cheers!


#2

I have used alsa-info.sh to upload ALSA information to: http://www.alsa-project.org/db/?f=c3029bc3f676cbd624744f2810f472edde1f186f


#3

Well after looking at this for a week I just tried to reinstall pulseaudio and would you look at that everything is now working.

Thanks anyway!


#4

I didn’t know it was possible to reboot files, but there you go. :rofl:

"Have you tried turning it off and on installing it again?