[Solved] Strange beep after login SDDM KDE plasma

Hi,

I just installed Manjaro KDE on my laptop and noticed this strange beep sound directly after login. This problem only happens on this laptop, on other laptop and desktop there is no beep.

I already followed the wiki:
https://wiki.archlinux.org/index.php/PC_speaker

But choose to set only the 'xset -b' in '/etc/xprofile'. This works for other beeps like hitting backspace in pacman. I dont want to block Globally using the blacklisting option, unless there is no other solution. In the system settings - notifications, i checked all the Plasma Workspace settings (login and logout). There is no sounds applied.

I hope somebody can help. If you need any logs etc, just let me know.

Thanks,

Hi @yyywwwyyywww,

welcome at the forum.

Can you show us your grub file by

cat /etc/default/grub

Here my grub, thanks for helping.

GRUB_DEFAULT=saved
GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="bootsplash.bootfile=bootsplash-themes/manjaro/bootsplash cryptdevice=UUID=bcc60ff5-ea0e-406a-b973-f8b924e00047:luks-bcc60ff5-ea0e-406a-b973-f8b924e00047 root=/dev/mapper/luks-bcc60ff5-ea0e-406a-b973-f8b924e00047 resume=/dev/mapper/luks-bcc60ff5-ea0e-406a-b973-f8b924e00047 apparmor=1 security=apparmor udev.log_priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=true

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/usr/share/grub/background.png"
GRUB_THEME="/usr/share/grub/themes/manjaro/theme.txt"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
GRUB_ENABLE_CRYPTODISK=y

Is the beep coming from the systems pc speaker (soldered onto the mainboard), or through the audio chips speakers (pcm)?

Have you looked at your autostart applications to see if one of them is causing the beep?

Do you have accessibility turned on, that will use the system bell by default?

There are some options in System Settings, Hardware, Audio, Applications: Event sound - make sure they are muted.

I try to listen clearly and it seems like the pc speaker sound.
I disabled all the autostart app, but still got the same beep.
I have the same setting like your screenshot. The system bell is by default.
Thx so far for helping.

This setting System Settings, Hardware, Audio, Applications: Event sound is already muted. Thanks so far. The beep is just annoying. :wink: I hope I can find where this is coming from.

Have you tried to disable bell on tab-completion in /etc/inputrc?

If you want to give it a try then change (probably the second line) to:

set bell-style none

I found it. The laptop starts so fast, that I couldn't see a system notification error. So i looked through journalctl -b and found an error about locale. So after some search in the forum i found:
https://forum.manjaro.org/t/gufw-doesnt-start/30514/33
Changing the formats and translation languages solved the problem. The error is not there anymore and also the strange beep.

Thank you guys for helping. Great community here!

2 Likes

Forum kindly sponsored by