[Solved] Still stuck at the Stable Update 2018-12-31 because of files that cannot be removed


#1

Sorry to post my problem once again. I’m still stuck with the stable update 2018-12-31 and i fear, my problem got lost in the discussion. I hope it’s ok to ask again.

In the end-of-the-year update discussion there was the user Citroen who had a similar problem than me. He got an error message that pacman couldn’t update his linux-firmware package because it was something missing. Here is that part of the discussion:

I had a similar Problem as he mentioned in that topic, but i think have done something terrible stupid. My /var/lib/pacman/local/linux-firmware… folder also only had the file mtree inside. There was no “files” or “desc” file what pacman always claimed. It was an even older linux-firmware version. I tried to uninstall the package, but that didn’t work because the process always reclaimed the missing “desc” file (sorry, didn’t made a screenshot). The user Citroen was lucky, because he had a second computer with those files and only had to copy them from one computer to the other. That didn’t work for me because i only have one Manjaro installation.

I thought the path could be only left over from a previous installation and deleted that folder :scream:. Now i know that was terrible wrong, because when i now want to do the end-of-the-year update, the packages can be downloaded but the process won’t install the files, because he finds firmware files and stops the installation…

…and so on.

I tried to find out which package is responsible for the files to manually get them out of the way, but when i ask pacman there is no package linked to them:

[furby@Travelmate ~]$ pacman -Qo /usr/lib/firmware/3com/3C359.bin Fehler: Kein Paket besitzt /usr/lib/firmware/3com/3C359.bin

Now i am not able to complete the update. Can anyone help in this situation?

Thanks


#2

See if you can find the offending package here> https://archive.archlinux.org/packages/
If so copy over the files.


#3

Thanx Hipster for your help. My problem is, that i don’t know the version of the linux-firmware package anymore, because i have deleted the folder :persevere:


#4

Yeah I was just looking. Did you have a backup? There might be a log somewhere.


#5

Good idea. I have a backup but i only back up my files in the home-directory, not doing a system-image. But i am doing the updates always on the shell with the

pacman -Syu

command. If i am lucky, pacman reports the error in an older log-file. But what log-file should i look for?


#6

there is this package in the repos.

linux-firmware  20181218.0f22c85-1

pamac > linux-firmware

and

pacman -Ss linux-firmware
core/linux-firmware 20181218.0f22c85-1 (base) [installed]
    Firmware files for Linux


#7

See how this goes. Terminal $ history 30. Pick any number to go back & see the command. You should be able to see what you deleted.


#8

Yeah, thats it! Thank you all for brainstorming :blush:. I found the remove-command in the history of the root. It was the package “linux-firmware 20181026.1cb4e51-1”. When i did that update, my notebook crushed and i ignored the warning when doing the following updates.

What’s best to do next? Download the package and try to install it manually? After that remove it and go on with the end-of-the-year-update?


#9

This is above my pay grade but if it was uninstalled you would think installing it should do no harm.

If you dare, pamac install linux-firmware (What kmartin said)

That will install the latest. Not sure where you would get the one you deleted.


#10

I found the package in the “index of packages” you send me:

and downloaded it. Now i only have to persuade pacman to install this local package and overwrite the still existing files.


#11

Thanks for your help kmartin. I am using KDE, so i should use Octopi, right?

When i do what you suggest my problem pops up again:


…and so on. That’t the point where i got stucked.


#12

What’s it saying? What’s the error? Use pacman or pamac to install with terminal.


#13

there is this thread:
https://forum.manjaro.org/t/linux-firmware-package-got-corrupted-during-2018-05-07-stable-update/46772/5

The Arch link may help


#14

Oh, sorry. I’m german native speaker, so i can read the error messages :blush:. The point is, that octopi can’t install the files, because the files from the former package still exist in the filesystem. But when i ask pacman from which package one of the file comes, he doesn’t know the answer, probably because i deleted the foulder in /var/lib/pacman/local/linux-firmware…


#15

…this looks promising, because it’s exactly what happened to me (the post on the Arch board)


#16

:unamused: i followed the exact way the arch user was able to solve the problem, but with manjaro pacman doesn’t have the --force switch. Without it, the problem still exists, because he still finds the existing files in the filesystem :cry:


#17

overwrite:

 --overwrite <path>
                       overwrite conflicting files (can be used more than once)

see:
pacman -Sh


#18

My limited understanding is that linux-firmware is associated with the kernels installed.
I reason that reinstalling kernels would rebuild the linux-firmware file(s).
And make things right with pacman… maybe?

:crossed_fingers:

Sorry I don’t speak German


#19

i am trying this command:

[Travelmate tmp]# pacman -U --overwrite /usr/lib/firmware/ linux-firmware-20181026.1cb4e51-1-any.pkg.tar.xz

with the downloaded package from the archlinux-package-repository but he still complains that the files exist:

Fehler: Konnte den Vorgang nicht durchführen (In Konflikt stehende Dateien)
linux-firmware: /usr/lib/firmware/3com/3C359.bin existiert im Dateisystem
linux-firmware: /usr/lib/firmware/3com/typhoon.bin existiert im Dateisystem
...

which means translated something like this:

Error: couldn't complete the action (conflicting files exist)
linux-firmware: /usr/lib/firmware/3com/3C359.bin exists in filesystem
linux-firmware: /usr/lib/firmware/3com/typhoon.bin exists in filesystem
...

I am using the 4.19 kernel. Just loading the 4.20 kernel and reboot to see whats next. Then reinstalling the 4.19 kernel and hope that brings the firmware with it? I’ll try.

No matter. I don’t speak English very well :blush:. It’s still fascinating for me to get help from all over the world like you and Hipster. Thank you very much for your support :blossom:


#20

Why don’t you try renaming/moving those two files? It may kick it into gear. Just remember or write down what they are.