[solved] Running Jekyll : dependency issue


I’ve installed Jekyll from AUR, but it won’t run. I’m getting this error :

Could not find 'listen' (< 3.1, ~> 3.0) - did find: [listen-3.1.5] (Gem::MissingSpecVersionError)

From what I understand, I’ve got the wrong version of some package installed.

But I don’t know what to do next to make Jekyll work.

Here’s the full output I get whenever I launch jekyll :

Traceback (most recent call last):
	12: from /usr/bin/jekyll:23:in `<main>'
	11: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `activate_bin_path'
	10: from /usr/lib/ruby/2.5.0/rubygems.rb:309:in `synchronize'
	 9: from /usr/lib/ruby/2.5.0/rubygems.rb:310:in `block in activate_bin_path'
	 8: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in `activate'
	 7: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `activate_dependencies'
	 6: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `each'
	 5: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1471:in `block in activate_dependencies'
	 4: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1439:in `activate'
	 3: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `activate_dependencies'
	 2: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1457:in `each'
	 1: from /usr/lib/ruby/2.5.0/rubygems/specification.rb:1468:in `block in activate_dependencies'
/usr/lib/ruby/2.5.0/rubygems/dependency.rb:312:in `to_specs': Could not find 'listen' (< 3.1, ~> 3.0) - did find: [listen-3.1.5] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/my-user/.gem/ruby/2.5.0:/usr/lib/ruby/gems/2.5.0', execute `gem env` for more information

Thanks for the help

The package is out-of-date. I’ve flagged it so the maintainer knows and can update it.

Assuming the only package you installed was jekyll, the package is also missing a dependency on ruby-listen. I’ve added a comment to the package page.

To solve this dependency issue install ruby-listen-3-0 from the AUR.

To update to 3.7.0, you can edit the PKGBUILD and set the pkgver yourself to 3.7.0 and build as normal. In that case you can install ruby-listen instead.

Alternatively, install it locally for your own account with gem install jekyll. This will install all dependencies and put the jekyll binary under $HOME/.gem/ruby/2.5.0/bin; add that to your $PATH and away you go.

Thanks ! It’s working now

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by