[SOLVED] RTL8821CE Wi-Fi not working

Using a HP Laptop.Installed Manjaro KDE which is working ok but it does’t read my wi-fi card,the Realtek RTL8821CE.Here is an Inxi result.

 Host: filip-pc Kernel: 4.19.0-3-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: KDE Plasma 5.14.4 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: HP product: HP Laptop 15-db0xxx v: Type1ProductConfigId 
  serial: <root required> 
  Mobo: HP model: 84AD v: 85.19 serial: <root required> UEFI: Insyde v: F.02 
  date: 04/06/2018 
Battery:
  ID-1: BAT1 charge: 40.7 Wh condition: 40.7/41.0 Wh (99%) 
  model: Hewlett-Packard PABAS0241231 status: Full 
CPU:
  Topology: Dual Core model: AMD A9-9425 RADEON R5 5 COMPUTE CORES 2C+3G 
  bits: 64 type: MCP arch: Excavator L2 cache: 1024 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 12380 
  Speed: 1397 MHz min/max: 1400/3100 MHz Core speeds (MHz): 1: 1397 2: 1397 
Graphics:
  Device-1: AMD Stoney [Radeon R2/R3/R4/R5 Graphics] vendor: Hewlett-Packard 
  driver: amdgpu v: kernel bus ID: 00:01.0 
  Device-2: AMD Jet PRO [Radeon R5 M230] vendor: Hewlett-Packard 
  driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: ati,radeon 
  unloaded: amdgpu,modesetting resolution: 1920x1080~60Hz 
  OpenGL: renderer: AMD STONEY (DRM 3.27.0 4.19.0-3-MANJARO LLVM 7.0.0) 
  v: 4.5 Mesa 18.2.6 direct render: Yes 
Audio:
  Device-1: AMD vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 00:01.1 
  Device-2: AMD Family 15h Audio vendor: Hewlett-Packard driver: snd_hda_intel 
  v: kernel bus ID: 00:09.2 
  Sound Server: ALSA v: k4.19.0-3-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.045.08-NAPI port: 3000 
  bus ID: 02:00.0 
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: 10:62:e5:8e:37:ef 
  Device-2: Realtek RTL8821CE 802.11ac PCIe Wireless Network Adapter 
  vendor: Hewlett-Packard driver: N/A port: 2000 bus ID: 03:00.0 
Drives:
  Local Storage: total: 1.95 TiB used: 931.92 GiB (46.7%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
  ID-2: /dev/sdb vendor: Samsung model: MZNLN128HAHQ-000H1 size: 119.24 GiB 
  ID-3: /dev/sdc type: USB vendor: Seagate model: ST1000LM035-1RK172 
  size: 931.51 GiB 
  ID-4: /dev/sdd type: USB vendor: Kingston model: DataTraveler 3.0 
  size: 14.41 GiB 
Partition:
  ID-1: / size: 108.34 GiB used: 10.13 GiB (9.4%) fs: ext4 dev: /dev/sdb2 
  ID-2: swap-1 size: 8.37 GiB used: 31.5 MiB (0.4%) fs: swap dev: /dev/sdb3 
Sensors:
  System Temperatures: cpu: 61.2 C mobo: 20.0 C 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 61 C device: radeon temp: 44 C 
Info:
  Processes: 193 Uptime: 1h 54m Memory: 3.80 GiB used: 2.32 GiB (60.9%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28 

Mind helping me out?

Se here:


and here

1 Like

Perhaps I didn’t understand it well. (New to Manjaro,comming from LinuxMint,so please forgive me)

Blockquote
First, install the linux419-headers package on kernel 419.
If you are using another kernel substitute the number from your kernel version in the package name.

So i understood it to go to the Kernel - System settings module.There it shows I already have installed and am running Linux 4.19.8-2 (Linux 419 below it,smaller letters)
And I also have the pacage already installed,but it isn’t working.
Maybe there is something I have missed?

Again,sorry for complicating things

Excellent. In order to build the module you need to install the linux419-headers package (not the same thing as the linux419 that you have installed as kernel), then install from AUR the rtl8821ce-dkms-git package.

Blockquote
install the linux419-headers package

Downloaded the tar.gz but I don’t know how to install it.Is there a command I could use in the terminal for it?

Oh, you posted in #technical-issues-and-assistance but it seems you should have posted in the #newbies:slight_smile: as you asked for more than a general information … Changed !

Buddy, open up the package manager and install it from there. Or do it from terminal:
sudo pacman -S linux419-headers

Now, did you enabled AUR or not? I’ll assume you didn’t, so run from terminal:
sudo pacman -S trizen base-devel --needed
then
trizen -S rtl8821ce-dkms-git --noconfirm
reboot.

1 Like

Thanks for being kind enough to help with all this,it means a lot :slight_smile:

Enter a selection (default=all): trizen -S rtl8821ce-dkms-git --noconfirm
error: invalid number: trizen

The first command runed just fine,this one however displays this message.

Yes, you have to press Enter and confirm all to install them :slight_smile:

Done.Still no wi-fi tho.

Did you reboot?

yes,still nothing

Did the rtl88821ce-dkms-git package install correctly?

What is the terminal output of:
dkms status

filip@filip-pc ~]$ dkms status
rtl8821ce, 1.0.1.r25.g5eee0cf: added

Have you enabled it in the Network applet? :slight_smile:

What does ip addr in a terminal say?

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 10:62:e5:8e:37:ef brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.39/24 brd 192.168.1.255 scope global dynamic noprefixroute enp2s0
       valid_lft 320sec preferred_lft 320sec
    inet6 fe80::af2e:cd6:666a:f099/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

nothing new appears in the applet

pacman -Qsq linux | grep linux | grep -v -E '(arch|util|sys|api|firmware)' | grep -v nvidia
1 Like

Try this commands one by one, then reboot

sudo modprobe wl
sudo rfkill unblock all
sudo depmod -a
sudo mkinitcpio -P

Also, did the dkms package is installed?
Hope @tbg will salvage the situation here :wink:

[filip@filip-pc ~]$ sudo modprobe wl
[sudo] password for filip: 
modprobe: FATAL: Module wl not found in directory /lib/modules/4.19.8-2-MANJARO