[SOLVED] Recently installed questionable login screen theme, it broke and now I can't login (KDE)

@Ludrew

If you cannot boot up the installed OS, boot up a liveOS and provide from terminal

sudo parted -l
sudo blkid

Then go to liveOS file manager and look into the installed manjaro OS partition.
From there, print out contents of

/etc/fstab
/etc/mkinitcpio.conf
/etc/default/grub

note:
/etc/mkinitcpio.conf --> just the HOOKS line will do
/etc/default/grub --> just the GRUB_CMDLINE_LINUX_DEFAULT= line will do.

I did all of this (have not done your previous post where you go to bed for the day) and took pictures. I uploaded them on imgur at https://imgur.com/a/VKDfv55.

However, booting into my liveOS, I was able to retrieve the files that I really needed (several hours worth of code), so I no longer really need to get my Manjaro partition working again. Now, I really just want to figure out what this problem is and get everything properly setup so that I don't run into this issue again or other severe problems in the future.

I am entirely open to delete the partition if need be. I figure something is wrong with my GRUB setup. I have a dual-boot with windows 10 and Manjaro. A few months ago, I had Ubuntu 18.04 installed on the partition Manjaro is now on, but overwrote it through the partitioning tool in the Manjaro installer. There still exists a tiny boot partition for Ubuntu on my hard drive that I haven't gotten rid of, maybe that is the problem?

In my last post where I replied to @gohlip, I did those commands you previously posted and put the results in that imgur link. I also listed some (probably) relevant information about my setup.

  1. I think we tried(?) changing the theme earlier and it didn't work, but if not, I don't know how to change it inside the tty.

  2. Honestly, I would rather just delete the partition than do all that. Especially since, and I said this in my last post, I got the important files that I needed to get by booting into a liveOS. And there isn't anything I have saved on there that I really need anymore because of that.

From your last few screen shots, you are in your installed OS (prompt) not the liveOS.
You can boot into the installed OS now.
The errors show xorg/xserver issues.
However, I am not good in these things (xorg/xserver) and if someone else can help, that will be best.
To fix it, again go into prompt (use '3' at linux line - hope you know this time) and use the commands the people here give you.

If you can tell them what your graphic card is, and whether any dual graphic cards, it will be good.
The best info would be

inxi -G
mhwd -l
mhwd -li

ps: my (unexpert) advice (only in the case of non-dual or fancy graphic cards)
if nvidia use non-free; if amd, use free
to fix , I (nonexpert) do this
remove all drivers in 'mhwd -li'
sudo pacman -Syyuu
install the appropriate driver (just one)
do again 'pacman -Syu' (to fix missing xorg/xserver, if required)

2 Likes

What is left now is to verify updated system and troubleshoot video drivers.
@gohlip is correct.
Delete pacman lock and retry update

sudo rm /var/lib/pacman/db.lck
sudo pacman -Syu

Reboot.
If sddm fails, go to TTY and try startx.
Post info

inxi -SMGxxxz
mhwd -li
cat /var/log/Xorg.0.log
1 Like

After I removed pacman, I am getting several "error: failed retrieving file 'multilib.db'" messages when I put in sudo pacman -Syu. At the end it says

error: failed to update multilib (invalid url for the server)
error: failed to synconize all databases

I may not have a connection, but when I type in ping google.com, I am getting

ping: www.google.com: name or service not known.

Try again.
If it always fails try recreate mirrorlist and post errors, if any.

sudo pacman-mirrors -f 12
1 Like

Even after recreating mirrorlist, I get the same error as before. Failed to synchronize all databases. At this point I am very close to just installing manjaro over this partition and being done with it. As a note I guess, this laptop has an Nvidia 940mx video card.

Please close this thread. I just went ahead and deleted all my partitions, reinstalled windows, then installed Arch and everything works good again. I figured out that the underlying issue was that my EFI partition had been corrupted, and without knowing how go into it and make the changes necessary to fix the problem, the easiest solution was to just delete it and start over. Thank you all for your help.

That's easy, right @AgentS ? No need to reinstall.
And we knew about the sddm theme as a red herring.
If we had known about it and has the info we requested from the start.

I had thought about letting this pass and just move on.
But somehow... right now, I'm a bit petulant.

I'll take a break. A short break. A Kit Kat break.

1 Like

I believe it was a system "corruption" problem, not really EFI or a simple sddm.
Also summer heat affects everything. :wink:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by