[SOLVED] Recently installed questionable login screen theme, it broke and now I can't login (KDE)

startkde did not do anything (no message at all) unfortunately.

Check permissions

ls -la

I'm not sure what I'm looking for here. It says "total 148" with a long list.

For a little more context, the SDDM theme I downloaded was the most downloaded one on the list -- the Mac Mojave theme. I was wondering why it only had 3/5 stars. Now I know I guess.

Did you try replacing the theme section of your sddm.conf file with the one I posted above?

I'm not sure how to do that.

  1. Boot to prompt this way (not tty)
    at grub manjaro menuentry press 'e'
    arrow down to linux line and add '3' (no apostrophes)
    boot to prompt
    login with password.
  2. at prompt, issue these commands
sudo mv /etc/sddm.conf /etc/sddm.conf.old
sudo cp /usr/lib/sddm/sddm.conf.d/default.conf /etc/sddm.conf
startx
2 Likes

Okay, so I open the GRUB command line (after pressing e at menu) and I have no idea where to put 3.

.
.
.
.

.

I don't know what the linux line is, so I can't navigate in relation to it.

I use that as well since a few days, and downloaded it the same way as you, from within KDE Settings, and it just works.
Didn't you encounter any error messages when you were trying to install it?

2nd last line. The last line is the initrd line. For example...

From

		linux	/boot/vmlinuz-5.2-x86_64 root=UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 rw  quiet
		initrd	/boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-5.2-x86_64.img

To

		linux	/boot/vmlinuz-5.2-x86_64 root=UUID=2b259af0-f5c5-4b3d-a2f6-19f1d83ee208 rw  quiet 3
		initrd	/boot/intel-ucode.img /boot/amd-ucode.img /boot/initramfs-5.2-x86_64.img
1 Like

I did not encounter any error message upon installation, it worked fine for a few days and I performed some updates via octopi, then when I was in Netflix the theme crashed when it went into the lock screen when I went afk. It gave me something like "theme crashed, please press ctrl + alt + f2 and type (some command that didn't work)".

Yup, while waiting for OP, I downloaded said theme and it works. No problem.
And ...I did my commands above and I got back my default.
And change back some things like autologin to get back to my preferred one.

So since I've nothing to do anymore, and the OP won't try my commands.
Good bye and have a good day.

And oh... I am going to mark my post above as solution so others here can use it.
Even if the OP won't. Muahahahaha !!!

2 Likes

What? I just used those commands after seeing where the linux line was. I got the same error as before when using startx. "Since the OP won't try my commands", I literally cannot get into my laptop. What purpose would ignoring your instructions do for me? I appreciate your help, but there's no need to be rude. I am just inexperienced.

After trying this, I get the same error as before when I use startx. My Linux line does look different, though. Instead of stopping at "rw quiet" the line continues into "rw quiet resume=UUID=fe0e3e21-9489-4d9e-b37b-dda65d2833\cd"

remove also (backspace to remove)
resume=UUID=fe0e3e21-9489-4d9e-b37b-dda65d2833\cd"
taking care not to remove 'rw'
remember add '3'
when booted , also do
sudo update-grub
you have bad grub.cfg.

3\cd"

cd??
Ho ho ho.

Me rude? ha ha ha.

1 Like

I did what you said, deleted that stuff and added 3, hit f10 to start and it didn’t seem to help. I took some pictures of my screen. Forgive my incredibly reflective screen and photography skills. Uploading: 290AE09A-1C13-40E6-ABF4-378A699FE0D3.jpeg... Uploading: A6D60E6C-86A3-432C-8A26-FD84D55B877D.jpeg... Uploading: B1591B92-4BE4-4C03-BBC5-DF301D5A803A.jpeg...

  1. I cannot see your link. Please resend link.
  2. I think there's more than just the installation of the sddm theme that is the problem.
    Your resume (swap) UUID as noted is not right.
    resume=UUID=fe0e3e21-9489-4d9e-b37b-dda65d2833\cd
  3. If you think you can follow, try using this first post and see if you can boot up.
    You have to use the [More Complicated Setup] to boot as your grub.cfg, I think, is kaput.
    And there's no need to use resume=UUID=xxxxxxx in that link; it isn't required.
    Hopefully that's all there is in the problem. But there may be more and you may still face difficulties.
  4. If you can boot up, provide from the terminal
sudo blkid
sudo parted -l
grep resume /etc/default/grub
grep keymap /etc/mkinitcpio.conf
cat /etc/fstab

That's asking a lot of info but I suspect there's some very unusual setup you may have.
5. Lastly, it may just be easier for you to reinstall.
But please note there is a difference in installing uefi and bios-legacy.
Be clear what your system and disk are in
msdos/gpt or uefi/bios-legacy and install appropriately.
Would be good to go through the installation wiki one more time.

In short, I think the sddm theme may just be a red herring (not the issue) that cause the problem you are facing. It is just coincidental that while you install sddm theme, your problem arise. Of course, we cannot be certain of that.

But good luck. We'll be around if you need more help.
Oh...it's late for me here. Good night.

2 Likes

I agree with @gohlip that sddm theme may not be the actual problem.
You need to check and verify proper setup for these:

  1. Home folder permissions. How?
    Run the command I posted above and check hidden files/folders permissions. Or post the output.
  2. Confirm packages are updated. How?
sudo pacman -Syu
systemctl poweroff
  1. Try another sddm theme (clever! )
  2. Confirm your swap/hibernation partition UUID is written properly in /etc/default/grub. How? Follow last post from @gohlip advice.
1 Like

Forum kindly sponsored by Bytemark