[SOLVED] [R8168] Ethernet cannot connect after resume from sleep

Hi!

After a recent update, my ethernet only works after a cold start.

If I suspend and resume my system - it's stuck in "Setting network address" phase and never connects:

image

So right now I'm using my phone in USB tethering mode to make my PC connect to my router via WiFi :stuck_out_tongue:

Has anybody got a similar problem?

Here's my system info:

$ inxi -Fxz
System:    Host: unfa-desktop Kernel: 4.19.49-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.3.0 Desktop: KDE Plasma 5.15.5 
           Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: PRIME B350M-A v: Rev X.0x serial: <filter> UEFI [Legacy]: American Megatrends 
           v: 4207 date: 12/07/2018 
CPU:       Topology: 8-Core model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen rev: 1 L2 cache: 4096 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm bogomips: 95848 
           Speed: 2299 MHz min/max: 1550/3000 MHz Core speeds (MHz): 1: 2299 2: 2292 3: 2625 4: 2695 5: 1277 6: 1276 7: 1300 
           8: 1274 9: 1727 10: 1614 11: 1322 12: 1365 13: 2818 14: 2784 15: 1286 16: 1282 
Graphics:  Device-1: NVIDIA GP106 [GeForce GTX 1060 6GB] vendor: Micro-Star MSI driver: nvidia v: 430.14 bus ID: 08:00.0 
           Display: x11 server: X.Org 1.20.5 driver: nvidia resolution: 1920x1080~60Hz, 1920x1080~60Hz 
           OpenGL: renderer: GeForce GTX 1060 6GB/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 direct render: Yes 
Audio:     Device-1: NVIDIA GP106 High Definition Audio vendor: Micro-Star MSI driver: snd_hda_intel v: kernel bus ID: 08:00.1 
           Device-2: Advanced Micro Devices [AMD] Family 17h HD Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 0a:00.3 
           Device-3: Logitech HD Pro Webcam C920 type: USB driver: snd-usb-audio,uvcvideo bus ID: 5-3:3 
           Device-4: BEHRINGER type: USB driver: snd-usb-audio bus ID: 3-1:2 
           Device-5: AKAI Professional M.I. type: USB driver: snd-usb-audio bus ID: 5-1.4:6 
           Sound Server: ALSA v: k4.19.49-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.047.01-NAPI 
           port: f000 bus ID: 06:00.0 
           IF: enp6s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: enp1s0f0u3 state: unknown speed: N/A duplex: N/A mac: <filter> 
Drives:    Local Storage: total: 2.05 TiB used: 1.57 TiB (76.3%) 
           ID-1: /dev/sda vendor: Western Digital model: WD20EZRZ-00Z5HB0 size: 1.82 TiB 
           ID-2: /dev/sdb vendor: Transcend model: TS256GMTS400 size: 238.47 GiB 
Partition: ID-1: / size: 222.37 GiB used: 79.96 GiB (36.0%) fs: btrfs dev: /dev/sdb4 
           ID-2: /home size: 222.37 GiB used: 79.96 GiB (36.0%) fs: btrfs dev: /dev/sdb4 
           ID-3: swap-1 size: 15.62 GiB used: 85.5 MiB (0.5%) fs: swap dev: /dev/sdb2 
Sensors:   System Temperatures: cpu: 47.0 C mobo: N/A gpu: nvidia temp: 41 C 
           Fan Speeds (RPM): cpu: 0 gpu: nvidia fan: 35% 
Info:      Processes: 441 Uptime: 1d 18m Memory: 31.41 GiB used: 11.55 GiB (36.8%) Init: systemd Compilers: gcc: 8.3.0 
           Shell: bash v: 5.0.7 inxi: 3.0.34

maybe you should uninstall r8168 from manjaro settings manager.

1 Like

I've uninstalled it, but now the ethernet adapter is not detected at all.
I've reinstalled it - no change. Stilll breaks after suspend/resume.

Here's dmesg output after resuming:

[  190.364377] WARNING: CPU: 2 PID: 803 at kernel/workqueue.c:2911 __flush_work+0x1bd/0x1d0
[  190.364379] Modules linked in: snd_seq_dummy snd_seq_midi snd_hrtimer snd_seq_midi_event snd_seq fuse uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 videobuf2_common videodev snd_hda_codec_hdmi mousedev input_leds media snd_usb_audio snd_usbmidi_lib snd_rawmidi snd_seq_device edac_mce_amd kvm snd_hda_codec_realtek snd_hda_codec_generic eeepc_wmi irqbypass asus_wmi uinput crct10dif_pclmul snd_hda_intel sparse_keymap crc32_pclmul nvidia_drm(POE) rfkill ghash_clmulni_intel pcbc wmi_bmof nvidia_modeset(POE) snd_hda_codec aesni_intel drm_kms_helper snd_hda_core aes_x86_64 crypto_simd cryptd snd_hwdep r8168(OE) glue_helper pcspkr snd_pcm drm k10temp snd_timer sp5100_tco snd i2c_piix4 gpio_amdpt evdev soundcore pinctrl_amd wmi agpgart pcc_cpufreq mac_hid ccp syscopyarea acpi_cpufreq sysfillrect
[  190.364418]  sysimgblt rng_core fb_sys_fops nvidia(POE) ipmi_devintf ipmi_msghandler vboxpci(OE) vboxnetflt(OE) vboxnetadp(OE) vboxdrv(OE) acpi_call(OE) sg crypto_user ip_tables x_tables btrfs libcrc32c crc32c_generic xor raid6_pq hid_generic usbhid hid sd_mod ahci libahci libata xhci_pci crc32c_intel scsi_mod xhci_hcd
[  190.364454] CPU: 2 PID: 803 Comm: NetworkManager Tainted: P           OE     4.19.49-1-MANJARO #1
[  190.364456] Hardware name: System manufacturer System Product Name/PRIME B350M-A, BIOS 4207 12/07/2018
[  190.364458] RIP: 0010:__flush_work+0x1bd/0x1d0
[  190.364459] Code: 66 0f 1f 44 00 00 45 31 ed eb 81 8b 4d 00 48 8b 55 08 83 e1 08 48 0f ba 6d 00 03 80 c9 f0 e9 4c ff ff ff 0f 0b e9 62 ff ff ff <0f> 0b 45 31 ed e9 58 ff ff ff e8 14 4c fe ff 0f 1f 40 00 0f 1f 44
[  190.364460] RSP: 0018:ffffa76a43c7f378 EFLAGS: 00010246
[  190.364461] RAX: 0000000000000000 RBX: ffff9d7923bd6c58 RCX: 0000000000000000
[  190.364462] RDX: 0000000000000001 RSI: 0000000000000001 RDI: ffff9d7923bd6c58
[  190.364463] RBP: ffff9d7923bd6c58 R08: 0000002c3be7d400 R09: ffff9d793a9f9000
[  190.364463] R10: 0000000000000000 R11: ffff9d793eaa0be8 R12: 0000000000000001
[  190.364464] R13: 0000000000000001 R14: ffffffff9f6a01a0 R15: ffffffffc1ab90a0
[  190.364465] FS:  00007f8c754c7d80(0000) GS:ffff9d793ea80000(0000) knlGS:0000000000000000
[  190.364467] CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[  190.364468] CR2: 00007f170400fc30 CR3: 00000007eac12000 CR4: 00000000003406e0
[  190.364469] Call Trace:
[  190.364473]  ? _synchronize_rcu_expedited+0x266/0x320
[  190.364478]  ? wait_woken+0x80/0x80
[  190.364481]  ? drain_workqueue+0x120/0x120
[  190.364484]  __cancel_work_timer+0x10a/0x190
[  190.364487]  ? fq_codel_reset+0x9f/0xd0
[  190.364489]  ? qdisc_reset+0x1e/0xe0
[  190.364494]  rtl8168_close+0x44/0x1f0 [r8168]
[  190.364498]  __dev_close_many+0x9c/0x110
[  190.364501]  __dev_change_flags+0xc2/0x1f0
[  190.364503]  dev_change_flags+0x21/0x60
[  190.364506]  do_setlink+0x30b/0xe90
[  190.364523]  ? btrfs_get_fs_root.part.12+0xf6/0x170 [btrfs]
[  190.364526]  ? kmem_cache_alloc_trace+0x176/0x1d0
[  190.364545]  ? prelim_ref_insert+0x128/0x260 [btrfs]
[  190.364566]  ? resolve_indirect_refs+0x20b/0x7b0 [btrfs]
[  190.364584]  ? btrfs_get_token_64+0x103/0x120 [btrfs]
[  190.364586]  rtnl_newlink+0x50f/0x820
[  190.364598]  ? generic_bin_search.constprop.16+0xeb/0x1a0 [btrfs]
[  190.364612]  ? btrfs_search_slot+0x858/0x9f0 [btrfs]
[  190.364616]  ? preempt_count_add+0x79/0xb0
[  190.364618]  ? _raw_spin_unlock+0x16/0x30
[  190.364633]  ? btrfs_lookup_fs_root+0x35/0x40 [btrfs]
[  190.364647]  ? btrfs_get_fs_root.part.12+0xf6/0x170 [btrfs]
[  190.364649]  ? kmem_cache_alloc_trace+0x176/0x1d0
[  190.364661]  ? prelim_ref_insert+0x128/0x260 [btrfs]
[  190.364674]  ? resolve_indirect_refs+0x20b/0x7b0 [btrfs]
[  190.364677]  ? __inc_numa_state+0x23/0x70
[  190.364679]  ? cpumask_next_and+0x19/0x20
[  190.364681]  ? find_busiest_group+0x749/0xb10
[  190.364684]  ? __wake_up_common+0x50/0x140
[  190.364686]  ? _raw_spin_unlock_irqrestore+0x20/0x40
[  190.364687]  rtnetlink_rcv_msg+0x126/0x390
[  190.364689]  ? __wake_up_common+0x77/0x140
[  190.364690]  ? rtnl_calcit.isra.11+0x110/0x110
[  190.364692]  netlink_rcv_skb+0x4c/0x120
[  190.364694]  netlink_unicast+0x196/0x240
[  190.364695]  netlink_sendmsg+0x202/0x3c0
[  190.364697]  sock_sendmsg+0x33/0x40
[  190.364699]  ___sys_sendmsg+0x295/0x2f0
[  190.364701]  ? _raw_spin_unlock_irqrestore+0x20/0x40
[  190.364702]  ? try_to_wake_up+0x233/0x480
[  190.364705]  ? pollwake+0x74/0x90
[  190.364705]  ? wake_up_q+0x70/0x70
[  190.364708]  ? __audit_syscall_exit+0x22a/0x290
[  190.364710]  ? __fget+0x6e/0xa0
[  190.364713]  __sys_sendmsg+0x57/0xa0
[  190.364717]  do_syscall_64+0x65/0x190
[  190.364719]  entry_SYSCALL_64_after_hwframe+0x44/0xa9
[  190.364721] RIP: 0033:0x7f8c76f58207
[  190.364722] Code: c3 66 90 41 54 41 89 d4 55 48 89 f5 53 89 fb 48 83 ec 10 e8 eb ec ff ff 44 89 e2 48 89 ee 89 df 41 89 c0 b8 2e 00 00 00 0f 05 <48> 3d 00 f0 ff ff 77 35 44 89 c7 48 89 44 24 08 e8 24 ed ff ff 48
[  190.364723] RSP: 002b:00007fff11d5cae0 EFLAGS: 00000293 ORIG_RAX: 000000000000002e
[  190.364725] RAX: ffffffffffffffda RBX: 000000000000000a RCX: 00007f8c76f58207
[  190.364725] RDX: 0000000000000000 RSI: 00007fff11d5cb20 RDI: 000000000000000a
[  190.364726] RBP: 00007fff11d5cb20 R08: 0000000000000000 R09: 0000000000000000
[  190.364727] R10: 000055a47e633010 R11: 0000000000000293 R12: 0000000000000000
[  190.364728] R13: 0000000000000000 R14: 00007fff11d5cc80 R15: 00007fff11d5cc7c
[  190.364730] ---[ end trace f274460ee85e3daa ]---
[  190.382074] audit: type=1130 audit(1561295223.962:46): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  190.569199] audit: type=1130 audit(1561295224.148:47): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  190.592262] PM: suspend entry (deep)
[  190.592264] PM: Syncing filesystems ... done.
[  193.511039] Freezing user space processes ... (elapsed 0.004 seconds) done.
[  193.515279] OOM killer disabled.
[  193.515279] Freezing remaining freezable tasks ... (elapsed 0.001 seconds) done.
[  193.516540] Suspending console(s) (use no_console_suspend to debug)
[  193.517445] serial 00:03: disabled
[  193.533529] sd 0:0:0:0: [sda] Synchronizing SCSI cache
[  193.533688] sd 0:0:0:0: [sda] Stopping disk
[  193.550235] sd 11:0:0:0: [sdb] Synchronizing SCSI cache
[  193.555124] sd 11:0:0:0: [sdb] Stopping disk
[  194.590436] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590438] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590439] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590440] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590441] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590442] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590443] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590444] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590445] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590446] snd_hda_intel 0000:08:00.1: spurious response 0x0:0x0, last cmd=0x5f2f0b
[  194.590453] snd_hda_codec_hdmi hdaudioC0D0: HDMI: invalid ELD data byte 11
[  195.120676] ACPI: Preparing to enter system sleep state S3
[  195.438132] PM: Saving platform NVS memory
[  195.438175] Disabling non-boot CPUs ...
[  195.478868] smpboot: CPU 1 is now offline
[  195.545292] smpboot: CPU 2 is now offline
[  195.582067] smpboot: CPU 3 is now offline
[  195.622412] smpboot: CPU 4 is now offline
[  195.692245] smpboot: CPU 5 is now offline
[  195.742268] smpboot: CPU 6 is now offline
[  195.772148] smpboot: CPU 7 is now offline
[  195.801995] smpboot: CPU 8 is now offline
[  195.851953] smpboot: CPU 9 is now offline
[  195.901975] smpboot: CPU 10 is now offline
[  195.958592] smpboot: CPU 11 is now offline
[  195.992078] smpboot: CPU 12 is now offline
[  196.031801] smpboot: CPU 13 is now offline
[  196.081840] smpboot: CPU 14 is now offline
[  196.121721] smpboot: CPU 15 is now offline
[  196.123062] ACPI: Low-level resume complete
[  196.123106] PM: Restoring platform NVS memory
[  196.123647] Enabling non-boot CPUs ...
[  196.123690] x86: Booting SMP configuration:
[  196.123690] smpboot: Booting Node 0 Processor 1 APIC 0x1
[  196.125970] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.126005]  cache: parent cpu1 should not be sleeping
[  196.126076] microcode: CPU1: patch_level=0x08001137
[  196.126297] CPU1 is up
[  196.126319] smpboot: Booting Node 0 Processor 2 APIC 0x2
[  196.128548] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.128581]  cache: parent cpu2 should not be sleeping
[  196.128650] microcode: CPU2: patch_level=0x08001137
[  196.128753] CPU2 is up
[  196.128763] smpboot: Booting Node 0 Processor 3 APIC 0x3
[  196.131001] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.131033]  cache: parent cpu3 should not be sleeping
[  196.131098] microcode: CPU3: patch_level=0x08001137
[  196.131217] CPU3 is up
[  196.131228] smpboot: Booting Node 0 Processor 4 APIC 0x4
[  196.133589] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.133621]  cache: parent cpu4 should not be sleeping
[  196.133697] microcode: CPU4: patch_level=0x08001137
[  196.133830] CPU4 is up
[  196.133840] smpboot: Booting Node 0 Processor 5 APIC 0x5
[  196.136088] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.136125]  cache: parent cpu5 should not be sleeping
[  196.136200] microcode: CPU5: patch_level=0x08001137
[  196.136358] CPU5 is up
[  196.136369] smpboot: Booting Node 0 Processor 6 APIC 0x6
[  196.138651] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.138691]  cache: parent cpu6 should not be sleeping
[  196.138782] microcode: CPU6: patch_level=0x08001137
[  196.138938] CPU6 is up
[  196.138950] smpboot: Booting Node 0 Processor 7 APIC 0x7
[  196.141198] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.141231]  cache: parent cpu7 should not be sleeping
[  196.141315] microcode: CPU7: patch_level=0x08001137
[  196.141490] CPU7 is up
[  196.141504] smpboot: Booting Node 0 Processor 8 APIC 0x8
[  196.143812] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.143857]  cache: parent cpu8 should not be sleeping
[  196.143943] microcode: CPU8: patch_level=0x08001137
[  196.144198] CPU8 is up
[  196.144211] smpboot: Booting Node 0 Processor 9 APIC 0x9
[  196.146509] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.146551]  cache: parent cpu9 should not be sleeping
[  196.146636] microcode: CPU9: patch_level=0x08001137
[  196.146873] CPU9 is up
[  196.146885] smpboot: Booting Node 0 Processor 10 APIC 0xa
[  196.149190] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.149236]  cache: parent cpu10 should not be sleeping
[  196.149320] microcode: CPU10: patch_level=0x08001137
[  196.149578] CPU10 is up
[  196.149591] smpboot: Booting Node 0 Processor 11 APIC 0xb
[  196.151913] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.151959]  cache: parent cpu11 should not be sleeping
[  196.152040] microcode: CPU11: patch_level=0x08001137
[  196.152336] CPU11 is up
[  196.152352] smpboot: Booting Node 0 Processor 12 APIC 0xc
[  196.154669] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.154714]  cache: parent cpu12 should not be sleeping
[  196.154799] microcode: CPU12: patch_level=0x08001137
[  196.155098] CPU12 is up
[  196.155111] smpboot: Booting Node 0 Processor 13 APIC 0xd
[  196.157391] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.157435]  cache: parent cpu13 should not be sleeping
[  196.157536] microcode: CPU13: patch_level=0x08001137
[  196.157896] CPU13 is up
[  196.157911] smpboot: Booting Node 0 Processor 14 APIC 0xe
[  196.160216] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.160259]  cache: parent cpu14 should not be sleeping
[  196.160334] microcode: CPU14: patch_level=0x08001137
[  196.160629] CPU14 is up
[  196.160640] smpboot: Booting Node 0 Processor 15 APIC 0xf
[  196.162941] [Firmware Bug]: ACPI MWAIT C-state 0x0 not supported by HW (0x0)
[  196.162985]  cache: parent cpu15 should not be sleeping
[  196.163079] microcode: CPU15: patch_level=0x08001137
[  196.163461] CPU15 is up
[  196.165034] ACPI: Waking up from system sleep state S3
[  196.231771] usb usb1: root hub lost power or was reset
[  196.231773] usb usb2: root hub lost power or was reset
[  196.232207] sd 0:0:0:0: [sda] Starting disk
[  196.232209] sd 11:0:0:0: [sdb] Starting disk
[  196.232674] serial 00:03: activated
[  196.540961] ata5: SATA link down (SStatus 0 SControl 300)
[  196.540982] ata2: SATA link down (SStatus 0 SControl 300)
[  196.543672] ata11: SATA link down (SStatus 0 SControl 300)
[  196.544783] ata6: SATA link down (SStatus 0 SControl 300)
[  196.614148] snd_hda_intel 0000:08:00.1: azx_get_response timeout, switching to polling mode: last cmd=0x006f0900
[  196.700837] ata12: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[  196.702163] ata12.00: configured for UDMA/133
[  199.886465] OOM killer enabled.
[  199.886465] Restarting tasks ... done.
[  199.894573] PM: suspend exit
[  199.906809] audit: type=1130 audit(1561295235.779:48): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=atop comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  199.910041] audit: type=1130 audit(1561295235.783:49): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-suspend comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  199.910055] audit: type=1131 audit(1561295235.783:50): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-suspend comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  199.912207] IPv6: ADDRCONF(NETDEV_UP): enp6s0: link is not ready
[  199.912680] enp6s0: 0xffffa76a4336d000, 60:45:cb:64:2c:ed, IRQ 66
[  199.919485] Process accounting resumed
[  199.964299] IPv6: ADDRCONF(NETDEV_UP): enp6s0: link is not ready
[  200.976337] audit: type=1131 audit(1561295236.849:51): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  202.664326] ata1: SATA link up 6.0 Gbps (SStatus 133 SControl 300)
[  202.696243] ata1.00: configured for UDMA/133
[  202.840510] audit: type=1131 audit(1561295238.713:52): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=tlp-sleep comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  204.036141] r8168: enp6s0: link up
[  204.036168] IPv6: ADDRCONF(NETDEV_CHANGE): enp6s0: link becomes ready
[  204.058992] do_IRQ: 7.34 No irq handler for vector
[  205.037483] r8168: enp6s0: link down
[  208.116154] r8168: enp6s0: link up
[  208.124334] do_IRQ: 7.34 No irq handler for vector
[  249.650816] r8168: enp6s0: link down
[  253.742849] r8168: enp6s0: link up
[  253.751026] do_IRQ: 7.34 No irq handler for vector
[  294.264141] r8168: enp6s0: link down
[  297.342806] r8168: enp6s0: link up
[  297.350988] do_IRQ: 7.34 No irq handler for vector
[  329.312651] audit: type=1130 audit(1561295365.186:53): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  339.890776] r8168: enp6s0: link down
[  339.985787] audit: type=1131 audit(1561295375.859:54): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=NetworkManager-dispatcher comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
[  342.969473] r8168: enp6s0: link up
[  342.977622] do_IRQ: 7.34 No irq handler for vector

Looks like there's some problem with NetworkManager? Hanging CPU cores?

Search "blacklist r8168".

Your problem can also be fixed with a single service file for suspend and resume. The service below will usually fix your suspend issue:

Network Restart Service

Create the following file with a root capable text editor:

/etc/systemd/system/network-restart.service

Add the following contents to the file:

#/etc/systemd/system/network-restart.service
#sudo systemctl enable network-restart.service
#sudo systemctl start network-restart.service
#sudo systemctl stop network-restart.service
#sudo systemctl disable network-restart.service
#systemctl status network-restart.service

[Unit]
Description=Network Suspend/Resume Service 
Before=sleep.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes
ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=-/usr/bin/ip link set enp6s0 down
ExecStop=/usr/bin/sleep 1
ExecStart=-/usr/bin/modprobe -r r8168
ExecStop=/usr/bin/sleep 3
ExecStart=-/usr/bin/modprobe r8168
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/ip link set enp6s0 up
ExecStop=/usr/bin/sleep 2
ExecStop=-/usr/bin/systemctl start NetworkManager
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
ExecStop=/usr/bin/sleep 1
ExecStop=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

[Install]
WantedBy=sleep.target

The sleep units in the service may be reduced, (or eliminated) if you do not like the delay it creates. Be aware though, that doing so may reduce the reliability of the service.

Once you have created and saved the service file, enable the service:

sudo systemctl enable network-restart.service

Then reboot the computer.

For others wishing to adapt this service to their installation (if different than above).

If your adapter's designation is different than โ€œenp6s0โ€ you will need to substitute you own adapterโ€™s ID into the service file.

If you are using a different driver module such as "r8169" you will need to substitute it in place of โ€œr8168โ€ in the service file.

1 Like

I've tried the service route. I know the service did work, becasue the PC was still on for a few good seconds after it switched off the screens. But after resuming the network still doesn't work, so I'll check out the blacklisting route.

Now the same problem expressed on another Manjaro machine - but I wasn't installing any updates!
Is it possible that the networking chips self-update their firmware and break like this?

This is really problematic. I have never had any problems of this nature on any hardware yet.

If that is happening without having done any updates this sounds more like your network/router issue.

I would systematically replace any cat5 cabling with cat 6 cables.

I would also assign a static address to your computer in your routers settings via mac address association.

I would also check to see if you have a router firmware update available,

And always be sure to reboot your router if you experience any strange networking issues.

Thanks, I'll try out everything (even thought I don't really have time to tinker)... This is really frustrating.

I've installed 5.1 kernel, but there's no change.

Now it seems that the second Manjaro PC doesn't have the same problem - it happened once, but not anymore. My main PC still has no network after a suspend/resume cycle though.

Have you tried hibernate instead?

Or, suspending via a terminal command?

I've tried hibernating and suspending from the commandline (systemclt suspend and systemctl hibernate). No change.

But today suddenly - it works again! I have suspended twice so far and the network connection comes back after resuming.

I have no idea why - I did nothing.

1 Like

And today it's bad again. I've tried restarting my router+modem box - but no luck.

A service should correct this issue for you.

Run the commands below before and after suspend/resume:

Do not cut and paste all the commands together at once.

Enter each command individually giving a second or two between entering commands.

Run these commands before attempting a suspend:

nmcli networking off

sudo systemctl stop NetworkManager

sudo ip link set enp6s0 down

sudo modprobe -r r8168

Once you have finished running those commands put the computer to sleep

Leave the computer suspended 20 - 30 seconds and then bring it out of suspend.

Run the following commands (if possible) after resuming:

sudo modprobe r8168

sudo ip link set enp6s0 up

sudo systemctl start NetworkManager

nmcli networking on

If running those commands results in resuming successfully (with full network connectivity afterwards) then a service should correct this issue. Be sure you have your adapters correct designation in the above commands. You can find this information with the command inxi -n. If your adapters designation is different than "enp6s0", then substitute your ID in the above commands. If your module is different than "r8168" then be sure to substitute it as well.

Let me know how that goes, this should be correctable.

Please post the full input and output of every command run before and after suspend/resume if the test was unsuccessful.

2 Likes

This worked! You're a wizard!

I got no output from any of the commands - this probably means no errors.

I don't know why but the sole service I made before didn't seem to work, but these commands did.
I'm going to try it again (it seems to run the same commands) - or should I do something differently?

Oh, the previous service file was not identical.
I've tried modifying the service file to fix that (though I have no idea what I'm doing).

#/etc/systemd/system/network-restart.service
#sudo systemctl enable network-restart.service
#sudo systemctl start network-restart.service
#sudo systemctl stop network-restart.service
#sudo systemctl disable network-restart.service
#systemctl status network-restart.service

[Unit]
Description=Network Suspend/Resume Service
Before=sleep.target
StopWhenUnneeded=yes

[Service]
User=root
Type=oneshot
RemainAfterExit=yes
ExecStartPre=-/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking off'
ExecStart=/usr/bin/sleep 1
ExecStart=/usr/bin/systemctl stop NetworkManager
ExecStart=/usr/bin/sleep 1
ExecStart=/usr/bin/ip link set enp6s0 down
ExecStart=/usr/bin/sleep 1
ExecStart=/usr/bin/modprobe -r r8168
ExecStart=/usr/bin/sleep 3
ExecStop=/usr/bin/modprobe r8168
ExecStop=/usr/bin/sleep 2
ExecStop=/usr/bin/ip link set enp6s0 up
ExecStop=/usr/bin/sleep 2
ExecStop=/usr/bin/systemctl start NetworkManager
ExecStop=/usr/bin/sleep 1
ExecStop=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli networking on'
#ExecStop=/usr/bin/sleep 1
#ExecStop=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi off'
#ExecStop=/usr/bin/sleep 1
#ExecStop=/usr/bin/sudo -u $USER /bin/bash -lc 'nmcli r wifi on'

[Install]
WantedBy=sleep.target

Some commands were prefixed with - and ExecStart and ExecStop seemed misplaced here and there.

2 Likes

Alright. The above seems to work!

The only problem is that this takes place before the processes are frozen - so any network connections get severed before suspending. I there a way to correct that?

I had the same problem on a completely different machine running Manajro - the same fix worked, I just had to use a different ethernet device name.

Using ip addr shown me all network interfaces.

Test out kernel 4.14 to check for improvement if you are still having issues.

Unfortunately I'm holding back from updates right now, because I had other issues. I rolled back and I'm waiting.

You should be able to install a kernel from the command line without performing a full system update using mhwd.

sudo mhwd-kernel -i linux414
1 Like

I'm currently running Kernel 4.19 - so that'd be a downgrade, is that really what you meant?

Forum kindly sponsored by