[Solved] Problems with scrolling using touchpad after update

drivers
xfce
libinput
touchpad

#1

Hi, I’m new to this forum :slight_smile:

I’m using Manjaro for a while, and didn’t run into any major problems that weren’t already solved online.

My current problem that I can’t seem to find help for online, appeared right after I did the last update. Before the update the scrolling functionality on my touchpad was flawless. Now - it’s more like some percent chance that it will recognize the two finger scrolling as a scroll gesture, and most of the time the mouse is only moving. So while I’m trying to initiate the scrolling, I’m just trying that with two fingers repeatedly until it happens. Some times though, it starts right away, but other times it takes more than 10 trials.

I tried installing xf86-input-synaptics, but it makes my mouse acceleration and speed really bad and far from precise, and I’ll have to manually edit config files for the natural scroll direction.

I’m asking f you know what created this bug for me, or how to solve it. It’s not that broken like this, but I’m losing my patience.

Thanks!

Below is the dump from running the - inxi -Fxzc0 command.

System:    Host: atanas-pc Kernel: 4.9.20-1-MANJARO x86_64 (64 bit gcc: 6.3.1)
           Desktop: Xfce 4.12.3 (Gtk 2.24.31) Distro: Manjaro Linux
Machine:   Device: laptop System: Acer product: Aspire E5-575G v: V1.15
           Mobo: Acer model: Ironman_SK v: V1.15 UEFI [Legacy]: Insyde v: V1.15 date: 09/19/2016
Battery    BAT1: charge: 26.1 Wh 100.0% condition: 26.1/28.0 Wh (93%)
           model: PANASONIC AS16A5K status: Full
CPU:       Dual core Intel Core i5-7200U (-HT-MCP-) cache: 3072 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 10852
           clock speeds: max: 3100 MHz 1: 807 MHz 2: 807 MHz 3: 799 MHz 4: 809 MHz
Graphics:  Card-1: Intel Device 5916 bus-ID: 00:02.0
           Card-2: NVIDIA Device 179c bus-ID: 01:00.0
           Display Server: X.Org 1.19.3 drivers: intel (unloaded: nvidia) Resolution: 1920x1080
           GLX Renderer: Mesa DRI Intel HD Graphics 620 (Kabylake GT2)
           GLX Version: 3.0 Mesa 17.0.2 Direct Rendering: Yes
Audio:     Card Intel Device 9d71 driver: snd_hda_intel bus-ID: 00:1f.3
           Sound: Advanced Linux Sound Architecture v: k4.9.20-1-MANJARO
Network:   Card-1: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter
           driver: ath10k_pci bus-ID: 03:00.0
           IF: wlp3s0 state: up mac: <filter>
           Card-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.043.02-NAPI port: 3000 bus-ID: 04:00.1
           IF: enp4s0f1 state: down mac: <filter>
Drives:    HDD Total Size: 128.0GB (46.3% used)
           ID-1: /dev/sda model: KINGSTON_RBUSNS8 size: 128.0GB
Partition: ID-1: / size: 59G used: 19G (33%) fs: ext4 dev: /dev/sda1
           ID-2: /home size: 57G used: 36G (67%) fs: ext4 dev: /dev/sda3
           ID-3: swap-1 size: 1.74GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 37.5C mobo: N/A
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 192 Uptime: 2:02 Memory: 2472.7/11888.9MB Init: systemd Gcc sys: 6.3.1
           Client: Shell (bash 4.4.121) inxi: 2.3.8


[Stable Update] 2017-04-02 - Mesa-Stack, Kernels, Plasma, Firefox
#2

Now, after update, I have the same problem. Need help.


#3

As a temporary workaround you can try

  1. remove synaptics driver and downgrade libinput.

  2. downgrade the kernel.

Only try 2 if 1 doesn’t work. If 2 works, try different kernels to see if one of them works better.

You can also rollback the update that caused the issue, if you have trouble finding the cause and need a more working environment to dissect the problem.

But in general, my advice is: find the package that caused the issue and downgrade it. Update again later to see if the issue has been resolved.


#4

Hey, it seems I got the same problem after update. Excellent, that’ll help in troupleshooting…

The culprit is libinput package. Just donwgrade it with

donwgrade libinput

If you don’t have donwgrade, install it with

sudo pacman -Sy donwgrade

You should report this issue so it gets fixed on the next update. Someone will probably report it, because it seems to consistently happen with update.


#5

Wonderful. Your solution worked for me. Thanks.

@juzles
If downgrade libinput also worked for you, please set this topic to solved.

@Chrysostomus
Unfortunately my screen’s brightness Fn keys on my notebook don’t work anymore after update. But I’m sure I’ll find
a solution with forum search. It’s curious, because the other Fn keys for volume control a keyboard backlight work fine.


#6

Found a solution. Now, my brightness Fn keys, work fine:


#7

Thanks, downgrading libinput fixed the issue.

I guess I’ll keep this old version for a while until it gets fixed or something…


#8

See: Touchpad with problem after last update [SOLVED]


#9

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.