[SOLVED] Problems with Grub and /boot/efi after install Manjaro KDE 17.0.1

Hello everybody.
I tried to install Manjaro KDE as the second system on my PC alongside with Windows 10 (UEFI+GPT; Secure Boot: off).
Earlier I had installed Ubuntu, Fedora and Antergos with the same configurations and everything was installed without problems. But something went wrong.
IMAGE
Upon completion of the installation, Calamares issued the following error:
IMAGE
After reboot I was met by a minimal bash.
Then I came across a possible solution to this problem here: Solution for Calamares UEFI issue on 17-dev/alpha.
I performed the following actions:

[manjaro@manjaro ~]$ sudo su
[root@manjaro manjaro]# mount /dev/sda6 /mnt
[root@manjaro manjaro]# mount /dev/sda8 /mnt/home
[root@manjaro manjaro]# mount /dev/sda2 /mnt/boot/efi
[root@manjaro manjaro]# manjaro-chroot /mnt/ /bin/bash
[root@manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
Installing for x86_64-efi platform.
Installation finished. No error reported.
[root@manjaro /]# update-grub
Generating grub configuration file ...
Found background: /usr/share/grub/background.png
Found Intel Microcode image
Found linux image: /boot/vmlinuz-4.9-x86_64
Found initrd image: /boot/initramfs-4.9-x86_64.img
Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
ERROR: mkdir /var/lock/dmraid
  WARNING: Failed to connect to lvmetad. Falling back to device scanning.
Found memtest86+ image: /boot/memtest86+/memtest.bin
done
[root@manjaro /]#

Then Grub picked up the system and … Here, too, something went wrong:


Can someone suggest how to deal with this situation?
Thanks!

I am uncertain about this but using the non manjaro chroot you cd to the mtn and install grub and then chroot to do update grub. I did note that your grub update did not find your windows installation so did not work correctly.

If you had otherwise installed Manjaro correctly (except for grub),
refer this link at F10, do you see other linux OS boots listed? like Ubuntu, Fedora and Antergos? If listed, you can select one of their boots and use their bootloader [1] to boot up manjaro.

If not listed (or you had uninstalled all other linux OS (from your screen shot, most likely)), then boot up livecd and as per the link,

sudo mount /dev/sda6 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug

[1] - to use other OS bootloader to boot Manjaro, see this

grub> search.file /boot/intel-ucode.img root
grub> configfile /boot/grub/grub.cfg

And after booting up Manjaro,

sudo grub-install /dev/sda
sudo update-grub

Thanks for answers!
Displaying the Windows loader in Grub is not a primary task :slight_smile: I already dealt with this previously (on other distros).
After executing these commands:

sudo mount /dev/sda6 /mnt
sudo mount /dev/sda2 /mnt/boot/efi
sudo grub-install --target=x86_64-efi --efi-directory=/mnt/boot/efi --bootloader-id=manjaro --boot-directory=/mnt/boot --recheck --debug

I booted into emergency mode again and then executing these commands:

sudo grub-install /dev/sda
sudo update-grub

Grub was installed (most likely) correctly and even appeared the Windows loader. But Manjaro still does not load. This time, another problem arose:


PS: When installing, I chose the free driver.

As you indicated, "Grub was installed (most likely) correctly and even appeared the Windows loader."
It mostly is a graphic issue.
Boot into prompt and fix your graphic driver there.
Unfortunately, I’m not good in fixing graphic issues, so others have to help you with it.
You may want to provide your graphic details. These may help
sudo inxi -G
mhwd -li
mhwd -l

Oh. just in case, to boot to prompt,
At grub menu, press 'e’
Arrow down to linux line
Arrow right past ‘quiet’ and 'splash’
Backspace to remove ‘quiet’ and ‘splash’ taking care not to remove 'rw’
Add ‘3’ (without apostrophes meaning just 3)
Press F10 or ‘ctl’ + ‘x’ to boot

Good luck.

1 Like

After you have booted to console following advice of @gohlip, install drivers with mhwd. You can choose your driver from a nice menu with this one liner:

 `DIALOG " driver menu " --radiolist "\n choose item with spacebar\n " 0 0 12 $(mhwd -l | awk '/video-/{print $1}' | awk '$0=$0" - off"' | sort | uniq)  2>/tmp/.driver ; mhwd -f -i pci $(cat /tmp/.driver)`

But since you can’t copy/paste into the console, you probably want to do this manually. Check the output of

 mhwd -l

To see driver options for your system. Then, choose a driver name and

 mhwd -f -i pci name_of_chosen_driver

Thank you all for your answers. The problem is solved.
I reinstalled the system, but previously updated all the packages in Live mode. After that, I ran the installation and finally Grub’s error was again. Then I performed the following commands

[manjaro@manjaro ~]$ sudo su
[root@manjaro manjaro]# mount /dev/sda6 /mnt
[root@manjaro manjaro]# mount /dev/sda8 /mnt/home
[root@manjaro manjaro]# mount /dev/sda2 /mnt/boot/efi
[root@manjaro manjaro]# manjaro-chroot /mnt/ /bin/bash
[root@manjaro /]# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=Manjaro --force
Installing for x86_64-efi platform.
Installation finished. No error reported.
[root@manjaro /]# update-grub

and Manjaro started without any problems.

Forum kindly sponsored by Bytemark