[SOLVED]Problem with the wifi on HP notebook, wireless 8265 disconecting randomly after few seconds


#1

Hi ,

I have Intel Corporation Wireless card, wireless 8265 on HP notebook. The problem is that automaticaly disconnects randomly. It’s nighrmare. And when the notebook connects to my rooter , all other wifi devices are disconected.
I have tried the wicd network manager, also have tried downloading the intel drivers and replacing them. Also stoped the bluethoot and updagraded the linux kernel to the last version 4.15… . Nothing helps.

The problem is only when using battery

Here are some errors that I get using “dmesg -w”

failed to remove key (1, ff:ff:ff:ff:ff:ff) from hardware (-22)
disassociated from …:…:…:…:…:…:…:…: (Reason: 14=MIC_FAILURE)

https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1720930
May be it has something similar to that bug, but I don’t know how to tell the kernel to load particular version of the firmware if it is possible. But also this bug seems quite different because I don’t have this problem only on shutdown, I have it through the session.

So my question is how to solve this. I’ve tried like 5 hours to solve this and I’m tired.

The installation is one day old and is the last stable Manjaro installation with KDE. I wrote this from another computer. That is why I don’t provide all the logs.

sudo lshw -C network
[sudo] password for neli: 
  *-network                 
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 15
       serial: 48:ba:4e:51:de:c4
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8168 driverversion=8.045.08-NAPI duplex=half latency=0 link=no multicast=yes port=twisted pair speed=10Mbit/s
       resources: irq:126 ioport:3000(size=256) memory:f0204000-f0204fff memory:f0200000-f0203fff
  *-network
       description: Wireless interface
       product: Wireless 8265 / 8275
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 78
       serial: f8:34:41:71:ec:56
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.15.3-2-MANJARO firmware=22.391740.0 ip=192.168.1.7 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:129 memory:f0100000-f0101fff

also did try to turn off power management using this link, but with off and 1 insted of 0 , https://wiki.archlinux.org/index.php/Power_management#Network_interfaces.

The solution for me was to disable IPv6
https://wiki.manjaro.org/index.php?title=Turn_OFF_IPv6
Also I did try other things like making my router to work with Mixed mode, but without n, also I have selected chanel 11, and changed the WPA Encryption Algorithm to AES.


#2

The solution for me was to disable IPv6

https://wiki.manjaro.org/index.php?title=Turn_OFF_IPv6

Also I did try other things like making my router to work with Mixed mode, but without n, also I have selected chanel 11, and changed the WPA Encryption Algorithm to AES.


#3

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.