[SOLVED] Problem Installing Manjaro on MacBook Pro

kde
macbook
installation
macos

#1

Hi,

I’m new to Linux and trying to install Manjaro (17.1.9 x86_64 stable KDE version) on an old MacBook Pro, but I’ve run into a problem. Initially, I’m trying to setup as a dual boot, but I’m happy to do a single install as well. This is my first post to this forum.

Error I’m getting: After seeing the “welcome to GRUB” greeting flash and then landing on the “Welcome to Manjaro” page, I am stuck at “Starting version 238” line after selecting the boot row from the Welcome page. There is only a _ cursor on the second line and keyboard is unresponsive (including press and holding any key). Same result regardless of boot method and waiting time.

Attempted boot methods: I’ve tried Live USB (two ways: etcher.io and article link below) and DVD. Iso checksum was verified before burning.

System details:
Early 2011 15” MacBook Pro (model identifier 8,2)
8GB Memory
AMD Radeon HD 6750M PCIe 1GB graphics card
Intel Integrated Graphics 3000 (512MB) built-in
Filevault (encrypted) enabled
750GB HDD SATA
Mac OS Sierra 10.12.6; HFS+ format
System Integrity Protection (SIP) disabled
rEFInd installed (0.11.2; latest version) and running
Trying to use as a dual boot (Mac and Manjaro)

Listed Boot loader order (from Welcome to Manjaro). First entry is highlighted
(hd2.gpt1)/efi/refind/refind_x64.efi
(hd2.gpt1)/efi/refind/._refind_x64.efi
(hd2.gpt1)/efi/tools/gptsync_x64.efi
(hd2.gpt1)/efi/tools/._gptsync_x64.efi
(hd2.gpt3)/com.apple.recovery.boot/boot.efi

Steps I’ve followed:

1.	Read the Manjaro user’s manual, but there wasn’t an explicit section on Macs.  So, followed other instructions there as best I could.  Also, used this article (https://linuxnewbieguide.org/how-to-install-linux-on-a-macintosh-computer/)
2.	In following the linuxnewbieguide.org article, I got a partitioning error (step 3) using Apple’s Disk Utility, despite trying different partition sizes and formats (Mac and non-Mac).  So, no partition was setup, but I figured that the Manjaro installer would be overwriting it anyways.
3.	Searched google and this forum about this error.  I saw a few references to it (some examples below, but I’ve verified checksums and am not getting as far along as the other reference (and pressing/holding a key isn’t working either)  
⁃	https://forum.manjaro.org/t/manjaro-live-usb-stuck-on-starting-version238/45377
⁃	https://forum.manjaro.org/t/stable-update-2018-04-28-kernels-cinnamon-browsers-mesa-kde-apps-kde-framework-virtualbox/45938
⁃	https://forum.manjaro.org/t/unable-to-boot-in/45985
4.	In general, it seems that my AMD graphics card could be a problem, but I still have that partitioning error (Is FileVault the cause?).  

Other background: This is my first Linux install and distro, but I’ve been absorbing info from youtube (e.g., distro reviews/installs, general Linux topics, etc.), lots of RSS feeds and twitter accounts, numerous books and podcasts, etc. for the last 9-12 months. I’m fairly comfortable using the Terminal on my Mac. Is there a way to get into the Manjaro terminal from the Welcome page? Saw a reference to CTRL-ALT-F2, and I tried the Mac equivalent (command+alt+f2) without success.

Any guidance would be greatly appreciated on where to start, how to fix, etc. I really hope to be able to get Manjaro going. Thank you for reading my post and possibly helping if you can.


#2

I have succesfully booted Manjaro on a MacBook Pro mid 2017.

No special caution to be taken.

I had no keyboard and no touchpad/mouse but it is workable and I did not install anything. I don’t have the brain/energy what-not to work through the trouble. It is working OK for the use it has.

Actually it is the only system my licensed TeamViewer is always working - so I am thinking - it is working - don’t mess with it. :slight_smile:


#3

Try hitting ‘e’ at grub selection and add to boot options:
radeon.modeset=1


#4

Thanks for letting me know it’s possible. Looking forward to the “it’s working” phase :slight_smile:


#5

Thank you very much for the suggestion. The “Welcome to Grub” flashes by in less than a second. However, hitting “e” like you suggested got me into Grub (ver. 2.03), where I saw a nested “if” statement for language selection only. I added the “radeon.modeset=1” statement at the top. There was no visible save option. Just F10 to boot and F2 for a command line. Tried F10 to boot, which returned to the Welcome to Manjaro. It failed again when I booted.

Then, your suggestion sparked an idea. I noticed “driver=free” was the setting on the “Welcome to Manjaro” screen, so I switched it to “nonfree” (due to AMD). I also found another place (perhaps it was the place you meant) for that modeset command. Using the paper/pen icon (between the Manjaro icon and help icon) on the Welcome to Manjaro screen, I was able to add radeon.modeset=1 and have it saved.

It almost worked….the boot started scrolling [ok] for two screens, only error was this one on the second line (immediately after starting version 238 message). However, it went past this error without any problems.

[ 4.886933] [drm:radeon_init. [radeon]] ERROR No UMS support in radeon module!

Then, it got stuck again immediately after the following statement about 1 minute into the boot (used my camera to video it):

[OK] Started TLP system startup/shutdown.

Here, it just showed a flashing cursor.

Any ideas? It was nice to see some progress. Thank you again.


#6

I would maybe try with setting it to ‘0’ (which I meant to in the first place. doh)
You might see ‘quiet’ as a current option where you should put radeon.modeset=1.
Im trying to bypass the second radeon card, so that it hopefully just boots intel.
(btw - you will end up using free/open drivers no matter what - there are no more closed for intel/amd)


#7

Wow! It is like a real-time chat, except I’m too slow (trying various options). Unbelievable, many thanks. Tried two basic methods.

  1. In terms of “Welcome to Manjaro navigation, I’ve been using hitting the “enter” button after arrowing down between the Manjaro icon and help icon, which takes me to a screen that has “Example boot command line arguments” (setup, kernel, and video). I generally haven’t been using the “[C] GRUB Command line” option from that screen. I haven’t been using the [E] Edit Selection option either. Then, there’s a prompt to enter one of those inputs. In fact, radeon.modeset=0 is one of the examples shown.

I tried radeon.modeset=0. No luck…get stuck in the same place (Started TLP system startup/shutdown). If I don’t select nonfree for some reason, I can’t get past “starting version 238” line at the very top. I tried on both my USB and DVD. Also, I still get this message at the top: [ 4.886933] [drm:radeon_init. [radeon]] ERROR No UMS support in radeon module!

  1. Then, I use [E] at the boot entry item. Again, your “quiet” mention helped me realize that I might not have been in the right location with my first approach… Now, I see a “quiet systemd.show_status1” mentioned in the 2nd line of the actual Grub 2.03 screen. Tried changing “quiet” to radeon.modeset=1 (there’s already a radeon.modeset=0 entry in the preceding row). Now, I get only five lines of boot before it gets stuck. Last two last below.

:: running hook [udev]
:: Triggering uevents…

If I set the quiet text to radeon.modeset=0, I get the same result as before. Stuck on Started TLP system startup/shutdown.

Any other thoughts or suggestions? No rush, I will probably take a break until tomorrow. Even as I fail, I’m definitely getting better at navigating around the installer. Thanks again.


#8

Sorry, I don’t think I correctly replied to you (cscs). So, please see my posted response.


#9

Oh, well we dont need to double-down then. But I found some interesting references at archwiki:
https://wiki.archlinux.org/index.php/MacBookPro8,1/8,2/8,3_(2011)
(which may be your model, or atleast seems similar)

Which advises
radeon.modeset=0 i915.modeset=1 i915.lvds_channel_mode=2
To get intel working

Amond other things,I am not sure it is still true that only intel or amd can be used as in wiki.


#10

Use only one of them!!! Not both! :rofl:

This means you have a running system, just without X/GUI.
You might try to go on TTY (Ctrl+Alt+F2 or Mac equiv) and check /var/log/Xorg.0.log for errors.

Disclaimer: I know nothing about Macs


#11

Thank you. Yes, the 8,2 is my model. I will take a look at the page in more detail. Initially, those adjustments didn’t work, but I haven’t had a chance to read it in detail. I also found some threads on this forum about the “Started TLP system startup/shutdown” freezing, but haven’t really looked at them in detail. Will play around some and report back today/tomorrow. Many thanks again.


#12

Thank you for jumping in. I will avoid changing both references (your first point) :wink:

Unfortunately, it doesn’t seem like I can TTY to another terminal to check the Xorg log. Based on my initial search (links below), Macs seem to only have TTY1 or mixed success in doing so. The last link noted a success, but it didn’t exactly work for me (read on). Is there another method?

When I tried doing the mac equivalent (fn-ctrl-alt-F2 or other number 3-6) when it got stuck at Started TLP system startup/shutdown, the screen started to “strobe” with rapid flashing between both the boot screen and an underlying TTY2 text screen that showed enter login (manjaro) and password (manjaro). I could see a TTY2 reference at the top. I entered the login, then the password (a bit hard due to the strobing). However, I got an error saying the login was incorrect. If I did fn-ctrl-alt-F1, I returned to TTY1 and the strobing disappeared.

As I told cscs, I will play around today/tomorrow and share accordingly. Please let me know if you have any other suggestions. Thanks again.

https://stackoverflow.com/questions/800210/tty-switch-for-ctrl-alt-f1-and-alt-f1-f6-in-mac-os-x

https://ubuntuforums.org/showthread.php?t=1498680

https://discussions.apple.com/thread/2070249

https://bbs.archlinux.org/viewtopic.php?id=128714


#13

Just fyi

isnt the failure point, just the last thing you see. (but that hasnt stopped the OP/threads from being labeled such)
systemd.mask=mhwd-live.service
might be useful to disable automatic hardware detection


#14

Thanks, good point on my misunderstanding the failure point.

Ok, I done some more reading and reflecting. I wanted to run the following by you and anyone else willing to share an opinion.

Option 1
Please correct me as needed and add any you think are worth trying. I understand that there’s a lot of trial and error, since everyone’s setup is different (not to mention trying to do remote assistance with a newbie…thanks again). That said, I’m trying to take a step back to confirm some things and hopefully be a bit more systematic. Each manipulation takes 5-10 minutes, since editing is slow with arrows, etc.

Here’s the boot screen that I see by default when I select [E] on the Boot line of “Welcome to Manjaro”:

setparamas ‘Boot: Manjaro .x86_64 kde’ ‘x86_64 lang=en_US keytable=us tz=UTC driver=nonfree nouveau.modeset=0 i915.modeset=1 radeon.modeset=0 misobasedir=manjaro mi\ solabel=MJRO1719 quiet systemd.show_status=1’
#set arguments above with the editor
linux /boot/vmlinuz-$2
ignited /boot/intel_ucode.img /boot/initramfs-x86_64.img

Here’s the part I’ve primarily been changing:
nouveau.modeset=0 i915.modeset=1 radeon.modeset=0

Here’s what I will iterate through. As you know, I’ve already tried some, but I will double check. This list assumes that order doesn’t matter. If it does, please let me know, as more combinations will be needed. I plan to remove all mentions of ‘nouveau’, as I don’t have a Nvidia card. Again, if that’s a mistake, please advise.

i915.modeset=0 radeon.modeset=0. (Arch Wiki page)
i915.modeset=0 radeon.modeset=1
radeon.modeset=1 i915.modeset=0

radeon.modeset=1
radeon.modeset=1 i915.modeset=1
radeon.modeset=1 i915.modeset=1 i915.lvds_channel_mode=2 (modification based on Arch Wiki page)

radeon.modeset=0
radeon.modeset=0 i915.modeset=1
radeon.modeset=0 i915.modeset=1 i915.lvds_channel_mode=2. (Arch Wiki page)

To your earlier comment, where should I insert systemd.mask=mhwd-live.service?

Option 2
Should I wait until the next release and try again? I saw that 17.1.10 is out, but is it meaningfully different (in terms of my issue) from 17.1.9? Or wait another 6 months?

Option 3
More generally, I’m thinking that I might do a clean install (Mac OS, rEFInd, and Manjaro) on the computer. It’s an old computer, and there’s probably junk floating around in places. Also, I need to get the partitioning fixed (probably just need to temporarily disable Filevault). Normally, a reinstall (factory level - not via an existing backup) on a Mac would be a fair amount of work, but I don’t use it as my primary computer any more. So, I wouldn’t bother with a lot of stuff (i.e., restoring applications and data, setting things up, etc.). Just get a functioning dual-boot (use MacOS for any firmware updates and use Manjaro for a real computer), as recommended on the Arch Wiki page for Macs

Option 4
Another option is to get a more “Linux-friendly” computer (e.g., single OS, open-source friendly, etc.) at some point. Ironically, my primary laptop (another Mac that I’m not messing around with) only has an integrated Intel graphics card, and it would probably be a better candidate in that regard — but I can’t risk it. I know it’s possible to get Manjaro working on a Mac, but I obviously lack the experience with installation troubleshooting. I always have the feeling it could be anything and a single character could make all the difference. Obviously, I would rather not spend the money and also know that future installations/updates will always be needed regardless of the computer. Just think it might be a cleaner and more manageable platform, both initially and in the long-term.

Please let me know what you think. I am serious about switching to Linux, as I’m tired of all the walled gardens. Thanks again for your time.


#15

Once again, I didn’t correctly replied to you (cscs). So, please see my posted response. Sorry. I think the composer is losing track of my reply and treating it as a post, because I’ve been taking a long time to draft it. Either that, or it’s another user-error on my end.


#16

Update: I installed Manjaro on a VM (VirtualBox) on my Mac laptop. Not my preferred solution, but it will let me explore the system while I figure out the hardware issues. Thanks again to all who helped.


Manjaro 2008 Mac book Pro
#17

Manjaro on MBP8,2: Issues installing Manjaro on MacBook Pro

load_video
set gfxpayload=keep

outb 0x728 1
outb 0x710 2
outb 0x740 2
outb 0x750 0

Stuck at “Started TLP system startup/shutdown” Manjaro Gnome 17.1.12
#18

THANK YOU!!! It worked. I had seen something similar on the Arch Wiki for my Mac model (8,2) that cscs suggested to me, but I couldn’t access the logs to verify error messages and didn’t want cause more issues by changing it.

Believe it or not, it was my birthday this week. Thank you again for the gift :grinning:


#19

THANK YOU!!! It worked. I had seen something similar on the Arch Wiki for my Mac model (8,2) that cscs suggested to me, but I couldn’t access the logs to verify error messages and didn’t want cause more issues by changing it.

Believe it or not, it was my birthday this week. Thank you again for the gift :grinning:


closed #20

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.