[solved] Please help me kill baloo forever

i have this KDE bug with baloo_file_extractor that make my laptop freeze every few minutes.
this bug is at least 2 years old, but maybe the guys at KDE just don’t care.

this is the issue in the bugtracker:
https://bugs.kde.org/show_bug.cgi?id=333655
https://bugs.kde.org/show_bug.cgi?id=332421

now, there’re a lot of suggestion in forums (can’t link because new user), but nothing fix the problem:

  • i’ve tried disabling search, and/or excluding from it the /home folder, using the settings GUI, but it’s not saving my choices;

  • i’ve tried editing /.config/baloofilerc changing the option ‘Indexing-Enabled=true’ to ‘Indexing-Enabled=false’, and/or excluding folders from there, changes are saved, but it runs anyway;

  • i’ve tried the command “balooctl disable” but it runs anyway;

  • i’ve tried deleting folders like /.local/share/baloo, but it creates them again on reboot, of course.

maybe i need a script that kills baloo at startup?
help me getting rid of this process, please!

1 Like

weird,
I tried balooctl disable and it killed all baloo process and they don’t start anymore after login.[quote=“meadowlands, post:1, topic:3772”]
i’ve tried editing /.kde4/share/config/baloofilerc changing the option ‘Indexing-Enabled=true’ to ‘Indexing-Enabled=false’, and/or excluding folders from here, changes are saved, but it runs anyway;
[/quote]

I don’t know. but I also have the same settings in baloofilerc and baloorc. did you check both files?
and they are not in ~/.kde4/share/config/ but in ~/.config (I don’t have any baloo config file in ~/.kde4…)

1 Like

Couldn’t help but love the title of this thread. :grinning:

Please, don’t kill Baloo!

5 Likes

neither do i, lol. :joy:
my mistake. i’ve changed baloofilerc in ~/.config.
i didn’t notice the other file, baloorc, but i’ve found it already had the same settings. indexing-enable is set false, but nothing stops baloo.

the process i kill to fix the issue btw is baloo_file_extractor, keeping baloo_file alive without problems. but the second one launch the first one, if i’m not wrong.

maybe i can make manjaro kill it for me at startup by doing some magic in systemsettings -> startup & shutdown -> autostart, but i can’t guess what.

when I checked (nothing change in baloo since install) I just had baloo_file process running.
from where come baloo_file_extractor?? I mean who launch it or why?

could you post your ~/config/baloofilerc and /etc/xdg/autostart/baloo_file.desktop?

sure, here’s ~/.config/baloofilerc

[Basic Settings]
Indexing-Enabled=false

[General]
dbVersion=2
exclude filters=lzo,*.loT,.bzr,.histfile.*,CVS,.pch,__pycache__,CMakeCache.txt,po,confstat,Makefile.am,*.pc,*.o,*.vm*,*.orig,*.omf,*.nvram,*.pyc,cmake_install.cmake,ui_*.h,*~,*.moc,confdefs.h,.uic,*.lo,CMakeFiles,*.csproj,moc_*.cpp,CTestTestfile.cmake,.git,.obj,*.m4,*.part,lost+found,*.swap,*.elc,*.aux,.xsession-errors*,*.po,.hg,conftest,*.tmp,*.gmo,*.la,*.rej,*.class,.moc,config.status,litmain.sh,_darcs,core-dumps,libtool,qrc_*.cpp,CMakeTmp,CMakeTmpQmake,.svn,*.rcore,autom4te
exclude filters version=2
exclude folders[$e]=$HOME/
first run=true

here’s /etc/xdg/autostart/baloo_file.desktop

[Desktop Entry]
Type=Service
Exec=baloo_file
X-KDE-StartupNotify=false
X-KDE-autostart-condition=baloofilerc:Basic Settings:Enabled:true
X-KDE-autostart-phase=0
X-GNOME-Autostart-enabled=true
OnlyShowIn=KDE;GNOME;Unity;XFCE
NoDisplay=true

Name=Baloo File Daemon
Name[ar]=عفريت بالو للملفّات
Name[ast]=Degorriu de ficheros Baloo
Name[bs]=Baloo datotečni demon
Name[ca]=Dimoni de fitxers Baloo
Name[ca@valencia]=Dimoni de fitxers Baloo
Name[cs]=Démon souborů Baloo
Name[da]=Baloo fil-dæmon
Name[de]=Baloo-Dateidienst
Name[el]=Δαίμονας αρχείων Baloo
Name[en_GB]=Baloo File Daemon
Name[es]=Demonio de archivos de Baloo
Name[fi]=Baloo-tiedostopalvelu
Name[fr]=Démon de fichier Baloo
Name[gd]=Deamhan fhaidhlichean Baloo
Name[gl]=Daemon de ficheiros de Baloo
Name[hu]=Baloo fájl démon
Name[ia]=Baloo File Daemon (Demon de file de Baloo)
Name[it]=Demone dei file Baloo
Name[ko]=Baloo 파일 데몬
Name[lt]=Baloo failų tarnyba
Name[nb]=Baloo fil-daemon
Name[nds]=Baloo-Dateidämoon
Name[nl]=Baloo bestandsdeamon
Name[nn]=Baloo fil-teneste
Name[pa]=ਬਾਲੂ ਫਾਈਲ ਡੈਮਨ
Name[pl]=Usługa plików Baloo
Name[pt]=Serviço de Ficheiros do Baloo
Name[pt_BR]=Serviço de arquivos do Baloo
Name[ro]=Demon de fișiere Baloo
Name[ru]=Служба мониторинга файлов для Baloo
Name[sk]=Súborový démon Baloo
Name[sl]=Ozadnji program za datoteke Baloo
Name[sr]=Демон Балуа
Name[sr@ijekavian]=Демон Балуа
Name[sr@ijekavianlatin]=Demon Balooa
Name[sr@latin]=Demon Balooa
Name[sv]=Baloo-fildemon
Name[tr]=Baloo Dosya Yardımcısı
Name[uk]=Фонова служба обробки файлів Baloo
Name[x-test]=xxBaloo File Daemonxx
Name[zh_CN]=Baloo 文件进程
Name[zh_TW]=Baloo 檔案伺服程式

try to delete the .desktop file. (backup it somewhere).
and if baloo_file still start. that mean something else start it. but I don’t know who.

it works.
my manjaro is baloo-free now, thank you!

it won’t really resolve your problem as it will be reinstall the next time it will be updated.
I don’t know why it start baloo in your case and not mine. as all files are the same

true, but deleting a file every now and then is way better than kill a process every time you start your laptop!
I hope the KDE team will look into this, or maybe manjaro devs could find a distro-centric option to deal with baloo in a case like this.

I’m not sure to understand. and there should be a reason for your system start it as it doesn’t start in my case with all the same settings.
maybe your baloorc file is “corrupted” in some way. try to delate it. and reconfigure baloo and disable it again

It maybe related with this. I will check when i will be back home

reason is bugs, links are provided in my first post, and a bug is not 100% reproducible. we’ve the same settings on these 2 files, but baloo has a lot of dependecies, you cannot remove it without deleting plasma-desktop or dolphin, among the others, according to octopi.
https://api.kde.org/frameworks/baloo/html/baloo-dependencies.html
plus, i had the same issue with other distros, on other fresh installs.

i believe baloo is still broken, you can find really a lot of related topics on forums. it should be disabled by default, or at least it should be a lot easier to disable. both KDE and manjaro could do that. KDE could fix, also. :sweat_smile:

i’ve checked this, it seems unrelated to me. i dont know
https://community.kde.org/Baloo/Configuration#First_Run

yeah I understand. but normaly balooctl disable should not start it.
as the .desktop file will start baloo_file only if the settings “enable” is true. and it work in my case.
and it shoud not be related with baloo itself. as baloo isn’t running at that time. it’s an auto start condition defined in the .desktop file

you’re right, that’s weird.

not sure if this even applies because it’s from XFCE edition… but something starting without you actually starting it, and not set up to start in the sessions and startup list COULD be because you have “save session” checked and it’s saving your session with the program running, so it starts again next time you boot…

The way to fix it (if that happens to be the case, and I’m NOT saying it is) would be to kill the offending program, and then immediately restart the machine, BEFORE the program has any opportunity to restart itself… (that is, assuming you want “save session” active… otherwise, justy disable saved sessions)

As I said, not sure it helps or applies in KDE, but I’ve run around in circles with [programs starting “on their own” before this, and found that was the cause

There is also this kind of option in KDE. It worth a check for sure.

1 Like

for some rare file types…

hell no… the majority of users dont have a single problem with it

it usually should be an
balooctl disable
wich works for me

But the user should do that. an indexer always should be enabled by default.

if you’re a user and you have a problem with baloo, you’re the best one to help fixing it.

baloos indexing work is not just “a little script that can index all the files”. its more like “one script for a few types of files”. some random files have a little change in it, they are not like they should be and this can make baloo broken for you. so its really important to find files like this and send them to a baloo dev so he/she can create a fix.

sure it’s “always the same issue” but there are millions of file types and apps who create them in a different way. so baloo needs to support (or blacklist) everything…

BTW -> happy baloo user for years. Most important tool for me to work :slight_smile: ~ cause i <3 hashtags :stuck_out_tongue:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark