[SOLVED] Octopi and "the internet seems to be unavailable" error - [Octopi 0.9.0-9 until 0.9.0-11 is broken ]

Hi,

I have been using manjaro on kde for around 3 months now, and i love it. Octopi was working perfectly fine, until the last update on 9th of july. Since then octopi has been giving me the error

the internet seems to be unavailable

That error comes up whenever i make any transaction, checking for updates, removing packages, installing packages and updating packages, there might be other things that are not working but these are all that i have noticed so far. Strangely enough, i can search for packages just fine with no errors, and i did not modify anything in it except for adding trizen (the alien icon beside the search bar).

I have tried looking up online and came across this topic

Octopi internet seems unavailable

but it's more than a year old, so the solution suggested is not viable anymore, and i have tried updating the mirrors with no luck also. I don't put my laptop to sleep mode, so when i am done with it, i always shut it down, but i still tried rebooting and it didn't also work, neither did restarting octopi.

As far as i have seen, pacman works just fine, and i have been checking for updates and installing them from it. I have tried to install a package and it also works. I don't know where the problem is, my internet works just fine, and all applications that use internet also work normally except for octopi.
Is it a bug ?

inxi -Fxz:

System:    Host: zalnur434 Kernel: 5.1.16-1-MANJARO x86_64 bits: 64 compiler: gcc v: 9.1.0 Desktop: KDE Plasma 5.16.2 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: Apple product: MacBookAir6,2 v: 1.0 serial: <filter> 
           Mobo: Apple model: Mac-7DF21CB3ED6977E5 v: MacBookAir6,2 serial: <filter> UEFI: Apple v: 112.0.0.0.0 
           date: 02/14/2019 
Battery:   ID-1: BAT0 charge: 17.9 Wh condition: 32.8/54.3 Wh (60%) model: SMP bq20z451 status: Charging 
CPU:       Topology: Dual Core model: Intel Core i5-4260U bits: 64 type: MT MCP arch: Haswell rev: 1 L2 cache: 3072 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16007 
           Speed: 1915 MHz min/max: 800/2700 MHz Core speeds (MHz): 1: 1915 2: 1555 3: 2105 4: 1877 
Graphics:  Device-1: Intel Haswell-ULT Integrated Graphics vendor: Apple driver: i915 v: kernel bus ID: 00:02.0 
           Display: x11 server: X.Org 1.20.5 driver: intel unloaded: modesetting resolution: 1440x900~60Hz 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 19.1.1 direct render: Yes 
Audio:     Device-1: Intel Haswell-ULT HD Audio vendor: Apple driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series HD Audio driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
           Device-3: Broadcom and subsidiaries 720p FaceTime HD Camera driver: bdc-pci bus ID: 02:00.0 
           Sound Server: ALSA v: k5.1.16-1-MANJARO 
Network:   Device-1: Broadcom and subsidiaries BCM4360 802.11ac Wireless Network Adapter vendor: Apple driver: wl v: kernel 
           port: efa0 bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
Drives:    Local Storage: total: 233.76 GiB used: 92.35 GiB (39.5%) 
           ID-1: /dev/sda vendor: Apple model: SSD SM0256F size: 233.76 GiB 
Partition: ID-1: / size: 220.58 GiB used: 92.25 GiB (41.8%) fs: ext4 dev: /dev/sda2 
           ID-2: swap-1 size: 8.35 GiB used: 103.6 MiB (1.2%) fs: swap dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 63.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 205 Uptime: 6h 03m Memory: 3.79 GiB used: 2.33 GiB (61.4%) Init: systemd Compilers: gcc: 9.1.0 
           clang: 8.0.0 Shell: bash v: 5.0.7 inxi: 3.0.34
Octopi Version : 0.9.0-10 (git-d23565) - Qt 5.12.4
Pacman version : 5.1.3

Edit: missing words

just do sudo pacman -Syyu in a terminal that should work

Just tried it. Octopi was updated to 0.9.0-11. I restarted octopi, then tried to install, update, and remove, the error remained. So i rebooted and tried the same things but the error remains.

have you tried sudo pamac -Syyu in a terminal they are saying octopi is broken

1 Like

yes i have tried it in terminal.
Oh i see, so octopi is broken.. thanks a lot for your help @rbrick49, i will leave the topic opened for 24 hours just in case, maybe there is a work around, then mark it as solved.

Btw, can you provide the link to the website that says it's broken please ? i want to keep up with the news :slight_smile:

just do a sudo pamac checkupdates and see if that works

just use the search option on top of this page just put in octopi it will answer you

Just saw the topic, it seems to be broken from 0.9.0-9 onward. I will just downgrade to 0.9.0-8.
I will mark the topic as solved then. Thanks a gain @rbrick49 really appreciate the help.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.