[SOLVED]Nvidia Proprietary Drivers @#%$!

inxi for Demon Machine in question.

So, I want to switch from the nvidia proprietary drivers to the free nou-whatever.
I can't remove the bloody things!

sudo mhwd -r pci video-nvidia

Starting
> Removing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: python-py3nvml: removing nvidia-utils breaks dependency 'nvidia-utils'
Error: pacman failed!
Error: script failed!


Done ...

No, Pcaman, you are in fact not done.
So, I've tried varies things so far.
Searched the forums obviously and found several seemingly helpful threads.

Just two of the many. I've been trying to rip this driver out for about 30 minutes now.

  • First thing I did was the normal sudo mhwd -r pci video-nvidia, then installed the Free drivers.
  • Installed other kernels, they keep installing the nvidia modules!
  • I've removed kernels and the modules.
    I can't remove this stupid thing.
  • Tried booting into TTY and removing. Pfft.
  • Tried pacman --force -S video-nvidia. I come back to FAILED: Failed to load kernel modules then it sits trying to load TLP!? (I thought I uninstalled that stupid thing?)

I seem to be running both drivers at the same time? Huh?


Also, why can one not resize the mhwd window?

It's probably something stupid I'm missing. I feel dumb, help.

As always, thank you for your time, knowledge, and patience. :slight_smile:

First lets try to find out what kernels you have installed:
mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2}'
and if there are also headers there
mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2"-headers"}'
Remove the EOL kernel, if you have one installed, then try to remove the nonfree driver and then install the free driver, but ... may i ask why you want to drop the video-nvidia ? Also, you have them both installed as per the screenshot provided, and that is what i usually avoid ...
With the GeForce GTX 1070 Ti you will not get less performance using the video-linux.

There is no such package. video-nvidia is a set of scripts that will install the driver and kernel modules + configs, that is why it needs to be run trough mhwd.

Usually by running:
sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf
you fix most of the issues with nvidia proprietary drivers.
Also, care to share that nvidia.config?

1 Like

Got linux51 and linux52. Had linux419 initially but it was a victim of my efforts.

mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2}'
linux51
linux52
mhwd-kernel -li 2>/dev/null | awk '/ linux/ {print $2"-headers"}'
linux51-headers
linux52-headers

No EOLs installed. :slight_smile:

I'm having issues I can't resolve with the proprietary nvidia drivers. One of them is in the screenshot. The fonts are just terrible. I've tried everything I could find on the Wikis and here and they just klook horrid. Also, in VirtualBox no matter the settings it graphical glitches, a lot. Changed Compositors, you name it. There's some other stuff but I just want to see if the free drivers will work better.

Both installed, yes. I wasn't thrilled when I saw that. It was not my intent to have both installed. But it was a rookie mistake. :frowning:

Yep, I discovered this. :wink: It was in one of the threads and I was desperate.

cat /etc/X11/mhwd.d/nvidia.conf
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 430.26

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
EndSection

Section "Screen"
    Option         "Coolbits" "4"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

Did I cat the wrong one? :blush:
Did I answer everything? :smiley:

Oh- sudo mhwd-gpu --setmod nvidia --setxorg /etc/X11/mhwd.d/nvidia.conf
I can give that a try right now.

Very simple.
python-py3nvml needs nvidia driver. Uninstall this python library first. Then the nvidia driver.

6 Likes

So I sudo pacman -R python-py3nvml
and get checking dependencies... error: failed to prepare transaction (could not satisfy dependencies) :: gwe: removing python-py3nvml breaks dependency 'python-py3nvml'

OMG! It was GreenWithEnvy! I removed it and I successfully removed the nvidia drivers!

> Removing video-nvidia...
Sourcing /etc/mhwd-x86_64.conf
Has lib32 support: true
Sourcing /var/lib/mhwd/local/pci/video-nvidia/MHWDCONFIG
Processing classid: 0300
Sourcing /var/lib/mhwd/scripts/include/0300
Processing classid: 0302
checking dependencies...
:: lib32-vulkan-icd-loader optionally requires lib32-vulkan-driver: packaged vulkan driver
:: vulkan-icd-loader optionally requires vulkan-driver: packaged vulkan driver
warning: dependency cycle detected:
warning: eglexternalplatform will be removed after its nvidia-utils dependency

Packages (5) egl-wayland-1.1.3-1  eglexternalplatform-1.0+3+g7c8f8e2-1  lib32-nvidia-utils-1:430.26-1  linux51-nvidia-1:430.26-9  nvidia-utils-1:430.26-1

Total Removed Size:  313.85 MiB

:: Do you want to remove these packages? [Y/n] 
:: Processing package changes...
removing linux51-nvidia...
removing lib32-nvidia-utils...
xorg configuration symlink valid...
removing nvidia-utils...
xorg configuration symlink valid...
removing egl-wayland...
removing eglexternalplatform...
:: Running post-transaction hooks...
(1/4) Updating linux51 module dependencies...
(2/4) Reloading system manager configuration...
(3/4) Arming ConditionNeedsUpdate...
(4/4) Updating the desktop file MIME type cache...
'/etc/X11/xorg.conf.d/90-mhwd.conf' symlink is invalid! Removing it...
> Successfully removed video-nvidia

@Strit You evil genius! Thank you. :purple_heart:
@bogdancovaciu Thank you very much. You're the bestest!

3 Likes

Makes sense that a tool designed to control Nvidia GPU stuff, depends on the nvidia driver. :slight_smile:

I forgot I had it installed. /sigh
This giant post~ An hour of my life I'll never get back! :rofl:

@SinisterBrain
Before you do that (reason i didn't mentioned it), but you already did
lets fix the config because you added the Option "Coolbits" "4" to the Screen section and not to the Device section ... so, try this curated config:

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0"
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Unknown"
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
	Option "NoLogo" "1"
    Option         "TripleBuffer"  "On"
    Option  "ConnectToAcpid"    "Off"
    Option "metamodes" "nvidia-auto-select +0+0 {ForceCompositionPipeline=On}"
    Option         "Coolbits" "4"
EndSection
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "COMPOSITE" "Enable"
EndSection

Section "ServerFlags"
    Option "IndirectGLX" "On"
EndSection
 
Section "InputClass"
    Identifier          "Keyboard Defaults"
    MatchIsKeyboard        "yes"
    Option              "XkbOptions" "terminate:ctrl_alt_bksp"
EndSection

then add to /etc/profile.d/kwin.sh file this lines:

export KWIN_TRIPLE_BUFFER=1
export __GL_MaxFramesAllowed=1

Reboot and then set the Compositing like this:

Have a great day :wink: and after you will see how poorly the free driver performs, take in consideration the above. Cheers!

2 Likes

Thank you for the configs. :slight_smile:
I'll probably be back after I see how sucky the free drivers are. :confused:
You have a great day too. Thank you for jumping into my weirdness. :wink:

1 Like

There will be plenty of those :stuck_out_tongue:

I'm in the weirdness club since i was born. :smiley:

2 Likes

Well, the fonts suck with the free drivers too.
It's only KDE too.
Guess, I'll go back to the non-free (after all that!UGH!) and try your tweaks. :slight_smile:

For fonts try this:

image

I used to have a .Xresources file in my home directory, with this in it:

#if __has_include(".extend.Xresources")
#include ".extend.Xresources"
#endif

! ^ The above lines are no comments!
! Leave them as they are if a file ~/.extend.Xresources is being used on your system.
! config can be added there or also here below.
! For comments use "!"

Xft.dpi: 96
Xft.antialias: true
Xft.hinting: true
Xft.rgba: rgb
Xft.autohint: false
Xft.hintstyle: hintslight
Xft.lcdfilter: lcddefault

XTerm*background: #2b2b2b
XTerm*foreground: #e7e7e7
XTerm*pointerColor: #16A085
XTerm*faceName: Fixed
XTerm*faceSize: 10

but i no longer use it, is all fine without it on my end.

My current.

Just garbage.

Think I'll give your config thingy a try.

I'm on Cantarell side :slight_smile:

image

Noto is just where I ended up after trying a bajillion fonts.
I tend to use the boring Droid or Roboto ones.

Fonts look a bit better. Not where I'd like them.
cough never had font issues in Wiiinnndddoooowwwwsss. :wink:

Thank you @bogdancovaciu, it's helped a lot with clearing up the fonts.
I think KDE hates fonts or something?

Hope you have a great morning/afternoon/evening/midnight! :innocent:

Not sure about that, i don't think so. maybe you need 150% scaling, try DPI set to 144 (= 96 * 1.5) ... Maybe for 2560x1440 resolution (as per your provided inxi) you need a bit of tweaking.

Yes, is still morning (late morning) here. Likewise to you too!

Addition: Maybe see here https://www.linuxsecrets.com/archlinux-wiki/wiki.archlinux.org/index.php/HiDPI.html
and look for 2560x1440 - much better than i was describing above :slight_smile:

1 Like

DO you happen to know which config to edit to set that? It won't stick in the Settings Panel. :frowning:

Bah, just saw your link.

You can force the font DPI in font settings, and the scale factor in Display and Monitor > Scale Display. You might have to tweak too the GTK part of it with GDK_SCALE/GDK_DPI_SCALE ... see also here:
https://wiki.archlinux.org/index.php/HiDPI#KDE

1 Like

I think your fonts look absolutely fine - this shows again how subjective it is... :wink:

Set DPI to 108-120 for a 27" 1440p monitor, and font size to 10 or 11.
I would do that by directly editing /etc/sddm/sddm.conf and adding dpi=XX option to X server command line.

Ah, and you can of course also try freetype2-ultimate5 from AUR - this makes (some) fonts look more M$ like.

2 Likes