[SOLVED] No sound on pinebook 1080

I cannot hear any sound from my pinebook 1080 with manjaro and kernel 5.2.0-1.

Alsamixer finds three sound cards:

  • pulseaudio
  • sun50i-a64-audio
  • allwinner,hdmi

I tried the first two (I have not hdmi cable to try).

I raised the volume but without any result.

In dmesg I found this error:

[ 12.555985] ALSA device list:
[ 12.559010] No soundcards found.

What do I need?

First $ inxi -Fxxxz
Second , is pavucontrol installed?

Output related to audio from

inxi -Fxxxz

Audio:
  Device-1: sun50i-a64-dw-hdmi driver: sun8i_dw_hdmi bus ID: N/A
  chip ID: allwinner:1ee0000
  Device-2: simple-audio-card driver: asoc_simple_card bus ID: N/A
  chip ID: simple-audio-card:soc
  Device-3: simple-audio-card driver: asoc_simple_card bus ID: N/A
  chip ID: simple-audio-card:sound
  Device-4: simple-audio-card driver: N/A bus ID: N/A
  chip ID: simple-audio-card:sound_spdif
  Sound Server: ALSA v: k5.2.0-1-MANJARO-ARM

pavucontrol is installed and this the output:

Please check with alsamixer to see if the DAC audio device is muted.

Ok, I solved.

I needed to change the output from pavucontrol from one device to another (with the same name?).

Thanks too much!

Yeah, Device naming is a bit weird on ARM devices. :slight_smile:

In configuration :wink: