(SOLVED) Newbie here - please help with Broadcom issue

I just installed Manjaro Cinnamon after testing it for two days on a usb. Everything worked fine but after install I have no wireless. It was there for testing so why would it go away on install.

I was using Linuxmint for the past 3 years but it got buggy and a buddy said to try Manjaro. I’m here!

Anyway I am using a Dell Inspiron 1720 Intel Core 2 Duo CPU, 2GHz, 4G ram and a Broadcom 4321 card. I’m not that up on knowing what to do next so I checked what drivers are installed. I see that the linux49-broadcom-wl driver is installed but that doesn’t seem to help.

Can someone point me in the right direction?

The 4321 is one of these strange chips that depending on the revision, use different drivers.
What revision and/or pci id, does your chip have?
That will determine what driver it’s compatible with.
The easiest thing to do would be remove the wl driver using manjaro-tools, reboot, and see if the b43 kernel module works.
The live media detects what to use on boot with mhwd, and will disable the wl driver if needed.
Calamares on the other hand, may not have detected this properly when it installed the system.

2 Likes

WOW! Thanks AJSlye . . . that fixed the problem. Happy camper here!!

Can you post inxi -Nxx output, please?

This has already been solved.
Read the entire thread.

Besides all that was needed was inxi -Nxx

1 Like

I know, I asked for the record to maybe help fixing this issue for other users.

1 Like

https://wiki.archlinux.org/index.php/broadcom_wireless#Driver_selection

1 Like

Well if it doesn’t match these pcid’s, then the wl driver probably will not work:
Broadcom BCM4321 (PCI IDs 14e4:4328, 14e4:4329, 14e4:432a), In other words 14e4:4321 doesn’t work…
However, they all work with the B43 kernel module, as long as the firmware is installed…

https://wiki.debian.org/wl#supported
https://wireless.wiki.kernel.org/en/users/Drivers/b43#Supported_devices

1 Like

Here is my old post


Mine was Broadcom BCM4311.

Oh, and to confuse the issue even more, there is the open source firmware: OpenFWWF

http://netweb.ing.unibs.it/~openfwwf/index.php

Yea, had one of those once upon a time too.
Let me guess: 14e4:4313

Here’s the output:

[guess@guess-pc ~]$ inxi -Nxx
Resuming in non X mode: xrandr not found. For package install advice run: inxi --recommends
Network: Card-1: Broadcom Limited BCM4401-B0 100Base-TX
driver: b44 v: 2.0 bus-ID: 03:00.0 chip-ID: 14e4:170c
Card-2: Broadcom Limited BCM4321 802.11a/b/g/n
driver: b43-pci-bridge bus-ID: 0c:00.0 chip-ID: 14e4:4328

1 Like

OK, now that’s strange, the 14e4:4328 chip should work with the wl (STA) driver.
Could be that the brcm80211 driver is being detected before the wl driver.
It might needed to be blacklisted as well as the b43 and sbb.

https://wiki.archlinux.org/index.php/broadcom_wireless#Device_with_broadcom-wl_driver_not_working.2Fshowing

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by