[SOLVED] Network problems - rtl8723be and r8168 adapters

What happened Sir ?Did I do the mistake again? Please let me know, What is the mistake ?

thank you.

Santanu please listen to me. Do absolutely nothing I do not ask you explicitly to do.

Did I ask you to redo the edit?

Did I ask you to restart?

Do absolutely nothing but what I ask. You need to slow down and wait for instructions.

1 Like

I am extremely sorry, Sir. Okay, Sir. I will wait for your advice.

grep -r "blacklist\|install\|options"  /etc/modprobe.d/

Blockquote[santanu@manjaro_santanu ~]$ grep -r “blacklist|install|options” /etc/modprobe.d/
/etc/modprobe.d/rtl8723be.conf:options rtl8723be fwlps=0 ant_sel=2 ips=N swlps=N swenc=Y disable_watchog=1
/etc/modprobe.d/r8169_blacklist.conf:blacklist r8169

You need to read this before we go much further. You need to format your outputs properly.

Information on how to properly post hardware specs and logs on the forum:

Do you have physical access to your router. Can you reboot your router. Did you reboot your router when I asked you to earlier.

Do you know how to set configuration options in your router.

1 Like

No, Sir. I can’t reboot the router. It is done by our campus authority. I have no idea about router configuration.

We are just the users of wifi and ethernet provided by our campus.

That’s too bad. Please let me know when I’ve asked you to do something and you are unable to carry it out. Thank you.

Please modify the original script I asked you to create. Make sure the contents are exactly like this. When you make a script make sure there are no empty white spaces at the start of any line, and leave a empty line at the end of the script.

#!/bin/bash
sleep 15
sudo systemctl stop NetworkManager
sleep 2
sudo ip link set eno1 down
sudo ip link set wlo1 down
sleep 2
sudo modprobe -r r8169
sudo modprobe -r rtl8723be
sleep 2
sudo modprobe r8169
sudo modprobe rtl8723be fwlps=0 ips=N swlps=N swenc=Y disable_watchog=1 ant_sel=2
sleep 2
sudo ip link set eno1 up
sudo ip link set wlo1 up
sleep 2
sudo systemctl start NetworkManager

You must start formatting your outputs properly. I just noticed this because it was all jumbled with the rtl8723 options. When we were working on your LAN connection I’m pretty sure you said had no blacklist files left in /etc/modprobe.d. Now I find out otherwise.

You still have a blacklist on r8169. It must be deleted.

Be very careful to enter this command in the terminal exactly as I have written it.

sudo rm -r /etc/modprobe.d/r8169_blacklist.conf

After completing these changes, please confirm successful completion by again posting:

grep -r “blacklist|install|options” /etc/modprobe.d/

Please format the output with three backticks before and after the output.

3x`
Paste text or code here
3x`

As in this picture.

[santanu@manjaro_santanu ~]$ sudo rm -r /etc/modprobe.d/r8169_blacklist.conf
[sudo] password for santanu: 
[santanu@manjaro_santanu ~]$ grep -r “blacklist|install|options” /etc/modprobe.d/
bash: options”: command not found
install: missing file operand
Try 'install --help' for more information.
^C
[santanu@manjaro_santanu ~]$ 

Sir, the grip … command is incomplete. I think it is missing the backward slash

grep -r “blacklist|install|options” /etc/modprobe.d/
grep -r "blacklist\|install\|options"  /etc/modprobe.d/

Yes, you are correct it must have gotten truncated.

[santanu@manjaro_santanu ~]$ grep -r "blacklist\|install\|options"  /etc/modprobe.d/
/etc/modprobe.d/rtl8723be.conf:options rtl8723be fwlps=0 ant_sel=2 ips=N swlps=N swenc=Y disable_watchog=1
[santanu@manjaro_santanu ~]$ 

Much better, my ftreind. My eyes are loving this now.

I need to double check the edits on the script. This was the path and name I gave you for the script. If you changed the path or name then edit this command to reflect the correct path.

cat ~/.config/bin/netstart.sh

I hope you don’t mind if I edit your post title to reflect the issues more clearly. This will help others who have similar problems find a cure.

[santanu@manjaro_santanu ~]$ cat ~/.config/bin/netstart.sh
#!/bin/bash
sleep 15
sudo systemctl stop NetworkManager
sleep 2
sudo ip link set eno1 down
sudo ip link set wlo1 down
sleep 2
sudo modprobe -r r8169
sudo modprobe -r rtl8723be
sleep 2
sudo modprobe r8169
sudo modprobe rtl8723be fwlps=0 ips=N swlps=N swenc=Y disable_watchog=1 ant_sel=2
sleep 2
sudo ip link set eno1 up
sudo ip link set wlo1 up
sleep 2
sudo systemctl start NetworkManager

[santanu@manjaro_santanu ~]$ 

Excellent.

Before we restart, run the script by entering in terminal:

~/.config/bin/netstart.sh

Test you internet wifi/lan after. Let me know what happens.

Okay Sir. You must do( edit post title)it, if it helps someone.

Sir, it said," permission denied ‘’. Do I have to be root to run this command ?

Yes, sorry I forgot you need sudo.

Forum kindly sponsored by