[SOLVED]Need help! System down - Failed to start light display manager after re-boot

Manjaro 20.1
After recent update my Nvidia 340 driver is no longer displayed when I run mhwd -l in a tty
I can see driver for video-linux is displayed which I believe is the nouveau driver.
How can I default to this driver to enable booting into the desktop?

Hello lappetspm,

you can install and set the ‘video-linux’ driver with

sudo mhwd -a pci free 0300

If this wont help, please provide the output from these commands:

inxi -Fxa


mhwd -l


mhwd -li
1 Like

Thanks for helping.
The driver ‘video-linux’ is already installed.
See attached

Hello lappetspm,

‘mhwd -l’ shows you which drivers are available for your system. And ‘mhwd -li’ shows you which drivers are installed on your system.
So when I look at your ‘mhwd -li’-output it say that there are only the network driver are installed.

Is this the output of ‘sudo mhwd -a pci free 0300’ ? If so try:

sudo mhwd -f -i pci video-linux
1 Like

Errors trying to install free driver
See attached

Hm, seems to be there is a problem with you network. Have you proof your internet connection?

Yes network is working ok I’ve just booted into live cd

Please try to update mirror servers with:

sudo pacman-mirrors -f 0

See attached

Hm, first INFO says ‘Internet connection appears to be down’ and the 3 warnings befor looks like DNS didnt work.

What is the output from

ping -c 4 manjaro.org

Normaly it should look like

PING manjaro.org ( 56(84) bytes of data.
64 Bytes von mail.manjaro.org ( icmp_seq=1 ttl=53 Zeit=35.9 ms
64 Bytes von mail.manjaro.org ( icmp_seq=2 ttl=53 Zeit=35.6 ms
64 Bytes von mail.manjaro.org ( icmp_seq=3 ttl=53 Zeit=35.5 ms
64 Bytes von mail.manjaro.org ( icmp_seq=4 ttl=53 Zeit=35.8 ms

--- manjaro.org ping statistics ---
4 Pakete übertragen, 4 empfangen, 0% packet loss, time 3004ms
rtt min/avg/max/mdev = 35.504/35.706/35.938/0.180 ms

Also try:

ping -c 4
1 Like

ping: manjaro.org: Name or service not known

And could you ping the IP Adress I posted above?

ping: connect: Network is unreachable

Hardware seems ok from live CD working

If your hardware(cable/router/wifi) seems to ok you can use


to configure the network connection.

1 Like

Ok I’ll take a look

Ok network is working after installing kernel 5.10
When I run sudo mhwd -a pci free 0300 it says successfully installed.
I tried re-booting but still black screen

Should I reinstall kernel 5.4 as this was the one I was using before the latest update?

Dont think that the Kernel is the problem. How did you install Kernel 5.10 without internet connection?

And what does

mhwd -li

outputs now?

I reinstalled latest r8168 driver

Sudo pacman -S linux-latest-r8168

Which also added kernel 5.10
I must have already downloaded the file ?

But when I rebooted back to kernel 5.4 the network is still not working

Mhwd -li
Gives see attached