[SOLVED] Manjaro XFCE Edition (17.1.12) full disk installation

xfce

#1

My forun name is OldAl. My full name is Algis Kabaila. I am 93, probably the oldest member of this forum. Here are the details of my hp400 PC:
[ak@hp ~]$ inxi -Fxxxz
System:
Host: hp Kernel: 4.14.70-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1
Desktop: N/A wm: xfwm4 dm: lightdm 1.28.0 Distro: Manjaro Linux
Machine:
Type: Desktop System: Hewlett-Packard product: HP ProDesk 400 G2 SFF
v: N/A serial: Chassis: type: 4 serial:
Mobo: Hewlett-Packard model: 18E9 serial: UEFI: Hewlett-Packard
v: L02 v02.39 date: 12/11/2014
Battery:
Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M185/M225
serial: charge: 100% (should be ignored) rechargeable: yes
status: Discharging
CPU:
Topology: Dual Core model: Intel Core i3-4160 bits: 64 type: MT MCP
arch: Haswell rev: 3 L2 cache: 3072 KiB
flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28746
Speed: 2397 MHz min/max: 800/3600 MHz Core speeds (MHz): 1: 1696 2: 1696
3: 1696 4: 1696
Graphics:
Device-1: Intel 4th Generation Core Processor Family Integrated Graphics
vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0
chip ID: 8086:041e
Display: x11 server: N/A driver: intel unloaded: modesetting
alternate: fbdev,vesa resolution:
OpenGL: renderer: Mesa DRI Intel Haswell v: 4.5 Mesa 18.1.8 compat-v: 3.0
direct render: Yes
Audio:
Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:03.0
chip ID: 8086:0c0c
Device-2: Intel 8 Series/C220 Series High Definition Audio
vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0
chip ID: 8086:8c20
Sound Server: ALSA v: k4.14.70-1-MANJARO
Network:
Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
driver: r8168 v: 8.045.08-NAPI port: e000 bus ID: 02:00 chip ID: 10ec:8168
IF: enp2s0 state: up speed: 100 Mbps duplex: full mac:
Drives:
Local Storage: total: 465.76 GiB used: 11.27 GiB (2.4%)
ID-1: /dev/sda vendor: Seagate model: ST500DM002-1BD142 size: 465.76 GiB
speed: 6.0 Gb/s rotation: 7200 rpm serial: rev: HP74 scheme: GPT
Partition:
ID-1: / size: 448.97 GiB used: 11.27 GiB (2.5%) fs: ext4 dev: /dev/sda2
ID-2: swap-1 size: 8.32 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda3
Sensors:
System Temperatures: cpu: 29.8 C mobo: 27.8 C
Fan Speeds (RPM): N/A
Info:
Processes: 148 Uptime: 8m Memory: 3.78 GiB used: 872.7 MiB (22.5%)
Init: systemd v: 239 Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23
running in: xfce4-terminal inxi: 3.0.21
[ak@hp ~]$
After some experimenting of Manjaro, I decided to install it in whole disk. According to the “manjaro user guide” calamares is the installation tool that Manjaro uses. My intention was to:

  1. Install on the all of the hard disk and have full UEFI system generated.
  2. Using the “gparted” reduce the size of the second very large partition and then create additional partitions for other Linux os’s
    Howeverq, I find that the PC is locked and will only boot the Manjaro failing to boot from the build in dvd drive. On this hp400, the default boot was dvd. If the dvd failed to boot, then the second option was to boot from the hdd. It was the common booting arrangement. “Calamares” have disabled booting of the dvd drive. I am unable to use the installed gparted to do any dhnages to the hdd, as it is mounted. I can not boot Knoppix because I can not now boot dvd drive, as booting dvd has been disabled by the installer. How can I again get control of my hp400?
    OldAl.

#2

Try pressing the F12 key during boot up. Select the hard drive as your first boot option. This is usually selectable in your bios which device boots first.


#3

F10 invoked HP Setup Utility. Have changed the Boot order, pushing Manjaro down on the EFI boot menu. Promising start, though it failed to boot Knoppix. Will try a little more. Perhaps. Thank you tpg. Will try to get it to work… Also, will try to see if F12 gives the same as F10.

OldAl


#4

“Knoppix” failed qto boot. Tried at random a linuxmint installation disk - linuxmint-19. It booted ok, it had a gparted. As the mint-19 was running “in memory” (not installed) it was possible to shrink the no2 disk and create a total of 4 partitions, little over 100 GB each, with the Manjaro OS still working.
@tpg: Just a little hand holding was all that was needed. You gave that to me and I am so gratful. I was si worried.
OldAl.


#5

Certainly, but I’m the most attractive :wink: :slight_smile: :smiley:

FYI :slight_smile: . It must be @tbg not @tpg. @OldAl


#6

You are my personal hero. If I’m still installing and troubleshooting my own OS when I’m your age I will consider myself blessed. A big thumbs up to you. :+1:

Keep on keeping on.


closed #7

This topic was automatically closed after 90 days. New replies are no longer allowed.