[SOLVED] Manjaro not showing up on BIOS priority order, but can boot from Live Manjaro USB

Hello, I am quite new to using Manjaro (DE Gnome) and "Manjaro" does not show up in my BIOS bootup priority. However, if I boot from my Live USB and select "Detect EFI bootloaders" I can boot my actual Manjaro drive.

efibootmgr -v Output:

BootCurrent: 0002
Timeout: 0 seconds
BootOrder: 2001,0001,2002,2003
Boot0000* Manjaro	HD(1,GPT,20970ae9-1803-46e0-bb39-ee42504f01a9,0x22,0x1007de)/File(\EFI\Manjaro\grubx64.efi)
Boot0001* Windows Boot Manager	HD(1,GPT,cff7bc19-6fe3-4cb3-a94f-976c88bd2f21,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* EFI USB Device (Generic STORAGE DEVICE)	PciRoot(0x0)/Pci(0x14,0x0)/USB(5,0)/HD(1,MBR,0x0,0x3c1228,0x2000)RC
Boot0003* EFI Network 1 for IPv6 (54-B2-03-1B-B8-97) 	PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54b2031bb897,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0004* EFI Network 1 for IPv6 (54-B2-03-1B-B8-97) 	PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54b2031bb897,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0006* Windows Boot Manager	HD(1,GPT,cff7bc19-6fe3-4cb3-a94f-976c88bd2f21,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

Additionally, when I try to change the bootorder so that Manjaro is included via efibootmgr, it resets itself whenever the computer is restarted.

inxi -Fxz Output:

System:
  Host: god-pc Kernel: 5.1.8-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.3.0 Desktop: Gnome 3.32.2 Distro: Manjaro Linux 
Machine:
  Type: Laptop System: LG product: 15U780-PA51K v: 1.0 serial: <filter> 
  Mobo: LG model: 15U780 v: 1.0 serial: <filter> UEFI: INSYDE v: 15U78F05 
  date: 05/10/2018 
Battery:
  ID-1: BAT0 charge: 55.5 Wh condition: 55.5/56.9 Wh (98%) model: G15G-53 
  status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-8250U bits: 64 type: MT MCP 
  arch: Kaby Lake rev: A L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 28808 
  Speed: 800 MHz min/max: 400/3400 MHz Core speeds (MHz): 1: 800 2: 800 
  3: 800 4: 799 5: 800 6: 800 7: 800 8: 800 
Graphics:
  Device-1: Intel UHD Graphics 620 vendor: LG driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] vendor: LG 
  driver: nvidia v: 430.14 bus ID: 01:00.0 
  Display: x11 server: X.org 1.20.5 driver: nvidia 
  resolution: <xdpyinfo missing> 
  OpenGL: renderer: N/A v: N/A direct render: N/A 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: LG driver: snd_hda_intel 
  v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.1.8-1-MANJARO 
Network:
  Device-1: Intel Wireless 8265 / 8275 driver: iwlwifi v: kernel port: 5000 
  bus ID: 02:00.0 
  IF: wlp2s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: LG driver: r8169 v: kernel port: 4000 bus ID: 03:00.0 
  IF: enp3s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.03 TiB used: 17.66 GiB (1.7%) 
  ID-1: /dev/sda vendor: Toshiba model: MQ04ABF100 size: 931.51 GiB 
  ID-2: /dev/sdb vendor: SanDisk model: SD9SN8W128G1009 size: 119.24 GiB 
Partition:
  ID-1: / size: 913.43 GiB used: 17.66 GiB (1.9%) fs: ext4 dev: /dev/sda3 
  ID-2: swap-1 size: 2.00 GiB used: 0 KiB (0.0%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 54.0 C mobo: N/A gpu: nvidia temp: 48 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 261 Uptime: 2h 40m Memory: 11.64 GiB used: 2.06 GiB (17.7%) 
  Init: systemd Compilers: gcc: 9.1.0 Shell: bash v: 5.0.7 inxi: 3.0.34

I'm new to this, so let me know if I missed any required information. thank you!

I assume you mean you've done 'sudo efibootmgr -o 0000,0001' .
If you don't mean this, do this command. :point_up:

Do 2 things.

  1. At manjaro terminal
sudo cp /boot/grub/x86_64-efi/core.efi /boot/efi/EFI/boot/bootx64.efi

If error that directory /boot/efi/efi/boot not found, make directory and repeat command
sudo mkdir /boot/efi/efi/boot

  1. Go into your bios and see if you can set manjaro entry as default.
    You may have to make a security password for some motherboards
    Some require you to add the entry to firmware and then set as default.

ps: I noticed you do not have a system hard disk entry
you have usb, cdrom and network.
it is missing a hard drive entry.

1 Like

Yes, I've done exactly that.

After I ran that command, the BIOS still did not allow me to select the Manjaro entry. I booted up Manjaro with my Live USB as usual, then ran efibootmgr -v but now Manjaro is completely gone from the list:

BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 2001,0001,2002,2003
Boot0000* EFI USB Device (Generic STORAGE DEVICE)	PciRoot(0x0)/Pci(0x14,0x0)/USB(5,0)/HD(1,MBR,0x0,0x3c1228,0x2000)RC
Boot0001* Windows Boot Manager	HD(1,GPT,cff7bc19-6fe3-4cb3-a94f-976c88bd2f21,0x800,0x82000)/File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0002* EFI USB Device (Generic STORAGE DEVICE)	PciRoot(0x0)/Pci(0x14,0x0)/USB(5,0)/HD(1,MBR,0x0,0x3c1228,0x2000)RC
Boot0003* EFI Network 1 for IPv6 (54-B2-03-1B-B8-97) 	PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54b2031bb897,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0004* EFI Network 1 for IPv6 (54-B2-03-1B-B8-97) 	PciRoot(0x0)/Pci(0x1c,0x5)/Pci(0x0,0x0)/MAC(54b2031bb897,0)/IPv6([::]:<->[::]:,0,0)RC
Boot0006* Windows Boot Manager	HD(1,GPT,cff7bc19-6fe3-4cb3-a94f-976c88bd2f21,0x800,0x82000)/File(\EFI\Manjaro\grubx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...o................
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

I've added a security password, no luck. How would I "add the entry to firmware"? Also, does not having a hard drive entry affect anything? If so, how would I create one? Sorry for the lack of understanding, I haven't really worked with BIOS since I recently moved from a Macbook to an LG computer.

Have you done this? Do this if you haven't.

If you have done the above, go to this first post under [Some difficult UEFI setups] section. LG is not listed there but look at other mobo links and see if they can be any useful. As said, some are not fully BBS (uefi) compliant and needs to go to the bios to get entry into default. The ones we know and are difficult to fix are the HP and the Asus (some models only). If you find a way to fix your LG, come back here with your method so others with same issue with LG can learn from you.

Oh, some have fix uefi issues with bios firmware upgrade from the manufacturer. You may want to see if there is any upgrade from LG.

Good luck.

1 Like

After hours of testing, I figured out what the issue was.

First of all, I added a boot entry by running sudo efibootmgr -c -d /dev/sda -p 1 -l "\EFI\Manjaro\grubx64.efi" -L "Manjaro"

Then, I double-checked the flags of the boot partition (in my case /dev/sda1) and found out that the flags were somehow set to msfwdata. I changed them to boot and esp, and went back to the BIOS. The "Manjaro" boot entry did not show, however I tried booting up via the HDD harddrive (the one that Manjaro is installed in). Then, it automatically launched Manjaro by default.

I'm not sure why it was changed to that flag, as I made sure it had the correct flags for that partition.
Thank you @gohlip for your assistance and quick replies!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.