[SOLVED] Manjaro not booting after fresh installation (Hybrid GPU - Intel + NVIDIA)

drivers
boot
hybrid
graphics

#1

Hi,
I’m new to Manjaro and I am dying to try and stick with it as my main OS.
I tried the XFCE Live OS and it worked butter smooth and kept my machine super cool in temperature.

I downloaded the latest “Manjaro XFCE Edition (17.0.5)” ISO with the official torrent file and had it checksum verified.
I made the bootable USB drive and got it to boot only with systemd.mask=mhwd-live.service else it won’t boot.
I went on to install with “free” drivers as the “nonfree” version freezes mid-installation.
This installation is on a laptop with a hybrid GPU setup (integrated - intel, discrete - nvidia)

Now post the installation, on rebooting, the OS fails to boot and gets stuck midway.
I tried to add systemd.mask=mhwd-live.service again, but in vain.
I also see around 3-4

PCIe Bus Error: severity=Corrected type=Physical Layer

and adding pci=nomsi to boot params doesn’t let a successful boot completion either.

Another weird thing I noticed was booting into non-GUI mode using systemd.unit=multi-user.target and running any lspci command more than once, freezes the system. So any lspci command runs successfully for the first time, but then running the same command again or a diiferent one, freezes the system.

From the non-GUI mode when I check for the graphic driver by running lspci -v it shows
"i915" for VGA controller (Intel Corporation HD Graphics 530) and “nouveau” for the 3D controller (NVIDIA Corporation GM107M GeForce GTX 960M), which was exactly the configuration when running lspci -v from the Live OS which runs properly.

I have also tried other boot params like,

  • acpi_osi="!Windows 2015"
  • nouveau.modeset=0 modprobe.blacklist=nouveau
  • acpi_osi=! acpi_osi="Windows 2009" acpi_backlight=native
  • i915.preliminary_hw_support=1 tpm_tis.interrupts=0 acpi_osi=! acpi_backlight=native idle=nomwait nouveau.modeset=0 (boot params from my last openSuse installation)

Please please please help me out guys…i really loved the experience on the Live OS


#2

Boot into a Manjaro live environment.

Some system info.

inxi -Fxx

Also what is the make and model of your laptop? If it is a Dell or Clevo there are many threads on here about similar hybrid graphics issues. Have a read.

Access your installed system root partition via chroot

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot /mnt

Now check which graphics driver you have installed

mhwd -li

To get your machine booting remove the current hybrid driver and install the intel driver.

sudo mhwd -r pci [current driver]
sudo mhwd -i pci video-intel

I’d also remove all the additional kernel parameters you scatter gunned in /etc/default/grub, then run

sudo mkinitcpio -P

Reboot. If you can now boot successfully then the issue is narrowed down to your nvidia gpu, which can be investigated in more detail.

Remember that these config changes are done within your chroot shell, so that they effect your actual installed system, not the live environment.


#3

Thanks @sueridgepipe…I figured that bumblebee was causing the issue.
I found in Bumblebee’s Github page about an issue which could be solved by just adding acpi_osi=! acpi_osi="Windows 2009" which solved it.
Anyways thank you once again for replying with some way of troubleshooting.
:relaxed::slightly_smiling_face:


Asus gl552vw & manjaro compability
#4

Oh BTW make and model for someone other’s reference is Asus GL552VW-DH71 with Intel HD 530 and NVIDIA GeForce GTX 960M


#5

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.