[SOLVED] Manjaro logo at start-up

After recent update I don't see Manjaro logo. How can I have it back? I don't want to see grub, only logo that indicates that system is loading, because now I see only black screen and after that Plasma 5. I didn't install grub-vanilla. Manjaro is my only / single system.
@openminded

cat /etc/default/grub

#grub-quiet 
GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="quiet nomodeset loglevel=3 rd.systemd.show_status=auto rd.udev.log-priority=3 vt.global_cursor_default=0"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=false

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=3
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

cat /etc/mkinitcpio.conf

# vim:set ft=sh
# MODULES
# The following modules are loaded before any boot hooks are
# run.  Advanced users may wish to specify all system modules
# in this array.  For instance:
#     MODULES=(piix ide_disk reiserfs)
MODULES="crc32c-intel"

# BINARIES
# This setting includes any additional binaries a given user may
# wish into the CPIO image.  This is run last, so it may be used to
# override the actual binaries included by a given hook
# BINARIES are dependency parsed, so you may safely ignore libraries
BINARIES=()

# FILES
# This setting is similar to BINARIES above, however, files are added
# as-is and are not parsed in any way.  This is useful for config files.
FILES=""

# HOOKS
# This is the most important setting in this file.  The HOOKS control the
# modules and scripts added to the image, and what happens at boot time.
# Order is important, and it is recommended that you do not change the
# order in which HOOKS are added.  Run 'mkinitcpio -H <hook name>' for
# help on a given hook.
# 'base' is _required_ unless you know precisely what you are doing.
# 'udev' is _required_ in order to automatically load modules
# 'filesystems' is _required_ unless you specify your fs modules in MODULES
# Examples:
##   This setup specifies all modules in the MODULES setting above.
##   No raid, lvm2, or encrypted root is needed.
#    HOOKS=(base)
#
##   This setup will autodetect all modules for your system and should
##   work as a sane default
#    HOOKS=(base udev autodetect block filesystems)
#
##   This setup will generate a 'full' image which supports most systems.
##   No autodetection is done.
#    HOOKS=(base udev block filesystems)
#
##   This setup assembles a pata mdadm array with an encrypted root FS.
##   Note: See 'mkinitcpio -H mdadm' for more information on raid devices.
#    HOOKS=(base udev block mdadm encrypt filesystems)
#
##   This setup loads an lvm2 volume group on a usb device.
#    HOOKS=(base udev block lvm2 filesystems)
#
##   NOTE: If you have /usr on a separate partition, you MUST include the
#    usr,  and shutdown hooks.
HOOKS="base udev autodetect modconf block keyboard keymap filesystems"

# COMPRESSION
# Use this to compress the initramfs image. By default, gzip compression
# is used. Use 'cat' to create an uncompressed image.
#COMPRESSION="gzip"
#COMPRESSION="bzip2"
#COMPRESSION="lzma"
#COMPRESSION="xz"
#COMPRESSION="lzop"
#COMPRESSION="lz4"

# COMPRESSION_OPTIONS
# Additional options for the compressor
#COMPRESSION_OPTIONS=()
1 Like

Re-pick your splash-screen?

1 Like

I don't use splash screen. It was different element but I don't know what is it called.

Hmm, well there's only a few choices.
Did you install a boot splash program like Plymouth?

1 Like

I don't have plymouth installed.

Maybe it's the Boot Splahs you could enable some time ago?

Support for it might just have gone missing recently.

2 Likes

Well, there's a very limited selection of programs that do what you're saying. Even then, 20 questions will take forever.
You'll need to figure out what the program is somehow.

There's the BIOS POST often replaced with the manufacturers Splash screen like ASUS or Lenovo.
Then there's a boot splash like Plymouth
Then perhaps a Grub menu if it's enabled.
Then the DE, in this case KDE, splash screen.
Then login.

1 Like

I know what it was. It was

GRUB_BACKGROUND="/usr/share/grub/background.png"

And I have it in my configuration but I see only black screen. Either it is not loaded anymore or is loaded but not displayed properly.

Ah ok.

Go into the /usr/share/grub/ directory and make sure the background.png is there. If it's missing it might not be loading.

I don't ever recall a background.png being there but I've been wrong before. :wink:

1 Like

IMy background.png is there. :thinking:

1 Like

I still have it. It is png.

1 Like

grub has been having some modifications done to it a lot lately and I'm seriously no expert with grub.

But I have an ultrawide monitor and my theme graphic wouldn't show until I set the resolution by hand in grub.

Example of my setting.

GRUB_GFXMODE=2560x1080x32

Then the background showed. You could try that for your monitor resolution.

Also I see @dglt typing. Probably should wait to see what he says before modifications to grub. :wink:

1 Like

i dont think that's what your referring to.

what your referring to is a bootsplash like plymouth.

GRUB_BACKGROUND="/usr/share/grub/background.png"

is the background of the grub menu, once you make a selection or skip grub entirely, a bootsplash is what's shown until plasma starts IF you have a bootsplash setup.

since you mentioned @openminded , were you possibly using his bootsplash?

3 Likes

Hi. Let me describe my point of view on this and what I'd do if I were you:

First, you don't want to see grub, so add this to /etc/default/grub:
GRUB_RECORDFAIL_TIMEOUT=0

Second, your GRUB_CMDLINE_LINUX_DEFAULT contains loglevel=3, rd.systemd.show_status=auto, rd.udev.log-priority=3. Get rid of them, use udev.log_priority=3, partially because you have udev hook in mkinitcpio, not systemd. loglevel=3 is a part of quiet AFAIK.

Also I don't understand why you have nomodeset there. If you're trying to prevent nouveau (for example) from early loading due to errors, you can set nouveau.noaccel=1, nouveau.modeset=0 or modprobe.blacklist=nouveau. Each of these options has its own effect, you'd better google it because it can take a lot of time to explain what they are for.

Now, moving to /etc/mkinitcpio.conf.
Sometimes it is necessary to add intel_agp i915 when using Intel graphics. Since you haven't provided your system info, I just had to write this.

Next, I see no fsck in the HOOKS array of yours. To me this looks like you have systemd-fsck-root.service enabled. But, your /etc/default/grub has no ro option, which is usually necessary for root fsck service to work properly. For instance, mine doesn't fail and reports this:

$ systemctl status systemd-fsck-root.service
● systemd-fsck-root.service - File System Check on Root Device
   Loaded: loaded (/usr/lib/systemd/system/systemd-fsck-root.service; enabled-runtime; vendor preset:>
   Active: active (exited) since Sun 2019-09-08 17:22:16 +10; 19h ago
     Docs: man:systemd-fsck-root.service(8)
 Main PID: 557 (code=exited, status=0/SUCCESS)
    Tasks: 0
   Memory: 0B
   CGroup: /system.slice/systemd-fsck-root.service

Sep 08 17:22:17 reiwa systemd-fsck[557]: root: clean, 641620/3244032 files, 9829219/12971776 blocks

By default grub uses rw which forces systemd fsck service to skip checking root filesystem on boot.

And finally, I want to add a link to my old post which is still actual. It was written to explain how to make use of plymouth instead of bootsplash.

PS: my GRUB_CMDLINE_LINUX_DEFAULT is ro quiet splash udev.log_priority=3 apparmor=1 security=apparmor audit=0 nouveau.noaccel=1.

PS2: if your PC is UEFI/GPT, you can try EFISTUB kernel loading (explained in my profile) in order to skip grub completely.

2 Likes
hwinfo --gfxcard
14: PCI 100.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: VCu0.OMbgO9Iekk7
  Parent ID: vSkL.XZFuHFOcrYB
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia GT218 [GeForce 210]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0a65 "GT218 [GeForce 210]"
  SubVendor: pci 0x1043 "ASUSTeK Computer Inc."
  SubDevice: pci 0x8354 
  Revision: 0xa2
  Driver: "nvidia"
  Driver Modules: "nvidia"
  Memory Range: 0xe0000000-0xe0ffffff (rw,non-prefetchable)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable)
  Memory Range: 0xd0000000-0xd1ffffff (ro,non-prefetchable)
  I/O Ports: 0x9000-0x907f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 25 (2943 events)
  I/O Port: 0x00 (rw)
  Module Alias: "pci:v000010DEd00000A65sv00001043sd00008354bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Driver Info #1:
    Driver Status: nvidia is active
    Driver Activation Cmd: "modprobe nvidia"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #12 (PCI bridge)

Primary display adapter: #14
cat /etc/default/grub      
#grub-quiet 
GRUB_DEFAULT=0
GRUB_TIMEOUT=0
GRUB_RECORDFAIL_TIMEOUT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR="Manjaro"
GRUB_CMDLINE_LINUX_DEFAULT="ro splash udev.log-priority=3"
GRUB_CMDLINE_LINUX=""

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.
GRUB_SAVEDEFAULT=false

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable Hidden Menu, and optionally hide the timeout count
#GRUB_HIDDEN_TIMEOUT=3
#GRUB_HIDDEN_TIMEOUT_QUIET=true

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter 
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx" 
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper 
# modes only.  Entries specified as foreground/background.
GRUB_COLOR_NORMAL="light-gray/black"
GRUB_COLOR_HIGHLIGHT="green/black"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
GRUB_BACKGROUND="/usr/share/grub/background.png"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
sudo hwinfo --framebuffer                      

02: None 00.0: 11001 VESA Framebuffer                           
  [Created at bios.459]
  Unique ID: rdCR.A4frQBHoMz0
  Hardware Class: framebuffer
  Model: "NVIDIA GT218 Board - 08730000"
  Vendor: "NVIDIA Corporation"
  Device: "GT218 Board - 08730000"
  SubVendor: "NVIDIA"
  SubDevice: 
  Revision: "Chip Rev"
  Memory Size: 14 MB
  Memory Range: 0x01000000-0x01dfffff (rw)
  Mode 0x0300: 640x400 (+640), 8 bits
  Mode 0x0301: 640x480 (+640), 8 bits
  Mode 0x0303: 800x600 (+800), 8 bits
  Mode 0x0305: 1024x768 (+1024), 8 bits
  Mode 0x0307: 1280x1024 (+1280), 8 bits
  Mode 0x030e: 320x200 (+640), 16 bits
  Mode 0x030f: 320x200 (+1280), 24 bits
  Mode 0x0311: 640x480 (+1280), 16 bits
  Mode 0x0312: 640x480 (+2560), 24 bits
  Mode 0x0314: 800x600 (+1600), 16 bits
  Mode 0x0315: 800x600 (+3200), 24 bits
  Mode 0x0317: 1024x768 (+2048), 16 bits
  Mode 0x0318: 1024x768 (+4096), 24 bits
  Mode 0x031a: 1280x1024 (+2560), 16 bits
  Mode 0x031b: 1280x1024 (+5120), 24 bits
  Mode 0x0330: 320x200 (+320), 8 bits
  Mode 0x0331: 320x400 (+320), 8 bits
  Mode 0x0332: 320x400 (+640), 16 bits
  Mode 0x0333: 320x400 (+1280), 24 bits
  Mode 0x0334: 320x240 (+320), 8 bits
  Mode 0x0335: 320x240 (+640), 16 bits
  Mode 0x0336: 320x240 (+1280), 24 bits
  Mode 0x033d: 640x400 (+1280), 16 bits
  Mode 0x033e: 640x400 (+2560), 24 bits
  Mode 0x0345: 1600x1200 (+1600), 8 bits
  Mode 0x0346: 1600x1200 (+3200), 16 bits
  Mode 0x034a: 1600x1200 (+6400), 24 bits
  Mode 0x0360: 1280x800 (+1280), 8 bits
  Mode 0x0361: 1280x800 (+5120), 24 bits
  Config Status: cfg=new, avail=yes, need=no, active=unknown

Even when I remove quiet from GRUB_CMDLINE_LINUX_DEFAULT=
I see only black screen.

systemctl status systemd-fsck-root.service
● systemd-fsck-root.service - File System Check on Root Device
   Loaded: loaded (/usr/lib/systemd/system/systemd-fsck-root.service; static; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:systemd-fsck-root.service(8)

I use btrfs and BIOS motherboard.

Isn't plymouth making start slower a little bit?

I think 'quiet' has loglevel 1:
CONFIG_CONSOLE_LOGLEVEL_QUIET=1
But maybe that kernel setting gets overridden by other settings.

Plymouth is deprecated since some time, if I remember correctly.

1 Like

Not Plymouth, but Bootsplash. Plymouth is being developed and widely used across different distros, while Bootsplash is dead for like more than year. Doesn't matter much since its corpse still can be incorporated to the kernel without much hassle and still reacts to some galvanic methods :slight_smile:

Ah OK then you don't need to play with efibootmgr and fsck hook and service. Just forget that part of my post. And remove ro then, it's not for your special case (btrfs).

First I should ask if you managed to hide grub completely? I mean did GRUB_RECORDFAIL_TIMEOUT=0 help?

And finally some adjustments to GRUB_CMDLINE_LINUX_DEFAULT are necessary. Not only you need to remove ro, but splash too. Put quiet there, so only quiet udev.log-priority=3 would be your options. This should make your system show a manufacturer logo during the boot. Sorry earlier I've forgotten to tell you that you have to regenerate initramfs: sudo mkinitcpio -P. Do it along with sudo update-grub to make sure if logo is present. If not, your MB doesn't provide bgrt logo at all and you need to install Plymouth or Bootsplash themes. Regenerating initramfs NOW is not necessary but I just want to make sure it is written here.
I've already linked to the post where I described how to enable Plymouth, the only thing I must add here is I don't understand why you have splash option now if you're still haven't installed Plymouth since splash is Plymouth-related thing, putting it in kernel option string does nothing (AFAIK).
As for Bootsplash, after installing any theme the kernel options string should be free from quiet and splash (obviously, explained above), but contain bootsplash.bootfile=bootsplash-themes/your/theme udev.log_priority=3 loglevel=3. queit prevents bootsplash from kicking in, in other words, if your MB doesn't provide a logo with quiet, then even with set bootsplash theme such quiet option will suppress the fancy splash and resulting in a black screen instead.

Do note that after installing and enabling either plymouth theme or bootsplash theme in kernel options you need to add relevant hooks to HOOKS array of /etc/mkinitcpio.conf and regenerate initramfs (see the beginning of this post). Only quiet option alone needs no extra intervention to mkinitcpio, but all it can do is showing a static OEM logo, and it doesn't work for BIOS PCs fwiw.

1 Like

I still don't see background but I installed plymouth. I will leave it for now, because it is not so important to waste more time on it.
Thank you.

If you installed plymouth, this shouldn't be...

It should be ...
GRUB_CMDLINE_LINUX_DEFAULT="splash rw"

And with

bootsplash-manjaro in HOOKS line at mkinitcpio.conf (and mkinitcpio to complete)

But with grub-2.04-6, not sure if it works as it should.

Probably the best, for an umimportant matter.

But ... everybody should use grub-vanilla, even for 'manjaro-laptops' (hidden menu).
But what do I know.

So it's not "plymouth" in the Hooks line?

Forum kindly sponsored by Bytemark