[solved] Manjaro Live wont't boot (stuck at: Welcome to GRUB)

stable
boot
live-media

#1

Hey guys,

so I’ve found similar problems on different websites online and also on this forum, but couldn’t find a working solution to my case.
So I downloaded the (as of now) newest stable - ISOs of XFCE and Cinnamon trying to install them on my old Lenovo B570 (model: 1068GEG).

On my main notebook I am running windows.
I used about three different USB pens, and tried Rufus (dd and ISO mode), imagewriter and Etcher.

The problem remains the same every time: I am greeted with “Welcome to GRUB!” and from there is doesn’t go any further.
Other Distros work fine, even arch-based distros (I’ve tried antergos, anarchy and Arch). It’s a legacy-boot, so no UEFI.

It doesn’t matter if I wait ten minutes or an hour :confused:
I really don’t know how to go on from there … any help is appreciated.

Thanks

*mt


Help to install manjaro on legacy mode
#2

Did you press the Boot Manjaro x86_64 line in the grub menu?


#3

I’m not even shown a menu where I can press anything :confused:
Like I said, it says “Welcome to GRUB!” and from there on nothing, nothing to choose from, nothing to type, no input of any kind works except for pressing the power button and shutting down the notebook.

RIght now (literally one minute ago) I tried creating a Live-USB with Linux Live USB Creator.

No at least the following happens:

Welcome to Grub!
error: unknown filesystem
Entering rescue mode...
grub rescue>

That has never happened before though. Only now after using Linux Live USB Creator.

Thx for your answer, btw!

Edit: The USB pen is not GPT protected, I already checked that.


#4

Where did you download the ISO and does the checksums match?


#5

I downloaded it from the main site (using torrent for Cinnamon and XFCE), checksums (sha1sum) match, yes!


#6

So, just to be clear, you downloaded both Cinnamon 17.0.5 and XFCE 17.0.5 with torrents and you checked the checksums for each of them?

Did you try creating the USB with just dd?

sudo dd if=/isofile.iso of=/dev/sdX bs=4M

change the path of the ISO file and the path of your USB device accordingly.


#7

Maybe better to download the 17.0.3 installer and using RUFUS in DD mode.


#8

@Strit: Yes, I downloaded both, the Cinnamon Edition and the XFCE Edition through torrent and checked the sha1sum for both of them, and they both were okay.

Right now I don’t have any other Linux notebook/pc with me, so I have to create a the USB in Windows (as I mentionend in the first post), but i’ve tried DD and ISO through Rufus and imagewriter.
Couple of minutes ago I also tried Linuxe Live USB Creator which at least leads to grub rescue, as mentionend above. Thanks for your help so far :slight_smile:

@bogdan: Hm, I’ll give that a try right now. Thanks!


#9

sigh

Same problem for Manjaro 17.0.3 :cry:

I’m booting from USB, and all I see is “Welcome to GRUB!” and than nothing I can do, but turn off the notebook :confused:
It’s just so weird since literally EVERY other distro (I tried) works…

Edit: Is there nothing I can do from boot rescue? (Which I at least get to when I write the image with Linux Live USB Creator)


#10

Oh, that’s quite surprising and unfortunate. Does your bios have some sort of security settings on?
My last resort, as a suggestion, is to try the Manjaro-Architect.


#11

Hey @melltuga, try to press down arrow button on keyboard twice and enter after welcome to GRUB message.


No way to install Manjaro on my desktop
#12

… wow.

How did I not realize that it might be that (I’ve installed manjaro on all of my notebooks so far (except for my main notebook, which I use for work).

Well, I’d still be interested in why I’m not shown the menu. Do you have an idea for that as well?


#13

I guess thanks to @AV_Aca this can be marked as solved then…


#14

Because your gpu dont support specific resolution that GRUB use in that video mode. Have the same problem.


#15

That is so weird, I’ve never encountered that before. Wow, thanks so much.

I’d be interested in how you found that one out, if you have the time…


#16

Also, thanks to everyone involved!


#17

Hi, i had the same problem here… thanx for you solution! :grinning:


#18

Glad that i could help. :grin:
I wonder… Is this good timing to create a pool so we can try to see how many people are affected?


#19

Well, more interesting ist to fix this? I had also an APU.
LF


#20

I’m not sure that can be fixed “on a GRUB level”. I understand why Manjaro developers made that switch.
Only thing that comes to my mind is to try to persuade Manjaro-devs to additionally create something like a alternate ISO with old GFX Boot Menu. But that could only be possible if we have enough affected users.