[Solved] Manjaro KDE is incredibly slow, but Cinnamon and XFCE are snappy

kde
desktop-environment
performance
desktop-hopping

#41

I mean the GUI pamac, yes. My mistake.


#42
Gtk-Message: 17:15:04.443: Failed to load module "appmenu-gtk-module"

(pamac-manager:6109): Gtk-WARNING **: 17:15:04.476: Theme directory actions32@2x of theme breeze-dark has no size field

#43

I must say thanks for yakuake. This is one sweet terminal.


#44

This is a GTK3 application - what theme do you have set?

Reboot, try again as you said it was on first run. Also try a KDE app like kate or dolphin.


#45

Good isn’t it :smiley: Though I find konsole itself to be a bit poor, yakuake is better.


#46

I have Breeze Dark set for almost everything, Simple-and-Soft for cursor theme, Papirus-Dark for icons, and then under “GNOME Application Style (GTK)”, I have the following changes:
Cursor Theme: Simple-and-Soft
Icon Theme: Breeze Dark
Fallback Theme: ePapirus

I haven’t restarted my laptop yet, but I can tell you Dolphin on startup takes about a minute-and-a-half to start, and then after that takes 5 seconds to start. So it’s faster than Pamac at startup but slower than Pamac afterwards.
Here are the errors I get when running dolphin on yakuake:

kf5.kio.core: We got some errors while running testparm "Load smb config files from /etc/samba/smb.conf\nError loading services.\n"
kf5.kio.core: We got some errors while running 'net usershare info'
kf5.kio.core: "Can't load /etc/samba/smb.conf - run testparm to debug it\n"

#48

That definitely is not normal.
Are you sure baloo is disabled or inactive?
See balooctl status


#49

So your gtk theme is breeze-dark as well? Do you have breeze-gtk installed?


#50

I disabled it in Plasma settings but apparently it’s still running.

Baloo File Indexer is running
Indexer state: Indexing file content
Indexed 89723 / 94629 files
Current size of index is 493.33 MiB

#51

Avoid unnecessary load times.

Do not install any Plasmoids you don’t really need.

Go to System Settings > Startup and Shutdown.

  • In Autostart and Service Manager , disable what you know you do not need, e.g. Bluetooth if you do not use it.
  • In Session Management , select Start with an empty session .

#52

balooctl disable
to disable it.
It’s still indexing files, and on a HDD that slows down just about everything.


#53

According to Pamac, breeze-gtk is installed.


#54

Anyway, good luck, I am in the middle of moving house… And here comes the IKEA van (gulp). Will be back later.


#55

Disabled it, Dolphin still takes about 5 seconds.


#56

@xircon
Sure, mate. Thanks for all the help. Good luck moving house.


#57

Will start uninstalling Plasmoids.

Under System Settings > Startup and Shutdown, the menus are a little different. I think the menus you’re referring to are:

  • Autostart
  • Background Services
  • Desktop Session

If so, I’ve already disabled everything there that I don’t need. The only thing I haven’t done is selecting Start with an empty session. I’ve selected that now and will try restarting after I’ve done all your suggestions.


#58

Do you have the possibility to make a fresh install ?
I have KDE, and for me it’s the fastest and smoothest version from any distros that I have tried.
I have SSD and the total start, from pressing the power button, takes about 18 seconds.


#59

OP, at this point I would go for a clean, fresh slate. Your 5400 RPM spinner has nothing to do with minute+ app start up times but at this point–having tried all else–it might be the fact of combined DEs, applications and settings all jammed up in your flimflam.

Until you install and run Plasma solely, I don’t think you’re gonna have much more success. You don’t need anything close to an SSD to achieve very acceptable speeds for anything KDE.

regards


#60

@hilltothesouth you should not write your solution to the first topic, as this isn’t how this forum works.
Please post the solution in a new post and mark the post that gives the solution as “Solution” (checkmark showed after clicking the … button). You should try to realize which was the actual problem, as it is not really contributing to say “I did all and I don’t know what was the solution”.
Be a proper Manjaro family member! :wink:


#61

I’d pondered removing this drudge for years from my KDE4 & nowadays Plasma5 but never proceeded… today i realised i could not remember why i’d never done it. Then i rediscovered the reason; a dependency of kmymoney unfortunately is akonadi, ergo removing the latter also removes the former. That revelation surprised & puzzled me, so i fired up my Manjaro Xfce VM & made as if i was going to install kmymoney via Pamac. Sure enough, in the long list of dependencies that would also be installed, one sadly is akonadi. Given that KMM is a critically important pgm for me, which i will not forego, it seems i’m stuck with the akonadi drudge. Hence FYI – it’s good that you were able to remove it, but if in future you ever decide to use KMM, then the dreaded A will return to haunt you. :thinking: