[Solved] Manjaro KDE is incredibly slow, but Cinnamon and XFCE are snappy

kde
desktop-environment
performance
desktop-hopping

#1

I have Manjaro XFCE and KDE installed, and until recently had Cinnamon installed as my main DE until the recent update to 18.0.0 wouldn’t allow me to log in to Cinnamon anymore. So I’ve used all three of these DE’s with Manjaro and KDE is definitely the most beautiful, and definitely the SLOWEST by far! I never even thought about performance on XFCE and Cinnamon, because I never had a problem with speed on them. But on KDE, I’m taking 4 minutes just to reach my desktop and 5-10 seconds each just to open Firefox, Pacman, my system settings, Konsole, or anything, really. Contrast that with Cinnamon’s less-than-2-minutes to reach desktop and about-1-second to open any application, and you see why I’m complaining. Is this normal for KDE or is there something wrong with my install? I installed Manjaro with XFCE originally, then added Cinnamon on top of that, then removed Cinnamon, and then finally installed KDE. Might all my desktop hopping have something to do with this problem?

Here’s my set-up.

System:    Host: Alloy Kernel: 4.19.6-1-MANJARO x86_64 bits: 64 compiler: gcc v: 8.2.1 Desktop: KDE Plasma 5.14.4 
           Distro: Manjaro Linux 
Machine:   Type: Laptop System: ASUSTeK product: N750JK v: 1.0 serial: <filter> 
           Mobo: ASUSTeK model: N750JK v: 1.0 serial: <filter> UEFI: American Megatrends v: N750JK.203 date: 05/21/2014 
Battery:   ID-1: BAT0 charge: 44.4 Wh condition: 44.4/69.5 Wh (64%) model: ASUSTeK N750-62 status: Not charging 
CPU:       Topology: Quad Core model: Intel Core i7-4710HQ bits: 64 type: MT MCP arch: Haswell rev: 3 L2 cache: 6144 KiB 
           flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39925 
           Speed: 1896 MHz min/max: 800/3500 MHz Core speeds (MHz): 1: 1897 2: 1891 3: 1896 4: 1896 5: 1892 6: 1898 7: 1845 
           8: 1896 
Graphics:  Device-1: Intel 4th Gen Core Processor Integrated Graphics vendor: ASUSTeK driver: i915 v: kernel bus ID: 00:02.0 
           Device-2: NVIDIA GM107M [GeForce GTX 850M] vendor: ASUSTeK driver: nouveau v: kernel bus ID: 01:00.0 
           Display: x11 server: X.org 1.20.3 driver: intel,nouveau unloaded: modesetting resolution: <xdpyinfo missing> 
           OpenGL: renderer: Mesa DRI Intel Haswell Mobile v: 4.5 Mesa 18.2.6 direct render: Yes 
Audio:     Device-1: Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio driver: snd_hda_intel v: kernel bus ID: 00:03.0 
           Device-2: Intel 8 Series/C220 Series High Definition Audio vendor: ASUSTeK driver: snd_hda_intel v: kernel 
           bus ID: 00:1b.0 
           Sound Server: ALSA v: k4.19.6-1-MANJARO 
Network:   Device-1: Qualcomm Atheros AR9485 Wireless Network Adapter vendor: AzureWave driver: ath9k v: kernel port: e000 
           bus ID: 03:00.0 
           IF: wlp3s0 state: up mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: ASUSTeK driver: r8168 v: 8.045.08-NAPI 
           port: d000 bus ID: 04:00.0 
           IF: enp4s0 state: down mac: <filter> 
Drives:    Local Storage: total: 931.51 GiB used: 189.50 GiB (20.3%) 
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB 
Partition: ID-1: / size: 156.76 GiB used: 19.01 GiB (12.1%) fs: ext4 dev: /dev/sda6 
Sensors:   System Temperatures: cpu: 59.0 C mobo: N/A 
           Fan Speeds (RPM): cpu: 2700 
Info:      Processes: 243 Uptime: 28m Memory: 11.61 GiB used: 1.99 GiB (17.2%) Init: systemd Compilers: gcc: 8.2.1 
           clang: 7.0.0 Shell: bash v: 4.4.23 inxi: 3.0.27 


SOLUTION

Thanks all. It worked! I restarted my laptop and performance is now comparable to Cinnamon and XFCE. Still just a tad bit slower than them but at least comparable and acceptable.

I did a lot, so I can’t be too sure what finally did it. What I think finally sped things up:

  1. Actually disabling baloo
  2. Selecting System Settings > Startup and Shutdown > Desktop Session > On Logins > Start with an empty session
  3. Uninstalling Akonadi / PIM

So thanks to @torvic, @Librewish, and @xircon for the suggestions. I’ll also be sure to take @bogdancovaciu’s advice into account next time I try to install multiple DE’s.


#2

systemd-analyze blame
to check whats causing the slow startup


#3

@Librewish

         13.638s systemd-journal-flush.service
         11.942s dev-sda6.device
          8.421s ModemManager.service
          4.809s NetworkManager.service
          4.355s systemd-fsck@dev-disk-by\x2duuid-FA50\x2dEA02.service
          3.732s avahi-daemon.service
          3.713s polkit.service
          3.628s grub-boot-indeterminate.service
          3.612s bluetooth.service
          3.609s systemd-logind.service
          3.604s add-autologin-group.service
          3.523s ufw.service
          3.478s systemd-udevd.service
          3.125s run-media-southhill773-Data.mount
          2.083s systemd-sysusers.service
          2.036s ldconfig.service
          1.786s lvm2-monitor.service
          1.596s systemd-tmpfiles-setup-dev.service
           998ms systemd-modules-load.service
           975ms boot-efi.mount
           757ms systemd-timesyncd.service
           706ms systemd-tmpfiles-setup.service
           660ms udisks2.service
           638ms systemd-udev-trigger.service
           569ms systemd-random-seed.service
           557ms systemd-rfkill.service
           526ms systemd-binfmt.service
           502ms systemd-tmpfiles-clean.service
           480ms upower.service
           444ms systemd-journal-catalog-update.service
           415ms wpa_supplicant.service
           368ms systemd-sysctl.service
           285ms haveged.service
           268ms kmod-static-nodes.service
           266ms systemd-journald.service
           264ms systemd-backlight@leds:asus::kbd_backlight.service
           246ms systemd-backlight@backlight:intel_backlight.service
           223ms tlp.service
           222ms dev-hugepages.mount
           221ms systemd-remount-fs.service
           220ms sys-kernel-debug.mount
           193ms systemd-update-utmp.service
           148ms proc-sys-fs-binfmt_misc.mount
           118ms dev-mqueue.mount
            41ms sys-fs-fuse-connections.mount
            39ms user@1000.service
            31ms systemd-user-sessions.service
            31ms rtkit-daemon.service
            24ms pamac-system.service
            24ms systemd-update-done.service
             8ms user-runtime-dir@1000.service
             2ms tmp.mount
             2ms sys-kernel-config.mount


#4

First of all:

  1. do you use the same user for all this DE’s ?
  2. KDE Plasma was installed afterwards and we can’t estimate what/how you did it.
  3. according to your inxi it seems you are using the nouveau driver for GeForce GTX 850M, alongside with Intel GPU … and probably your Compositor is also not set to OpenGL 3.1 in Settings.

#5

@bogdancovaciu

  1. Same user
  2. I used the wiki here: https://wiki.manjaro.org/index.php/Install_Desktop_Environments#KDE_Plasma_5
  3. I already am using OpenGL 3.1 for the compositor

#6

The problem isn’t the graphics, by the way. It’s starting applications up. The graphics are smooth once the applications start running, but starting them up is incredibly slow.


#7

you can use bleachbit to clean your cache and journald
you can also disable modem manager service if you dont use 3g/4g modem
same for bluetooth


#8

Yes, but you have to be very careful, and don’t use it as root.
Do NOT clean journals with bleachbit, do it with journalctl


#9

Not the best mixup

That is how you install a DE from a non DE installation, not how to mix them up :slight_smile:

OK then

is a HDD that has 5400 RPM spin speed, you can’t expect instant load. Also, KDE plasma has some animations and the Launck Feedback that might create the impression of latency …


#10

I already disabled bluetooth.

I can’t find any service called “modem manager” in the Plasma settings, so I’ll have to do some more figuring out for that one. But I’m not sure I’d want to disable it because I move Wi-Fi networks a lot; I work in a lot of cafes.

As for bleachbit, I’ll start working on giving it a try since systemd-journal-flush.service is at the top of the blame list. As for the cache, I have no idea what cache I should be cleaning up.


#11

Because is case sensitive and is called ModemManager


#12

Got it. Now I know better for next time.


#13

Baloo file indexing could be slowing your system down.


#14

Okay, you have a rotating HDD - that explains most of the slowness.
KDE profits immensely from SSDs.


#15

Yeah, I tried “ModemManager” and “modemmanager” and “modem manager” and “Modem Manager”. I don’t think they’re in the Plasma settings but somewhere else.


#16

systemctl disable ModemManager


#17

Better to mask it, an update will bring it back :smiley:


#18

Ah yes :slight_smile: MM is one of the first things I remove.

In any way though, MM is not the reason why KDE feels slow.


#19

Already disabled baloo.


#20

What does MM do, exactly?