[Solved] Login Loop - Logging in leads to new login dialog



If you are able to chroot, you could try to : rm /home/user/.Xauthority

Related links : https://stackoverflow.com/questions/35257321/infinite-login-lightdm-archlinux


If you want help then provide the info requested and it can be worked through analytically, no guessing.


You said you cannnot log into tty, it could also be due to a caps mismatch when entering your username. Did you try it as both username and Username? Just an idea.

Regarding lightdm, you could check the status of the service (if you can get in with tty)

systemctl status lightdm.service



I respectfully disagree. In my opinion, guessing is appropriate when I am almost entirely ignorant of the inner workings of a system that has a problem. It’s like a Black Box experiment. If this were science, they’d call it forming a hypothesis, which would then be subjected to experiment to support or falsify it.

Your suggestions have been enormously helpful to me. I am genuinely grateful for that.

However, I feel that it is important for me to understand what’s going on. If I am lazy and just let you give me all the answers, then I may restore the system, but I will likely not understand what happened.

For example, you suggested that I get the information from inxi. I did that. I then tried to see whether I could find anything that offers a hint as to the problem. Similarly with the lightdm.conf file - and other configuration files I have hunted down. I felt I should at least make an effort to do some work on my own, instead of just sitting back and letting you and others do it for me.

I will post the results of the commands you suggested, when I am able to do so. I’m not ignoring your advice, I’m just trying to understand as I go along.


I did as you suggested, but it had the same results. The login was rejected…


Hmm… Ok, one more idea, you could try enabling autologin. It wouldn’t solve this looping issue, more of a workaround, but just to see if that works at least.

If you can chroot in, uncomment (remove the pound sign from in front of the line) the following line in the /etc/lightdm/lightdm.conf file and put your username at the end of it (you may want to make a backup copy of it first: sudo cp /etc/lightdm/lightdm.conf /etc/lightdm/lightdm.conf.bak)


To open and edit it in a terminal

SUDO_EDITOR=nano sudoedit /etc/lightdm/lightdm.conf

then Ctrl+X and y, to save it.


Could not agree more, but IMO you will learn far more by working through an issue like this in a more communal way. This was my personal experience anyway, once the issue is understood and fixed you can then dive into references like Arch wiki to fully understand it in much greater depth. Particularly when the issue stops your system from booting.

My 2c anyway, each to their own, all good.


You make a good point that I hadn’t considered… but it makes sense. I’ll try to me more communal.


I am working nights - I work for the health service in the UK. Just got home 08:00 ish - time for bed :smiley: :zzz:

The rest - Manjaro is used all over the world, so there is often people around.


I found the problem and corrected it. Now I can log into my system normally.

A file named ~/.xsession-error contained a line that read:

xfce4-session: error while loading shared libraries:  libxfconf-0.so.2: cannot open shared object file: No such file or directory

In the /usr/lib/ directory I found files for a newer version of xfce4 (libxfconf-0.so.3, etc,). Evidently when I upgraded xfce4, not all parts of it were upgraded.

I downgraded xfce4 to the previous version, which solved this problem.

I would like to point out that the problem of login loop isn’t caused by this particular error. The login loop arises when there’s some error in starting the desktop environment.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.