[Solved] Login Loop - Logging in leads to new login dialog


Suddenly, when I try to log into Manjaro, I find I’m in a loop. I enter my password. The computer does some magic, then gives me the login dialog asking for my password.

This is NOT the same as entering a wrong password. When I give a wrong password, I get the usual error message.

Somehow, there is an infinite loop going on.

I saw a thread about this from August, but there was no solution.

I’d like to get access to my files, if possible. When I use a Linux install USB, I can’t get at the directory using the file manager because of a “Permission Denied” error. I tried using the terminal, but then could not find the directory. I even tried this as root, without success.

Any info would be greatly appreciated.

When I tested the system to see whether the login loop still happened (it did), I tried logging in via TTY. Unlike before, this was successful. I don’t know why this is, but there you are.

I found something intriguing in the file ~/.xsession-error:

xrdb:  "Xft.hinting" on line 19 overrides entry on line 6
xrdb:  "Xft.hintstyle" on line 22 overrides entry on line 7
xfce4-session: error while loading shared libraries:  libxfconf-0.so.2: cannot open shared object file: No such file or directory

So I’ve got two more question:

  1. Is this a possible cause?
  2. How do I fix it, if so?

Note that I don’t know how to connect to the Internet from TTY, which complicates matters.


Can you get to a TTY (press ctrl+alt+f2)?


I get to the TTY, but my password is rejected (Login incorrect).

I suspect that I’m hosed. Wouldn’t be the first time…


The tty uses a US keyboard layout. If you have a keyboard of a different layout, you have to take that into consideration when entering your password. This could also be one of the reasons of the login loop, despite the fact that it doesn’t give you a wrong password error.


Thanks for the idea; however, I use a standard US keyboard.

I think I’ll probably just reinstall Manjaro, because I haven’t ever heard of anyone fixing this problem.


Is your Manjaro partition encrypted? If it is, that would explain this, if not, then it’s strange.


No, it’s just plain old data. It’s not the first time it’s happened to me, either. Guess I’m just lucky…


What DE and what DM?

Are there any journal log messages or kernel log messages that give a more detailed indication of what is going on?


I can’t get in at all. The GUI login dialog leads to a loop. When I get to a TTY, my login cedentials are rejected.

When I use a boot USB, I don’t have necessary permissions to view my home directory.

Using the file manager, I can see the home directory, but I cannot enter it. Using the terminal, I can’t even find the directory.

I’m not familiar with the terms DE and DM.


Desktop Environment (ie KDE, GNOME, XFCE, etc).
Display Manager (SDDM, GDM, LightDM, etc).

You can access your installed system to troubleshoot by live environmen and chroot. If you don’t know what chroot is…


From your live environment determine your installed system root partition using lsblk, then mount and chroot to this partition.

sudo mount /dev/sdXX /mnt
sudo manjaro-chroot /mnt

All commands will now effect your installed system not live system.

Now look for all journal log message for the previous boot cycle

journalctl -b

Or list all error messages

journalctl -p err


Can you login as root, and from root environment try to access your home directory:

or even change your user password.

and give new password.


Yes. As root, I could not see the directory - its disk or partition wasn’t mounted, I guess.

Following @sueridgepipe’s directions, I was able to get into my directory and evidently access my files.

I’m trying now to at least back up a couple of files I want, in case I need to reinstall.


Your instructions were very helpful. I can now access my disk.

I’m hampered by not having a Manjaro installation USB; I’m using lubuntu for the moment… Because of this, I don’t want to try chroot until I understand it better.

The good news is that if I do wind up reinstalling, I’ll probably be able to back up some files I want to keep. Thanks.

The journalctl output was concerned with the lubuntu boot, not the Manjaro one.


You’ll need a live Manjaro ISO in order to re-install, I would suggest you spend a little time troubleshooting from this live environment first before re-installing.

Post info here.


@sueridgepipe: I totally agree. I’m backing up my stuff just in case, able to save it thanks to your intructions. I’ve made the install USB. I can reinstall if needed, but I would prefer to get in there and see whether I can identify the problem and fix it. Even if I can’t fix it, I’m likely to learn something…

The inxi info:

System: Host: manjaro Kernel: 4.9.13-1-MANJARO i686 bits: 32 gcc: 6.3.1
Desktop: Xfce 4 dm: N/A Distro: Manjaro Linux
Machine: Device: laptop System: ASUSTeK product: 1005HA v: x.x serial: A4OAAS022169
Chassis: type: 10 v: x.x serial: 0x00000000
Battery BAT0: charge: 36.0 Wh 92.8% condition: 38.8/46.4 Wh (83%)

Much irrelevant material removed


Much more burdensome, irrelevant material removed.

Sorry about the mess…


Best way to learn.



It occurs to me that the problem isn’t likely to be at boot time. To my understanding, by the time I get to the login dialog, the system is already up and running. Would that be the “greeter?”

My DE is xfce. I’m not sure what the DM is. LightDM looks familiar, but I’m not certain.


I am awake :smiley:

The greeter is the “eye candy” of the Display Manager.

If you cannot log in, you can try the chroot method, or reinstall after recovery of your files.


Boot into live, chroot into your installed system, then use journalctl command to peruse log messages that could help in diagnosing the exact error.


inxi -Fxx
cat /etc/lightdm/lightdm.conf

I don’t use XFCE but there is plenty of users that do, the more specific info the better.

From within your live environment you can post exact text here.


Why is it so many Linux fans are night owls?

Evidently the greeter is how I access lightdm, right? If I understand correctly, then when I am trying to log in, it’s the greeter that creates the dialog asking for my password. Then something strange happens, and I get the greeter again.

So I’m guessing the problem is either with the greeter itself, or some bug that causes lightdm to loop back to the greeter.

I’ve recovered my files, so I can reinstall if need be. But I’m interested in this whole thing. I’m trying to figure it out. It’s intriguing.

The problem isn’t limited to Manjaro; I saw lots of posts about Ubuntu and other distros. There was some talk that there’s a library file missing. It’s evidently been happening for years.