SOLVED: Linux freezes occasionally


My linux freezes occasionally, used Cinnamon Mint before and Manjaro XFCE now (also both live usb’s). The mouse cursor moves but the system is irresponsible. Restarting X helps but further freezes occur. Same behavior with live USB.

I have already unattached all the drives except the MBR SSD, which passes SMART tests. I changed the mobo and CPU (previous freezing also in bios when tried to change the clock by typing numbers). Tried to change memory (although memtest is ok for memory). Tried to change GPU. All extra connections have been removed from mobo (S/PDIF module, front audio and usb, Chassis LCD).

What do you think? Actually the power supply is the only which have not been changed.

Thanks in advance

Hi, there are some 50 threads about freezing already, but you should start with the basics, #1 of Rules and Notices in the first place:

Oh, yes, my friend. We can probably begin with system information and log.


  Kernel: 5.8.16-2-MANJARO x86_64 bits: 64 compiler: N/A 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 
  root=UUID=d7121d7b-26f1-41f4-acbe-ab6169a7e2b8 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: Xfce 4.14.2 tk: Gtk 3.24.20 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASUSTeK model: M5A97 EVO R2.0 v: Rev 1.xx 
  serial: <filter> BIOS: American Megatrends v: 2603 date: 02/12/2015 
  Device-1: hidpp_battery_0 
  model: Logitech Illuminated Living-Room Keyboard K830 serial: <filter> 
  charge: 10% (should be ignored) rechargeable: yes status: Discharging 
  Topology: Quad Core model: AMD FX-4130 bits: 64 type: MCP arch: Bulldozer 
  family: 15 (21) model-id: 1 stepping: 2 microcode: 600063E 
  L2 cache: 2048 KiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 30514 
  Speed: 1446 MHz min/max: 1400/3800 MHz boost: enabled Core speeds (MHz): 
  1: 1473 2: 1419 3: 1409 4: 1482 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP: 
  disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: AMD Cape Verde PRO [Radeon HD 7750/8740 / R7 250E] 
  vendor: PC Partner Limited driver: radeon v: kernel alternate: amdgpu 
  bus ID: 01:00.0 chip ID: 1002:683f 
  Display: x11 server: X.Org 1.20.9 driver: ati,radeon unloaded: modesetting 
  alternate: fbdev,vesa display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 69 size: 708x398mm (27.9x15.7") 
  diag: 812mm (32") 
  OpenGL: renderer: AMD VERDE (DRM 2.50.0 5.8.16-2-MANJARO LLVM 10.0.1) 
  v: 4.5 Mesa 20.1.8 direct render: Yes 
  Device-1: AMD SBx00 Azalia vendor: ASUSTeK driver: snd_hda_intel v: kernel 
  bus ID: 00:14.2 chip ID: 1002:4383 
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 
  vendor: PC Partner Limited driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  chip ID: 1002:aab0 
  Sound Server: ALSA v: k5.8.16-2-MANJARO 
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK P8 series driver: r8169 v: kernel port: d000 bus ID: 02:00.0 
  chip ID: 10ec:8168 
  IF: enp2s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 810.44 GiB used: 7.67 GiB (0.9%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda vendor: Seagate model: ST3250410AS size: 232.89 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: F scheme: MBR 
  ID-2: /dev/sdb vendor: Seagate model: ST9500325AS size: 465.76 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s 
  rotation: 5400 rpm serial: <filter> rev: HPM1 scheme: MBR 
  ID-3: /dev/sdc vendor: Intel model: SSDSA2BW120G3H size: 111.79 GiB 
  block size: physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> 
  rev: 0365 scheme: MBR 
  ID-1: / raw size: 111.79 GiB size: 109.53 GiB (97.98%) used: 7.67 GiB (7.0%) 
  fs: ext4 dev: /dev/sdc1 
  Alert: No Swap data was found. last log:

Last log:

[     8.387] 
X.Org X Server 1.20.9
X Protocol Version 11, Revision 0
[     8.387] Build Operating System: Linux Manjaro Linux
[     8.387] Current Operating System: Linux nkorpi1 5.8.16-2-MANJARO #1 SMP PREEMPT Mon Oct 19 11:33:03 UTC 2020 x86_64
[     8.387] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-5.8-x86_64 root=UUID=d7121d7b-26f1-41f4-acbe-ab6169a7e2b8 rw quiet apparmor=1 security=apparmor udev.log_priority=3
[     8.387] Build Date: 02 September 2020  07:39:17AM
[     8.387]  
[     8.387] Current version of pixman: 0.40.0
[     8.387] 	Before reporting problems, check
	to make sure that you have the latest version.
[     8.387] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     8.387] (==) Log file: "/var/log/Xorg.0.log", Time: Wed Nov  4 23:33:12 2020
[     8.390] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     8.390] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     8.391] (==) No Layout section.  Using the first Screen section.
[     8.391] (==) No screen section available. Using defaults.
[     8.391] (**) |-->Screen "Default Screen Section" (0)
[     8.391] (**) |   |-->Monitor "<default monitor>"
[     8.391] (==) No monitor specified for screen "Default Screen Section".
	Using a default monitor configuration.
[     8.391] (==) Automatically adding devices
[     8.391] (==) Automatically enabling devices
[     8.391] (==) Automatically adding GPU devices
[     8.391] (==) Automatically binding GPU devices
[     8.391] (==) Max clients allowed: 256, resource mask: 0x1fffff
[     8.394] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/misc".
[     8.394] 	Entry deleted from font path.
[     8.394] 	(Run 'mkfontdir' on "/usr/share/fonts/misc").
[     8.396] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/TTF".
[     8.396] 	Entry deleted from font path.
[     8.396] 	(Run 'mkfontdir' on "/usr/share/fonts/TTF").
[     8.396] (WW) The directory "/usr/share/fonts/OTF" does not exist.
[     8.396] 	Entry deleted from font path.
[     8.396] (WW) The directory "/usr/share/fonts/Type1" does not exist.
[     8.396] 	Entry deleted from font path.
[     8.396] (WW) The directory "/usr/share/fonts/100dpi" does not exist.
[     8.396] 	Entry deleted from font path.
[     8.396] (WW) The directory "/usr/share/fonts/75dpi" does not exist.
[     8.396] 	Entry deleted from font path.
[     8.396] (==) FontPath set to:
[     8.396] (==) ModulePath set to "/usr/lib/xorg/modules"
[     8.396] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[     8.396] (II) Module ABI versions:
[     8.396] 	X.Org ANSI C Emulation: 0.4
[     8.396] 	X.Org Video Driver: 24.1
[     8.396] 	X.Org XInput driver : 24.1
[     8.396] 	X.Org Server Extension : 10.0
[     8.397] (++) using VT number 7

[     8.397] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[     8.398] (II) xfree86: Adding drm device (/dev/dri/card0)
[     8.398] (II) Platform probe for /sys/devices/pci0000:00/0000:00:02.0/0000:01:00.0/drm/card0
[     8.401] (EE) 
[     8.401] (EE) Backtrace:
[     8.401] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x53) [0x55650f897c03]
[     8.401] (EE) 1: /usr/lib/Xorg (0x55650f751000+0x151a45) [0x55650f8a2a45]
[     8.401] (EE) 2: /usr/lib/ (0x7fde570b8000+0x3d6a0) [0x7fde570f56a0]
[     8.401] (EE) 3: /usr/lib/Xorg (xf86BusProbe+0x1c2) [0x55650f8ace62]
[     8.401] (EE) 4: /usr/lib/Xorg (InitOutput+0xe9b) [0x55650f8be44b]
[     8.401] (EE) 5: /usr/lib/Xorg (0x55650f751000+0x39426) [0x55650f78a426]
[     8.401] (EE) 6: /usr/lib/ (__libc_start_main+0xf2) [0x7fde570e0152]
[     8.401] (EE) 7: /usr/lib/Xorg (_start+0x2e) [0x55650f78b5ae]
[     8.401] (EE) 
[     8.401] (EE) Segmentation fault at address 0x0
[     8.402] (EE) 
Fatal server error:
[     8.402] (EE) Caught signal 11 (Segmentation fault). Server aborting
[     8.402] (EE) 
[     8.402] (EE) 
[     8.402] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[     8.402] (EE) 
[     8.402] (EE) Server terminated with error (1). Closing log file

Perhaps, I partly figured this out. Seems to be that freezing is mostly due to buggy radeon driver. With nvidia card, no freezes at all in two hours testing session. My two originally tested cards are both old AMDs, R5-220 and R7-250. Same freezes occurred with both of the cards.

But, when I forced “amdgpu” driver for R7 250 (this is SI card and thus “experimentally” supported), the system has frozen once in past two days. Before I couldn’t use the system for an hour.

Fingers crossed I can confirm this in the weekend after more hours.

Don’t get too excited. I built a new desktop pc 6 weeks ago and can’t seem to rid myself of black screen system freezes. AMD gpu and cpu.

My point is I can go days, even week or so without a freeze and then have 3 over two days. So I wouldn’t count it ‘fixed’ until you’re freeze free for a month or more.

True. Freezes still occur with amdgpu but remarkably less. I think I have to switch to Nvidia. I have now tried three AMD cards; everyone have had critical problems with Linux but none of them failed in Windows. On the other hand, I have never had any problems with Nvidia cards.


Do you have swap partition/file, may I ask?

Sometimes your system may freeze if it gets low on RAM!

No, I haven’t. Truth is I had it on past. It was never used, so my RAM capacity has always been enough. I left the swap uncreated when installed Manjaro.

As said, no problems with Nvidia. Problems with radeon driver maybe 5-10 times per hour. Problems with amdgpu driver maybe one per day.

Problems with old nvidia card: what problems you are talking about, bro?

I have to say that Nvidia clearly beats AMD in Linux in terms of stability.

@The_Quantum_Alpha For me, not this type of freeze, where power to the monitor goes off.

@Ooberi Like you I already swapped memory. I got the box for my AMD graphics card out of the loft and sat it with my older nvidia card next to the computer ready to swap them out…not had a freeze since…I think it knows =D

Used now a NVIDIA card about a week, without any issues.

Can’t say anything more than AMD cards suck in Linux.

Back in the days of windows server 2008r2, I had several servers (HP and FS) that froze randomly. I took me forever to figure out that if they were booted with a original HP PS2 mouse connected, this happened. If they got to boot without any mouse connected, or with a non-HP mouse connected, they never froze. Even if the mouse got connected after the server was booted, there where never any issue.

For some reason HP shipped a mouse like this with every {D|M}L3x0 server those days.

What I learned after years of debugging this mouse model was that if you think you’ve tried to swap every single part, there is always a device you’ve forgotten.

1 Like

And in my case, it was not even enough to swap all the parts. I had to switch from AMD (in fact three cards probed) to NViDIA.

Tried 7870 XT, no screen at all.
Tried R5 220 (radeon), freezing occurs many times per hour.
Tried R7 250 (radeon, amdgpu), freezing occurs, frequency depending on the driver being used.

How someone is able to use that buggy driver code in Linux? As said, none of three proved cards failed in Windows.

Don’t know what’s the specific issue behind your problem, but overall the AMD driver experience on Linux is vastly superior to nVidia on Linux nowadays, imo.

It might be an issue of the older GCN1 cards, although I don’t remember anything of the sorts from back when I used one.

Anyway, if you found a solution that works for you, that’s good. :slight_smile:

Yes and this is weird. Nearly everyone are in favor of AMDs in open source world. But how I can be so unlucky with those cards? I have never had any problems with ancient Nvidia GT520 and legacy drivers. Now using NVIDIA GTX750 TI with recent drivers, no issues either.

How do you explain those freezes with AMD R5 220 and R7 250? How do you explain that booting with HD7870XT never succeeded? Those cards had no problems in Windows.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.