[SOLVED] LightDM fails to start after Manjaro XFCE update


#1

Using Manjaro XFCE - VERY great and nice Linux. However: After a system update today, LightDM fails to start. Everything was just fine before this update today; the last big update before had been done 12 days ago. Immediate error message:

systemctl status lightdm.service
● lightdm.service - Light Display Manager
   Loaded: loaded (/usr/lib/systemd/system/lightdm.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Tue 2018-05-15 11:35:12 CEST; 6min ago
     Docs: man:lightdm(1)
  Process: 836 ExecStart=/usr/bin/lightdm (code=exited, status=1/FAILURE)
 Main PID: 836 (code=exited, status=1/FAILURE)

Mai 15 11:35:12 mnjroxe systemd[1]: lightdm.service: Service hold-off time over, scheduling restart.
Mai 15 11:35:12 mnjroxe systemd[1]: lightdm.service: Scheduled restart job, restart counter is at 5.
Mai 15 11:35:12 mnjroxe systemd[1]: Stopped Light Display Manager.
Mai 15 11:35:12 mnjroxe systemd[1]: lightdm.service: Start request repeated too quickly.
Mai 15 11:35:12 mnjroxe systemd[1]: lightdm.service: Failed with result 'exit-code'.
Mai 15 11:35:12 mnjroxe systemd[1]: Failed to start Light Display Manager.

As one diagnosis, I followed other posts and fora:

sudo lightdm --test-mode --debug
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.26.0, UID=0 PID=831
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Registered seat module unity
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Monitoring logind for seats
[+0.01s] DEBUG: New seat added from logind: seat0
[+0.01s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.01s] DEBUG: Seat seat0: Starting
[+0.01s] DEBUG: Seat seat0: Creating greeter session
[+0.01s] DEBUG: Seat seat0: Creating display server of type x
[+0.01s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.01s] DEBUG: Using VT 7
[+0.01s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.01s] DEBUG: XServer 0: Logging to /var/log/lightdm/x-0.log
[+0.01s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.01s] DEBUG: XServer 0: Launching X Server
[+0.01s] DEBUG: Launching process 837: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.01s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.01s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.01s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.01s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.01s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.02s] DEBUG: Process 837 exited with return value 1
[+0.02s] DEBUG: XServer 0: X server stopped
[+0.02s] DEBUG: Releasing VT 7
[+0.02s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.02s] DEBUG: Seat seat0: Display server stopped
[+0.02s] DEBUG: Seat seat0: Stopping session
[+0.02s] DEBUG: Seat seat0: Session stopped
[+0.02s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.02s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.02s] DEBUG: Seat seat0: Stopping
[+0.02s] DEBUG: Seat seat0: Stopped
[+0.02s] DEBUG: Required seat has stopped
[+0.02s] DEBUG: Stopping display manager
[+0.02s] DEBUG: Display manager stopped
[+0.02s] DEBUG: Stopping daemon
[+0.02s] DEBUG: Exiting with return value 1

I did NOT AT ALL change the standard Manjaro settings which - as far as I am aware - relate to display management. This is my lightdm config; it is unchanged as compared to the one that came with the original Manjaro installation (file modification date is old):

/etc/lightdm/lightdm.conf
#
# General configuration
#
# start-default-seat = True to always start one seat if none are defined in the configuration
# greeter-user = User to run greeter as
# minimum-display-number = Minimum display number to use for X servers
# minimum-vt = First VT to run displays on
# lock-memory = True to prevent memory from being paged to disk
# user-authority-in-system-dir = True if session authority should be in the system location
# guest-account-script = Script to be run to setup guest account
# logind-check-graphical = True to on start seats that are marked as graphical by logind
# log-directory = Directory to log information to
# run-directory = Directory to put running state in
# cache-directory = Directory to cache to
# sessions-directory = Directory to find sessions
# remote-sessions-directory = Directory to find remote sessions
# greeters-directory = Directory to find greeters
# backup-logs = True to move add a .old suffix to old log files when opening new ones
# dbus-service = True if LightDM provides a D-Bus service to control it
#
[LightDM]
#start-default-seat=true
#greeter-user=lightdm
#minimum-display-number=0
#minimum-vt=7 # Setting this to a value < 7 implies security issues, see FS#46799
#lock-memory=true
#user-authority-in-system-dir=false
#guest-account-script=guest-account
#logind-check-graphical=false
#log-directory=/var/log/lightdm
run-directory=/run/lightdm
#cache-directory=/var/cache/lightdm
#sessions-directory=/usr/share/lightdm/sessions:/usr/share/xsessions:/usr/share/wayland-sessions
#remote-sessions-directory=/usr/share/lightdm/remote-sessions
#greeters-directory=$XDG_DATA_DIRS/lightdm/greeters:$XDG_DATA_DIRS/xgreeters
#backup-logs=true
#dbus-service=true

#
# Seat configuration
#
# Seat configuration is matched against the seat name glob in the section, for example:
# [Seat:*] matches all seats and is applied first.
# [Seat:seat0] matches the seat named "seat0".
# [Seat:seat-thin-client*] matches all seats that have names that start with "seat-thin-client".
#
# type = Seat type (local, xremote, unity)
# pam-service = PAM service to use for login
# pam-autologin-service = PAM service to use for autologin
# pam-greeter-service = PAM service to use for greeters
# xserver-backend = X backend to use (mir)
# xserver-command = X server command to run (can also contain arguments e.g. X -special-option)
# xmir-command = Xmir server command to run (can also contain arguments e.g. Xmir -special-option)
# xserver-config = Config file to pass to X server
# xserver-layout = Layout to pass to X server
# xserver-allow-tcp = True if TCP/IP connections are allowed to this X server
# xserver-share = True if the X server is shared for both greeter and session
# xserver-hostname = Hostname of X server (only for type=xremote)
# xserver-display-number = Display number of X server (only for type=xremote)
# xdmcp-manager = XDMCP manager to connect to (implies xserver-allow-tcp=true)
# xdmcp-port = XDMCP UDP/IP port to communicate on
# xdmcp-key = Authentication key to use for XDM-AUTHENTICATION-1 (stored in keys.conf)
# unity-compositor-command = Unity compositor command to run (can also contain arguments e.g. unity-system-compositor -special-option)
# unity-compositor-timeout = Number of seconds to wait for compositor to start
# greeter-session = Session to load for greeter
# greeter-hide-users = True to hide the user list
# greeter-allow-guest = True if the greeter should show a guest login option
# greeter-show-manual-login = True if the greeter should offer a manual login option
# greeter-show-remote-login = True if the greeter should offer a remote login option
# user-session = Session to load for users
# allow-user-switching = True if allowed to switch users
# allow-guest = True if guest login is allowed
# guest-session = Session to load for guests (overrides user-session)
# session-wrapper = Wrapper script to run session with
# greeter-wrapper = Wrapper script to run greeter with
# guest-wrapper = Wrapper script to run guest sessions with
# display-setup-script = Script to run when starting a greeter session (runs as root)
# display-stopped-script = Script to run after stopping the display server (runs as root)
# greeter-setup-script = Script to run when starting a greeter (runs as root)
# session-setup-script = Script to run when starting a user session (runs as root)
# session-cleanup-script = Script to run when quitting a user session (runs as root)
# autologin-guest = True to log in as guest by default
# autologin-user = User to log in with by default (overrides autologin-guest)
# autologin-user-timeout = Number of seconds to wait before loading default user
# autologin-session = Session to load for automatic login (overrides user-session)
# autologin-in-background = True if autologin session should not be immediately activated
# exit-on-failure = True if the daemon should exit if this seat fails
#
[Seat:*]
#type=local
#pam-service=lightdm
#pam-autologin-service=lightdm-autologin
#pam-greeter-service=lightdm-greeter
#xserver-backend=
#xserver-command=X
#xmir-command=Xmir
#xserver-config=
#xserver-layout=
#xserver-allow-tcp=false
#xserver-share=true
#xserver-hostname=
#xserver-display-number=
#xdmcp-manager=
#xdmcp-port=177
#xdmcp-key=
#unity-compositor-command=unity-system-compositor
#unity-compositor-timeout=60
greeter-session=lightdm-gtk-greeter
#greeter-hide-users=false
#greeter-allow-guest=true
#greeter-show-manual-login=false
#greeter-show-remote-login=true
user-session=xfce
#allow-user-switching=true
#allow-guest=true
#guest-session=
session-wrapper=/etc/lightdm/Xsession
#greeter-wrapper=
#guest-wrapper=
#display-setup-script=
#display-stopped-script=
#greeter-setup-script=
#session-setup-script=
#session-cleanup-script=
#autologin-guest=false
#autologin-user=
#autologin-user-timeout=0
#autologin-in-background=false
#autologin-session=
#exit-on-failure=false

#
# XDMCP Server configuration
#
# enabled = True if XDMCP connections should be allowed
# port = UDP/IP port to listen for connections on
# listen-address = Host/address to listen for XDMCP connections (use all addresses if not present)
# key = Authentication key to use for XDM-AUTHENTICATION-1 or blank to not use authentication (stored in keys.conf)
# hostname = Hostname to report to XDMCP clients (defaults to system hostname if unset)
#
# The authentication key is a 56 bit DES key specified in hex as 0xnnnnnnnnnnnnnn.  Alternatively
# it can be a word and the first 7 characters are used as the key.
#
[XDMCPServer]
#enabled=false
#port=177
#listen-address=
#key=
#hostname=

#
# VNC Server configuration
#
# enabled = True if VNC connections should be allowed
# command = Command to run Xvnc server with
# port = TCP/IP port to listen for connections on
# listen-address = Host/address to listen for VNC connections (use all addresses if not present)
# width = Width of display to use
# height = Height of display to use
# depth = Color depth of display to use
#
[VNCServer]
#enabled=false
#command=Xvnc
#port=5900
#listen-address=
#width=1024
#height=768
#depth=8

In case this might help,this is the pacman log of today’s system update - maybe the culprit is to be discovered therein:

/etc/var/log/pacman.log
[2018-05-15 10:38] [PAMAC] synchronizing package lists
[2018-05-15 10:38] [ALPM] transaction started
[2018-05-15 10:38] [ALPM] upgraded manjaro-system (20180319-1 -> 20180507-1)
[2018-05-15 10:38] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Fix js52 upgrade ...e[1;0m
[2018-05-15 10:38] [PACMAN] Running 'pacman --noconfirm -S js52'
[2018-05-15 10:38] [ALPM-SCRIPTLET] Löse Abhängigkeiten auf...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Suche nach in Konflikt stehenden Paketen...
[2018-05-15 10:38] [ALPM-SCRIPTLET] 
[2018-05-15 10:38] [ALPM-SCRIPTLET] Pakete (1) js52-52.7.3-2
[2018-05-15 10:38] [ALPM-SCRIPTLET] 
[2018-05-15 10:38] [ALPM-SCRIPTLET] Gesamtgröße des Downloads:           10,90 MiB
[2018-05-15 10:38] [ALPM-SCRIPTLET] Gesamtgröße der installierten Pakete:  46,53 MiB
[2018-05-15 10:38] [ALPM-SCRIPTLET] Größendifferenz der Aktualisierung:   0,00 MiB
[2018-05-15 10:38] [ALPM-SCRIPTLET] 
[2018-05-15 10:38] [ALPM-SCRIPTLET] :: Installation fortsetzen? [J/n] 
[2018-05-15 10:38] [ALPM-SCRIPTLET] :: Empfange Pakete...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Lade js52-52.7.3-2-x86_64.pkg.tar.xz herunter...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Prüfe Schlüsselring...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Prüfe Paketintegrität...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Lade Paket-Dateien...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Prüfe auf Dateikonflikte...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Überprüfe verfügbaren Festplattenspeicher...
[2018-05-15 10:38] [ALPM] transaction started
[2018-05-15 10:38] [ALPM-SCRIPTLET] :: Verarbeite Paketänderungen...
[2018-05-15 10:38] [ALPM-SCRIPTLET] Aktualisiere js52...
[2018-05-15 10:38] [ALPM] upgraded js52 (52.7.3-1 -> 52.7.3-2)
[2018-05-15 10:38] [ALPM] transaction completed
[2018-05-15 10:38] [ALPM] running 'systemd-update.hook'...
[2018-05-15 10:38] [ALPM-SCRIPTLET] :: Starte post-transaction hooks...
[2018-05-15 10:38] [ALPM-SCRIPTLET] (1/1) Arming ConditionNeedsUpdate...
[2018-05-15 10:38] [ALPM] transaction completed
[2018-05-15 10:38] [ALPM] running 'systemd-update.hook'...
[2018-05-15 10:38] [ALPM] warning: lock file missing /var/lib/pacman/db.lck
[2018-05-15 10:40] [PAMAC] synchronizing package lists
[2018-05-15 10:43] [ALPM] running 'firefox-pre.hook'...
[2018-05-15 10:43] [ALPM] transaction started
[2018-05-15 10:43] [ALPM] upgraded linux-api-headers (4.14.8-1 -> 4.16.1-1)
[2018-05-15 10:43] [ALPM] warning: /etc/passwd installed as /etc/passwd.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/gshadow installed as /etc/gshadow.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/fstab installed as /etc/fstab.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/shells installed as /etc/shells.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/shadow installed as /etc/shadow.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/crypttab installed as /etc/crypttab.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/hosts installed as /etc/hosts.pacnew
[2018-05-15 10:43] [ALPM] warning: /etc/group installed as /etc/group.pacnew
[2018-05-15 10:43] [ALPM] upgraded filesystem (2017.06-4.5 -> 2018.1-3)
[2018-05-15 10:43] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2018-05-15 10:43] [ALPM] upgraded glibc (2.26-11 -> 2.27-2)
[2018-05-15 10:43] [ALPM-SCRIPTLET] Generating locales...
[2018-05-15 10:43] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-05-15 10:44] [ALPM-SCRIPTLET]   de_DE.UTF-8... done
[2018-05-15 10:44] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2018-05-15 10:44] [ALPM-SCRIPTLET] Generation complete.
[2018-05-15 10:44] [ALPM] upgraded gcc-libs (7.3.1+20180312-2 -> 7.3.1+20180406-1)
[2018-05-15 10:44] [ALPM] upgraded pam (1.3.0-1 -> 1.3.0-2)
[2018-05-15 10:44] [ALPM] upgraded xz (5.2.3-1 -> 5.2.4-1)
[2018-05-15 10:44] [ALPM] upgraded cryptsetup (2.0.2-1 -> 2.0.3-1)
[2018-05-15 10:44] [ALPM] upgraded dbus (1.12.6-1 -> 1.12.8-1)
[2018-05-15 10:44] [ALPM] upgraded libidn (1.33-2 -> 1.34-2)
[2018-05-15 10:44] [ALPM] upgraded accountsservice (0.6.46-1 -> 0.6.47-1)
[2018-05-15 10:44] [ALPM] installed libnsl (1.2.0-1)
[2018-05-15 10:44] [ALPM] upgraded libuv (1.20.0-1 -> 1.20.2-1)
[2018-05-15 10:44] [ALPM] upgraded nodejs (9.11.1-1 -> 10.0.0-1)
[2018-05-15 10:44] [ALPM] upgraded npm (5.8.0-2 -> 6.0.0-1)
[2018-05-15 10:44] [ALPM] upgraded python2 (2.7.14-2 -> 2.7.15-1)
[2018-05-15 10:44] [ALPM] upgraded apm (1.19.0-2 -> 1.19.0-6)
[2018-05-15 10:44] [ALPM] upgraded archlinux-appstream-data (20180318-1 -> 20180424-1)
[2018-05-15 10:44] [ALPM] upgraded mhwd-nvidia (1:390.48-1 -> 1:396.24-1)
[2018-05-15 10:44] [ALPM] installed mhwd-nvidia-390xx (390.48-1.1)
[2018-05-15 10:44] [ALPM] upgraded mhwd-db (0.6.2-4 -> 0.6.3-1)
[2018-05-15 10:44] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m Updating Config: '/var/lib/mhwd/local/pci/video-nvidia'e[1;0m
[2018-05-15 10:44] [ALPM] upgraded libpsl (0.20.1-2 -> 0.20.2-0)
[2018-05-15 10:44] [ALPM] upgraded python (3.6.5-1 -> 3.6.5-2)
[2018-05-15 10:44] [ALPM] upgraded pinentry (1.1.0-1 -> 1.1.0-2)
[2018-05-15 10:44] [ALPM] upgraded mhwd (0.6.2-5 -> 0.6.3-1)
[2018-05-15 10:44] [ALPM-SCRIPTLET] xorg configuration symlink valid...
[2018-05-15 10:44] [ALPM] upgraded libepoxy (1.5.0-1 -> 1.5.1+6+gb80ea6a-1)
[2018-05-15 10:44] [ALPM] upgraded freetype2 (2.9-2 -> 2.9.1-1)
[2018-05-15 10:44] [ALPM] upgraded libinput (1.10.5-1 -> 1.10.6-1)
[2018-05-15 10:44] [ALPM] upgraded xkeyboard-config (2.23.1-2 -> 2.23.1-3)
[2018-05-15 10:44] [ALPM] upgraded nvidia-utils (1:390.48-1 -> 1:396.24-1)
[2018-05-15 10:44] [ALPM-SCRIPTLET] xorg configuration symlink valid...
[2018-05-15 10:44] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m If you run into trouble with CUDA not being available, run nvidia-modprobe first.e[1;0m
[2018-05-15 10:44] [ALPM] upgraded mesa (18.0.1-1 -> 18.0.3-0)
[2018-05-15 10:44] [ALPM] upgraded libwebp (0.6.1-1 -> 1.0.0-1)
[2018-05-15 10:44] [ALPM] upgraded atom (1.26.0-1 -> 1.26.1-1)
[2018-05-15 10:44] [ALPM] upgraded binutils (2.29.1-3 -> 2.30-3)
[2018-05-15 10:44] [ALPM] upgraded blueman (2.0.5-1 -> 2.0.5-2)
[2018-05-15 10:44] [ALPM] upgraded brotli (1.0.3-1 -> 1.0.4-1)
[2018-05-15 10:44] [ALPM] upgraded libbytesize (1.1-1 -> 1.2-1)
[2018-05-15 10:44] [ALPM] upgraded libaio (0.3.110-1 -> 0.3.111-1)
[2018-05-15 10:44] [ALPM] upgraded thin-provisioning-tools (0.7.5-1 -> 0.7.6-1)
[2018-05-15 10:44] [ALPM] upgraded qt5-base (5.10.1-7 -> 5.10.1-8)
[2018-05-15 10:44] [ALPM] upgraded cantata (2.2.0-3 -> 2.3.0-1)
[2018-05-15 10:44] [ALPM] upgraded crda (3.18-1 -> 4.14-1)
[2018-05-15 10:44] [ALPM] upgraded poppler (0.63.0-1 -> 0.64.0-1)
[2018-05-15 10:44] [ALPM] upgraded cups-filters (1.20.3-1 -> 1.20.3-2)
[2018-05-15 10:44] [ALPM] upgraded dhcpcd (7.0.1-1 -> 7.0.4-1)
[2018-05-15 10:44] [ALPM] upgraded file (5.32-1 -> 5.33-1)
[2018-05-15 10:44] [ALPM] upgraded firefox (59.0.2-2 -> 60.0-0)
[2018-05-15 10:44] [ALPM] upgraded firefox-i18n-de (59.0.2-1 -> 60.0-0)
[2018-05-15 10:44] [ALPM] upgraded firefox-i18n-en-us (59.0.2-1 -> 60.0-0)
[2018-05-15 10:44] [ALPM] upgraded gcc (7.3.1+20180312-2 -> 7.3.1+20180406-1)
[2018-05-15 10:44] [ALPM] upgraded gcr (3.28.0-1 -> 3.28.0-3)
[2018-05-15 10:44] [ALPM] upgraded net-snmp (5.7.3-7 -> 5.7.3-8)
[2018-05-15 10:44] [ALPM] upgraded hplip (3.18.3-2 -> 3.18.4-2)
[2018-05-15 10:44] [ALPM] upgraded jre8-openjdk-headless (8.u162-2 -> 8.u172-2)
[2018-05-15 10:44] [ALPM] upgraded jre8-openjdk (8.u162-2 -> 8.u172-2)
[2018-05-15 10:44] [ALPM] upgraded jdk8-openjdk (8.u162-2 -> 8.u172-2)
[2018-05-15 10:44] [ALPM] upgraded ldb (1.3.1-1 -> 1.3.2-1)
[2018-05-15 10:44] [ALPM] upgraded lib32-glibc (2.26-11 -> 2.27-2)
[2018-05-15 10:44] [ALPM] upgraded lib32-gcc-libs (7.3.1+20180312-2 -> 7.3.1+20180406-1)
[2018-05-15 10:44] [ALPM] upgraded lib32-nvidia-utils (1:390.48-1 -> 1:396.24-1.1)
[2018-05-15 10:44] [ALPM-SCRIPTLET] xorg configuration symlink valid...
[2018-05-15 10:44] [ALPM] upgraded lib32-mesa (18.0.1-1 -> 18.0.3-0)
[2018-05-15 10:44] [ALPM] upgraded lib32-mesa-vdpau (18.0.1-1 -> 18.0.3-0)
[2018-05-15 10:44] [ALPM] upgraded libetonyek (0.1.7-1 -> 0.1.8-1)
[2018-05-15 10:44] [ALPM] upgraded libmwaw (0.3.13-1 -> 0.3.14-1)
[2018-05-15 10:44] [ALPM] upgraded libpurple (2.13.0-1 -> 2.13.0-2)
[2018-05-15 10:44] [ALPM] upgraded libwps (0.4.8-1 -> 0.4.9-1)
[2018-05-15 10:44] [ALPM] upgraded libreoffice-still (5.4.6-1 -> 5.4.6-2)
[2018-05-15 10:44] [ALPM] upgraded libsynctex (2017.44590-13 -> 2017.44590-14)
[2018-05-15 10:44] [ALPM] upgraded libva-mesa-driver (18.0.1-1 -> 18.0.3-0)
[2018-05-15 10:44] [ALPM] upgraded libwbclient (4.7.6-1 -> 4.8.1-1)
[2018-05-15 10:44] [ALPM] upgraded linux-firmware (20180402.8c1e439-1 -> 20180501.397a604-1)
[2018-05-15 10:44] [ALPM] upgraded linux414 (4.14.36-1 -> 4.14.39-1)
[2018-05-15 10:44] [ALPM] upgraded linux414-nvidia (1:390.48-6 -> 1:396.24-1)
[2018-05-15 10:45] [ALPM] upgraded linux415-nvidia (1:390.48-5 -> 1:396.24-1)
[2018-05-15 10:45] [ALPM] upgraded linux416 (4.16.4-1 -> 4.16.7-1)
[2018-05-15 10:45] [ALPM] upgraded linux416-nvidia (1:390.48-3 -> 1:396.24-1)
[2018-05-15 10:45] [ALPM] upgraded linux416-virtualbox-host-modules (5.2.10-2 -> 5.2.10-6)
[2018-05-15 10:45] [ALPM-SCRIPTLET] In order to use the new version, reload all virtualbox modules manually.
[2018-05-15 10:45] [ALPM] upgraded man-pages (4.15-1 -> 4.16-1)
[2018-05-15 10:45] [ALPM] upgraded manjaro-hello (0.5.11-1 -> 0.5.11-2)
[2018-05-15 10:45] [ALPM] upgraded manjaro-release (17.1.9-1 -> 17.1.10-1)
[2018-05-15 10:45] [ALPM] upgraded mesa-vdpau (18.0.1-1 -> 18.0.3-0)
[2018-05-15 10:45] [ALPM] upgraded mpc (0.29-2 -> 0.30-1)
[2018-05-15 10:45] [ALPM] upgraded python-jade-application-kit (1.3.3-1 -> 1.3.4-1)
[2018-05-15 10:45] [ALPM] upgraded ms-office-online (18.04.3-1 -> 18.04.4-1)
[2018-05-15 10:45] [ALPM] upgraded nano (2.9.5-1 -> 2.9.6-1)
[2018-05-15 10:45] [ALPM] upgraded openvpn (2.4.5-1 -> 2.4.6-1)
[2018-05-15 10:45] [ALPM] upgraded pamac (6.2.7-1 -> 6.3.1-1)
[2018-05-15 10:45] [ALPM] upgraded perl-uri (1.73-1 -> 1.74-1)
[2018-05-15 10:45] [ALPM] upgraded pidgin (2.13.0-1 -> 2.13.0-2)
[2018-05-15 10:45] [ALPM] upgraded poppler-data (0.4.8-1 -> 0.4.9-1)
[2018-05-15 10:45] [ALPM] upgraded poppler-glib (0.63.0-1 -> 0.64.0-1)
[2018-05-15 10:45] [ALPM] upgraded poppler-qt5 (0.63.0-1 -> 0.64.0-1)
[2018-05-15 10:45] [ALPM] upgraded python-setuptools (1:39.0.1-1 -> 1:39.1.0-1)
[2018-05-15 10:45] [ALPM] upgraded smbclient (4.7.6-1 -> 4.8.1-1)
[2018-05-15 10:45] [ALPM] warning: directory permissions differ on /var/lib/samba/private/
filesystem: 755  package: 700
[2018-05-15 10:45] [ALPM] upgraded samba (4.7.6-1 -> 4.8.1-1)
[2018-05-15 10:45] [ALPM] upgraded spectre-meltdown-checker (0.35-1 -> 0.37-1)
[2018-05-15 10:45] [ALPM] installed xorg-xrandr (1.5.0-1)
[2018-05-15 10:45] [ALPM] upgraded steam-manjaro (1.0.0.54-10 -> 1.0.0.54-11)
[2018-05-15 10:45] [ALPM] upgraded tcl (8.6.8-2 -> 8.6.8-3)
[2018-05-15 10:45] [ALPM] upgraded vertex-maia-themes (20180424-3 -> 20180429-1)
[2018-05-15 10:45] [ALPM-SCRIPTLET] 
[2018-05-15 10:45] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m vertex-maia-themes:
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> For seamless integration of Firefox and Palemoon browsers
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> please copy the 'chrome' folder of the desired theme to your browser profile
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> or create a symlink.e[1;0m
[2018-05-15 10:45] [ALPM-SCRIPTLET] e[1;1me[1;32m==>e[1;0me[1;1m For example:
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> 'ln -s /usr/share/themes/Palemoon/Vertex-Maia-Dark/chrome/ ~/.moonchild\ productions/pale\ moon/<xyz123>.default/chrome'
[2018-05-15 10:45] [ALPM-SCRIPTLET]   e[1;0m
[2018-05-15 10:45] [ALPM] upgraded vulkan-icd-loader (1.1.70.0-3 -> 1.1.73.0-1)
[2018-05-15 10:45] [ALPM] upgraded xfce4-screenshooter (1.9.1-1 -> 1.9.2-1)
[2018-05-15 10:45] [ALPM] upgraded xfce4-sensors-plugin (1.2.6-3 -> 1.3.0-1)
[2018-05-15 10:45] [ALPM] upgraded xfce4-whiskermenu-plugin (2.1.6-1 -> 2.1.7-1)
[2018-05-15 10:45] [ALPM] upgraded yubikey-personalization (1.18.1-2 -> 1.19.0-1)
[2018-05-15 10:45] [ALPM] transaction completed
[2018-05-15 10:45] [ALPM] running '60-linux414.hook'...
[2018-05-15 10:45] [ALPM] running '60-linux415.hook'...
[2018-05-15 10:45] [ALPM] running '60-linux416.hook'...
[2018-05-15 10:45] [ALPM] running '90-linux414.hook'...
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'default'
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64.img
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Starting build: 4.14.39-1-MANJARO
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64.img
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux414.preset: 'fallback'
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.14-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.14-x86_64-fallback.img -S autodetect
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Starting build: 4.14.39-1-MANJARO
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:45] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:45] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.14-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:46] [ALPM] running '90-linux415.hook'...
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux415.preset: 'default'
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.15-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Starting build: 4.15.18-1-MANJARO
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.15-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux415.preset: 'fallback'
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.15-x86_64-fallback.img -S autodetect
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Starting build: 4.15.18-1-MANJARO
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.15-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:46] [ALPM] running '90-linux416.hook'...
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux416.preset: 'default'
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.16-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.16-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Starting build: 4.16.7-1-MANJARO
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.16-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux416.preset: 'fallback'
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-4.16-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.16-x86_64-fallback.img -S autodetect
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Starting build: 4.16.7-1-MANJARO
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [keymap]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [resume]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2018-05-15 10:46] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-4.16-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] ==> Image generation successful
[2018-05-15 10:46] [ALPM] running '99-grub.hook'...
[2018-05-15 10:46] [ALPM-SCRIPTLET] GRUB-Konfigurationsdatei wird erstellt …
[2018-05-15 10:46] [ALPM-SCRIPTLET] Hintergrund gefunden: /usr/share/grub/background.png
[2018-05-15 10:46] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.16-x86_64
[2018-05-15 10:46] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.16-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.16-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.15-x86_64
[2018-05-15 10:46] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.15-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.15-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Linux-Abbild gefunden: /boot/vmlinuz-4.14-x86_64
[2018-05-15 10:46] [ALPM-SCRIPTLET] initrd-Abbild gefunden: /boot/intel-ucode.img /boot/initramfs-4.14-x86_64.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Found initrd fallback image: /boot/initramfs-4.14-x86_64-fallback.img
[2018-05-15 10:46] [ALPM-SCRIPTLET] Found memtest86+ image: /boot/memtest86+/memtest.bin
[2018-05-15 10:46] [ALPM-SCRIPTLET] erledigt
[2018-05-15 10:46] [ALPM] running 'detect-old-perl-modules.hook'...
[2018-05-15 10:46] [ALPM] running 'firefox-post.hook'...
[2018-05-15 10:46] [ALPM] running 'glib-compile-schemas.hook'...
[2018-05-15 10:46] [ALPM] running 'gtk-update-icon-cache.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-daemon-reload.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-hwdb.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-sysusers.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-tmpfiles.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-udev-reload.hook'...
[2018-05-15 10:46] [ALPM] running 'systemd-update.hook'...
[2018-05-15 10:46] [ALPM] running 'texinfo-install.hook'...
[2018-05-15 10:46] [ALPM] running 'update-desktop-database.hook'...
[2018-05-15 10:46] [ALPM] running 'update-mime-database.hook'...

Please, I do need help in fixing my Manjaro XFCE! Thanks in advance.

PS: I am new to this forum, so please bear with me if some formatting is wrong or things are too wordy…


Laptop standbys in convertible tablet mode
#2

run startx manually from a different TTY
See if after that works properly. I would suggest to remove (using MHWD) the 4.15 kernel.
Also see the announcement wiki for the update, you have some pacnew files there too that might need some attention …

Edit: Also look if you do use the correct greeter


#3

Thanks, but no solution yet.

Running startx manually from a different TTY yields the Xorg error log as:

[    83.739] 
X.Org X Server 1.19.6
Release Date: 2017-12-20
[    83.741] X Protocol Version 11, Revision 0
[    83.742] Build Operating System: Linux 4.15.6-1-ARCH x86_64 
[    83.742] Current Operating System: Linux mnjroxe 4.16.7-1-MANJARO #1 SMP PREEMPT Wed May 2 19:14:22 UTC 2018 x86_64
[    83.742] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-4.16-x86_64 root=UUID=7b00f0cc-307f-40a2-bff2-a1f767ee15f5 rw quiet resume=UUID=d0e52c5d-112b-47dc-aa2c-7e1e31e38323
[    83.745] Build Date: 12 April 2018  05:31:07AM
[    83.745]  
[    83.746] Current version of pixman: 0.34.0
[    83.747] 	Before reporting problems, check http://wiki.x.org
	to make sure that you have the latest version.
[    83.747] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[    83.750] (==) Log file: "/var/log/Xorg.0.log", Time: Tue May 15 17:19:26 2018
[    83.751] (==) Using config directory: "/etc/X11/xorg.conf.d"
[    83.751] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[    83.751] (==) ServerLayout "Layout0"
[    83.751] (**) |-->Screen "Screen0" (0)
[    83.751] (**) |   |-->Monitor "Monitor0"
[    83.752] (**) |   |-->Device "Device0"
[    83.752] (**) |-->Input Device "Keyboard0"
[    83.752] (**) |-->Input Device "Mouse0"
[    83.752] (==) Automatically adding devices
[    83.752] (==) Automatically enabling devices
[    83.752] (==) Automatically adding GPU devices
[    83.752] (==) Automatically binding GPU devices
[    83.752] (==) Max clients allowed: 256, resource mask: 0x1fffff
[    83.752] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[    83.752] 	Entry deleted from font path.
[    83.752] (WW) The directory "/usr/share/fonts/Type1/" does not exist.
[    83.752] 	Entry deleted from font path.
[    83.752] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[    83.752] 	Entry deleted from font path.
[    83.752] 	(Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[    83.752] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[    83.752] 	Entry deleted from font path.
[    83.752] 	(Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[    83.752] (==) FontPath set to:
	/usr/share/fonts/misc/,
	/usr/share/fonts/TTF/
[    83.752] (==) ModulePath set to "/usr/lib/xorg/modules"
[    83.752] (**) Extension "Composite" is enabled
[    83.752] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    83.752] (WW) Disabling Keyboard0
[    83.752] (WW) Disabling Mouse0
[    83.752] (II) Loader magic: 0x55930d226d60
[    83.752] (II) Module ABI versions:
[    83.752] 	X.Org ANSI C Emulation: 0.4
[    83.752] 	X.Org Video Driver: 23.0
[    83.752] 	X.Org XInput driver : 24.1
[    83.752] 	X.Org Server Extension : 10.0
[    83.753] (++) using VT number 2

[    83.756] (II) systemd-logind: took control of session /org/freedesktop/login1/session/c1
[    83.760] (--) PCI:*(0:1:0:0) 10de:0dfa:103c:1631 rev 161, Mem @ 0xd0000000/16777216, 0xc0000000/134217728, 0xc8000000/33554432, I/O @ 0x00004000/128, BIOS @ 0x????????/131072
[    83.760] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
[    83.760] (II) LoadModule: "glx"
[    83.760] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[    83.762] (II) Module glx: vendor="X.Org Foundation"
[    83.762] 	compiled for 1.19.6, module version = 1.0.0
[    83.762] 	ABI class: X.Org Server Extension, version 10.0
[    83.762] (II) LoadModule: "nvidia"
[    83.762] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[    83.763] (II) Module nvidia: vendor="NVIDIA Corporation"
[    83.763] 	compiled for 4.0.2, module version = 1.0.0
[    83.763] 	Module class: X.Org Video Driver
[    83.763] (II) NVIDIA dlloader X Driver  396.24  Wed Apr 25 22:53:34 PDT 2018
[    83.763] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[    83.763] (II) Loading sub module "fb"
[    83.763] (II) LoadModule: "fb"
[    83.763] (II) Loading /usr/lib/xorg/modules/libfb.so
[    83.763] (II) Module fb: vendor="X.Org Foundation"
[    83.763] 	compiled for 1.19.6, module version = 1.0.0
[    83.763] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    83.763] (II) Loading sub module "wfb"
[    83.763] (II) LoadModule: "wfb"
[    83.763] (II) Loading /usr/lib/xorg/modules/libwfb.so
[    83.763] (II) Module wfb: vendor="X.Org Foundation"
[    83.763] 	compiled for 1.19.6, module version = 1.0.0
[    83.763] 	ABI class: X.Org ANSI C Emulation, version 0.4
[    83.763] (II) Loading sub module "ramdac"
[    83.763] (II) LoadModule: "ramdac"
[    83.764] (II) Module "ramdac" already built-in
[    83.764] (WW) NVIDIA(0): The NVIDIA Quadro 1000M GPU installed in this system is
[    83.764] (WW) NVIDIA(0):     supported through the NVIDIA 390.xx Legacy drivers. Please
[    83.764] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[    83.764] (WW) NVIDIA(0):     information.  The 396.24 NVIDIA driver will ignore this
[    83.764] (WW) NVIDIA(0):     GPU.  Continuing probe... 
[    83.764] (EE) No devices detected.
[    83.764] (EE) 
Fatal server error:
[    83.764] (EE) no screens found(EE) 
[    83.764] (EE) 
Please consult the The X.Org Foundation support 
	 at http://wiki.x.org
 for help. 
[    83.764] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[    83.764] (EE) 
[    83.766] (EE) Server terminated with error (1). Closing log file.

The log near the end points at my NVIDIA Quadro 1000M graphics card and NVIDIA drivers. Yes, I do use an NVIDIA driver with Manjaro, since it worked best; nouveau kept giving me problems (can’t remember exactly what, though). With openSUSE Tumbleweed, I keep using the nouveau driver, since I couldn’t find a suitable NVDIA, and since it just works smoothly there.

I will check into the announcements at the Manjaro forum top page regarding the graphics driver thing, but only by tomorrow. Please, of course, I do need any hints from the community to help out here!

Regarding the greeter: I can only say that everything used to work fine until this system update today.

Please, any help is gratefully welcomed.


#4

Nvidia dropped support for some of the cards with their latest nvidia driver that come with latest updates and of course, in those cases, GUI fails to load. If this is your case as well (probably, error msg says your graphic card is supported up to version 390, but with system updates you got never - but you can check this yourself I don’t have nvidia link handy it was posted somewhere in the thread, see link at the bottom), then you have two options:

  • replace nvidia driver with open source driver
  • replace current nvidia driver with the older version

to replace it with the open source do this:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-linux

To switch it to older version, do this:

sudo mhwd -r pci video-nvidia
sudo mhwd -i pci video-nvidia-390xx

Basically you are removing currently installed nvidia driver that is not supporting your card any more and then you are installing open source or older nvidia driver.

This is only solution for nvidia only card. if yours is hybrid, then commands are:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

All this was explained in second post of current updates, always check these ‘update’ posts first, before you actually decide to do an update (it is part of having rolling release based Linux):


#5

Thank you very much indeed, AlManja. Going back to the 390xx legacy driver worked smoothly. In addition to the recipes given, this just required an internet connection (at least in my case), but I learned that Linux is hooking up to the WiFi even with no GUI running.

Also, thank you for making me (and possibly others) aware of having to read the “update” posts on the Manjaro website and forum before any bigger update is attempted. Could save a lot of trouble! Well, in more than a year of running openSUSE Tumbleweed with its tsunamis of rolling release updates (as compared to the gently rolling tidal waves of Manjaro) I just wasn’t used to reading update notes beforehand (am not even sure Tumbleweed has such a thing). Sorry for that!

Even if it is of no use, please allow me to make one remark regarding this NVIDIA Corp. event of dropping support for an entire GPU family. I had read the forum top note on this, followed the link to the NVIDIA website and had - superficially - tried to find my graphics card (Quadro 1000M) there, but I didn’t. NVIDIA on that webpage just goes by GeForce names, which I couldn’t identify. I just found out at hindsight that the freedesktop.org webpage has the complete list of GPU families, GeForce names and all other names. May I thus politely suggest to make the Manjaro forum update note point to the freedesktop.org webpage more prominently than it does now?

Thanks again for your help.


#6

That is something we should really be pushing more, it is really important and can save people a lot of headaches. Maybe a link to the update thread in Pamac/Octopi?