[Solved] Kernel 4.13 doesn't boot with AMDGPU

kernel
amdgpu

#1

Hello, I have “manjaro i3” and wanted to test the kernel 4.13, but it does not start, it is stopped in “starting version 234”, and it does not advance from there. At the moment I’m using version 4.12 of the kernel, and with this good boot, just throw a fwnode warning, but everything works fine. What could be the problem? I leave my specifications:

System:    Host: federico-pc Kernel: 4.12.11-1-MANJARO x86_64 (64 bit gcc: 7.1.1)
           Desktop: i3 4.13-non-git Distro: Manjaro Linux
Machine:   Device: desktop Mobo: Gigabyte model: H87M-D3H v: x.x
           BIOS: American Megatrends v: F10 date: 07/16/2014
CPU:       Quad core Intel Core i5-4670 (Haswell rev.3) (-MCP-) cache: 6144 KB
           flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 27148
           clock speeds: max: 3800 MHz 1: 1199 MHz 2: 1044 MHz 3: 1199 MHz
           4: 1204 MHz
Graphics:  Card: Advanced Micro Devices [AMD/ATI] Curacao XT / Trinidad XT [Radeon R7 370 / R9 270X/370X]
           bus-ID: 01:00.0
           Display Server: x11 (X.Org 1.19.3) driver: amdgpu
           Resolution: 1920x1080@60.00hz, 1920x1080@60.00hz
           OpenGL: renderer: Gallium 0.4 on AMD PITCAIRN (DRM 3.15.0 / 4.12.11-1-MANJARO, LLVM 4.0.1)
           version: 4.5 Mesa 17.1.8 Direct Render: Yes
Audio:     Card-1 Intel 8 Series/C220 Series High Definition Audio Controller
           driver: snd_hda_intel bus-ID: 00:1b.0
           Card-2 Advanced Micro Devices [AMD/ATI] Cape Verde/Pitcairn HDMI Audio [Radeon HD 7700/7800 Series]
           driver: snd_hda_intel bus-ID: 01:00.1
           Sound: Advanced Linux Sound Architecture v: k4.12.11-1-MANJARO
Network:   Card: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
           driver: r8168 v: 8.044.02-NAPI port: d000 bus-ID: 03:00.0
           IF: enp3s0 state: up speed: 100 Mbps duplex: full
           mac: 94:de:80:ba:92:27
Drives:    HDD Total Size: 1500.3GB (19.0% used)
           ID-1: /dev/sda model: WDC_WD10EZEX size: 1000.2GB
           ID-2: /dev/sdb model: WDC_WD5000AAKX size: 500.1GB
Partition: ID-1: / size: 49G used: 9.9G (22%) fs: ext4 dev: /dev/sda3
           ID-2: /home size: 244G used: 15G (7%) fs: ext4 dev: /dev/sda4
           ID-3: swap-1 size: 2.15GB used: 0.00GB (0%) fs: swap dev: /dev/sda2
Sensors:   System Temperatures: cpu: 29.8C mobo: 27.8C gpu: 35.0
           Fan Speeds (in rpm): cpu: N/A
Info:      Processes: 149 Uptime: 12 min Memory: 944.2/7918.4MB
           Init: systemd Gcc sys: 7.1.1
           Client: Shell (bash 4.4.121) inxi: 2.3.27

Thanks

Solved by @maxper in post #12


Video-ati causing crashes (or KDE, I don't know)
#2

first gen GCN? amdgpu experimental?

Did you test the manjaro 4.13 kernel or a own build?


#3

Kernel manjaro from “manjaro-settings-manager”. My gpu is R9 270x, i think is First GCN


#4

for 4.13.0-1-MANJARO the exp amdgpu support should be enabled.

can you boot up 4.13 and login to a shell (wait after the startin 234 10 secounds and CTRL+ALT+F2) and do

journalctl -b -p err > ~/journal.log                           
cp /var/log/Xorg.0.log ~/xorg.log 

reboot to your 4.12 and you can just paste them here in

[code]
codeblocks
[/code]

#5

Hi tids, it is impossible to access the shell with CTRL + ALT + F2 … F3 … Fn. Does not load screen. The driver version I have installed is:

“xf86-video-amdgpu 1.3.0.2”

If there is anything I can continue to try to solve this problem. Thank you


#6

thats just the xorg driver. not important for us right now.
But its hard without more informations on why. :frowning:

I’d suggest to wait for 4.13.2 and try again. :persevere: It’s not the best plan but I dont have any Idea why this happens… :frowning:


#7

maybe new version of AMDGPU ?
http://www.phoronix.com/scan.php?page=news_item&px=AMDGPU-1.4-Radeon-7.10


#8

See

:wink: When he’s unable to use the TTY terminal it’s on kernel driver level.


#9

I have the same problem:

GPU: Radeon HD 7850 (GCN 1.0)

Linux 4.12 works fine. 4.13 and 4.14 get stuck on the first few lines, screen resolution doesn’t even change fromt hat from GRUb (so, no DRM), and I can’t even ssh into my computer.


#10

Same error here…


#11

It seems that it was not the only one, hopefully with the next updates something changes.


#12

I have Radeon HD7770, use amdgpu driver, this article helps me solve problem.

  1. Edit /etc/default/grub
  2. Add “radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1” to line GRUB_CMDLINE_LINUX="".
  3. sudo update-grub.
    I try this with kernel 4.13 and 4.14.

Kvm: disabled by bios - live DVD hangs on boot
How much is stable Amdgpu-experimental?
Boot stuck after upgrading from 4.12 to 4.14
Unable to install Manjaro
First Preview of Hakoila online
Kernel 4.13.1 hangs at boot
#13

Thanks, it works 10 points, it starts without problems now.


#14

Confirmed working fix for both 4.13 and 4.14. Thank you!

Somehow I had read that article when it was published but I forgot about that change.


4.13 kernel does not work with amdgpu enabled
4.13 kernel does not boot
#15

Thank so much, works fine!!!


#16

I use a R9 390x but with the active amdgpu this tip does not work, what can I try to do?


#17

Wow! That really helped me out! Thanks! It is working with linux 4.14 (will check 4.13 soon; Edit: It works with 4.13 for me, too!). A step foreward since 4.12.14 is the last release before it goes EOL.


#18

For the record if you are using systemd-boot you need to place the radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1 in the /boot/loader/entries/ folder.


#19

with the next stable update it should also work without that, because this little change is now in the package:


#20

At this moment I am with kernel 4.13 and with the grub in this way:

GRUB_CMDLINE_LINUX="radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=1 amdgpu.cik_support=1"

I am with the driver xf86-video-amdgpu, what should I do then so that everything works correctly? Should I install amdgpu-exp or not ?. Thank you