[SOLVED] KDE two touchpad devices detected erroneously

I'm having a weird issue with KDE where it creates a libinput device that is specified as:

SynPS/2 Synaptics TouchPad

Not sure how to remove this entry but have come across this and its become quite a nuisance when I switch over to KDE. Currently on Deepin but any help in how to remove this entry from libinput list-devices would be greatly appreciated. I will add there are two touchpad devices listed because of this additional entry and the touchpad configuration doesn't work on this Synaptics version. Everytime I reboot it defaults to Synaptics but a log out and log in reverts to the correct DLL082A:01 06CF:76AF Touchpad that works with KDE's integration. This is on a Dell XPS 13 9360

i have the same issue where the touchpad gets seen as 2 separate devices and creates crap performance. after playing with libinput of and on for months and getting nowhere (because it's :poop:) i gave the synaptics driver another go and after a good amount of trial/error got it working perfectly.

post these outputs:

inxi -Fxxxza
ls -la /etc/X11/xorg.conf.d/ ; cat /etc/X11/xorg.conf.d/*.conf
pacman -Qs xf86-input

That should be the one.
I really would like for us to minimize user information... somehow this isnt an easy flag .. but should be utilized when asking for info.
[I swear the inxi dev is around here somewhere .. maybe we can bug them if we find them...]

1 Like

i think it was one of your posts i seen in the last few days that made me start adding a to -Fxxxz so i could avoid having to ask for cat /proc/cmdline. i suppose adding --no-host is not asking much :+1:

3 posts were merged into an existing topic: The Goat Herd

inxi -Fxxxza

System:    Kernel: 5.2.8-arch1-1-ARCH x86_64 bits: 64 compiler: gcc v: 9.1.0 
           parameters: BOOT_IMAGE=/boot/vmlinuz-linux root=UUID=9b582a34-6df2-420b-acd0-6d721d07ed4f rw loglevel=3 quiet 
           Desktop: KDE Plasma 5.16.4 tk: Qt 5.13.0 wm: kwin_x11 dm: SDDM Distro: Arch Linux 
Machine:   Type: Laptop System: Dell product: XPS 13 9360 v: N/A serial: <filter> Chassis: type: 9 serial: <filter> 
           Mobo: Dell model: 02PG84 v: A00 serial: <filter> UEFI: Dell v: 2.12.0 date: 05/26/2019 
Battery:   ID-1: BAT0 charge: 48.8 Wh condition: 53.3/60.0 Wh (89%) volts: 8.2/7.6 model: SMP DELL TP1GT61 type: Li-poly 
           serial: <filter> status: Discharging 
CPU:       Topology: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP arch: Kaby Lake family: 6 model-id: 8E (142) 
           stepping: A (10) microcode: B4 L2 cache: 8192 KiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 31880 
           Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 801 4: 800 5: 800 6: 800 7: 800 8: 800 
           Vulnerabilities: Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
Graphics:  Device-1: Intel UHD Graphics 620 vendor: Dell driver: i915 v: kernel bus ID: 00:02.0 chip ID: 8086:5917 
           Display: x11 server: X.org 1.20.5 driver: intel unloaded: modesetting alternate: fbdev,vesa compositor: kwin_x11 
           resolution: <xdpyinfo missing> 
           Message: Unable to show advanced data. Required tool glxinfo missing. 
Audio:     Device-1: Intel Sunrise Point-LP HD Audio vendor: Dell driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
           chip ID: 8086:9d71 
           Sound Server: ALSA v: k5.2.8-arch1-1-ARCH 
Network:   Device-1: Intel Wireless-AC 9260 driver: iwlwifi v: kernel port: f040 bus ID: 3a:00.0 chip ID: 8086:2526 
           IF: wlp58s0 state: up mac: <filter> 
           IF-ID-1: docker0 state: down mac: <filter> 
Drives:    Local Storage: total: 476.94 GiB used: 58.43 GiB (12.3%) 
           ID-1: /dev/nvme0n1 vendor: Toshiba model: KXG50ZNV512G NVMe 512GB size: 476.94 GiB block size: physical: 512 B 
           logical: 512 B speed: 31.6 Gb/s lanes: 4 serial: <filter> rev: AADA4101 scheme: GPT 
Partition: ID-1: / raw size: 40.00 GiB size: 39.12 GiB (97.81%) used: 11.67 GiB (29.8%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /home raw size: 436.65 GiB size: 428.79 GiB (98.20%) used: 46.76 GiB (10.9%) fs: ext4 dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 46.5 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 218 Uptime: 2h 33m Memory: 15.39 GiB used: 3.72 GiB (24.2%) Init: systemd v: 242 Compilers: gcc: 9.1.0 
           Shell: fish v: 3.0.2 running in: fish inxi: 3.0.35 

ls -la /etc/X11/xorg.conf.d/ ; cat /etc/X11/xorg.conf.d/*.conf
Doesn't exist

pacman -Qs xf86-input

local/xf86-input-libinput 0.28.2-1 (xorg-drivers)
    Generic input driver for the X.Org server based on libinput

In case you're wondering I just installed Arch to see if its the same as on Manjaro. When I was using Deepin this particular entry wasn't there but appears on KDE. Not sure why there are two entries of Touchpad on a clean install:

Device:           SynPS/2 Synaptics TouchPad
Kernel:           /dev/input/event18
Group:            15
Seat:             seat0, default
Size:             70x50mm
Capabilities:     pointer gesture
Tap-to-click:     disabled
Tap-and-drag:     enabled
Tap drag lock:    disabled
Left-handed:      disabled
Nat.scrolling:    disabled
Middle emulation: disabled
Calibration:      n/a
Scroll methods:   *two-finger edge 
Click methods:    *button-areas clickfinger 
Disable-w-typing: enabled
Accel profiles:   none
Rotation:         n/a

post output of ls -laR /etc/X11

if you want to stick with libinput as a driver for touchpad i found that adding acpi_osi=! to kernel parameters gets rid of the second entry. though on your particular laptop you can try this one instead or even both
acpi_rev_override=1
or
acpi_osi=! acpi_rev_override=1

but unless you plan on using something like lininput gestures, the synaptic driver will likely work better. either way seems to get rid of the double entry of touchpad in settings.

if you want to give the synaptics driver a try,

sudo pacman -S xf86-input-synaptics

then create this file
sudo nano /etc/X11/xorg.conf.d/50-touchpad.conf

copy/paste this content

#synaptics/elan touchpad

Section "InputClass"
   Identifier "touchpad"
   Driver  "synaptics"
   MatchIsTouchpad  "on"
   Option      "VertScrollDelta" "-200"
   Option      "HorizScrollDelta" "-200"
#   Option      "MinSpeed"  "1"
#   Option      "MaxSpeed"  "1.5"
   Option      "Protocol"  "event"
   Option      "HorizHysteresis"  "0"
   Option      "VertHysteresis"   "0"
   Option      "PalmDetect"       "1"
   Option      "PalmMinZ"         "150"
   Option      "GrabEventDevice"  "1"
EndSection

save/exit/reboot. thats my current setup i found works best for me, you may need to change a few values to fit your preference.

since your currently on arch, im not sure if the package names match but on manjaro thats how they go.

ls -laR /etc/X11

/etc/X11:
total 16
drwxr-xr-x  4 root root 4096 Aug 11 20:35 ./
drwxr-xr-x 77 root root 4096 Aug 12 10:14 ../
drwxr-xr-x  3 root root 4096 Aug 11 20:13 xinit/
drwxr-xr-x  2 root root 4096 Jun 30 12:52 xorg.conf.d/

/etc/X11/xinit:
total 12
drwxr-xr-x 3 root root 4096 Aug 11 20:13 ./
drwxr-xr-x 4 root root 4096 Aug 11 20:35 ../
drwxr-xr-x 2 root root 4096 Aug 11 20:48 xinitrc.d/

/etc/X11/xinit/xinitrc.d:
total 16
drwxr-xr-x 2 root root 4096 Aug 11 20:48 ./
drwxr-xr-x 3 root root 4096 Aug 11 20:13 ../
-rwxr-xr-x 1 root root  318 Nov 10  2018 40-libcanberra-gtk-module.sh*
-rwxr-xr-x 1 root root  203 Jul 20 22:55 50-systemd-user.sh*

/etc/X11/xorg.conf.d:
total 8
drwxr-xr-x 2 root root 4096 Jun 30 12:52 ./
drwxr-xr-x 4 root root 4096 Aug 11 20:35 ../

I tried the kernel parameters you suggested and they only result on it being stuck to the Synaptics touchpad even after log off/log on like I am usually forced to do, as opposed to what I want the libinput touchpad driver installed. I'm not sure if its detecting the touch screen as a secondary touch device.

I added this script (touchpad.sh and changed to exec) to my .config/autostart-scripts:

#! /bin/bash

# disable Synaptics touchpad

device="SynPS/2 Synaptics TouchPad"

xinput --disable "$device"

Finally fixed the issue permanently by going to Startup and Shutdown > Autostart and selecting Run On = Before session startup. This disables the Synaptics touchpad before Plasma starts and now everything works perfectly on reboots. Adding a pic to show how it should look when configured if anyone else faces this issue.

1 Like